LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-15-2004, 12:03 PM   #1
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Rep: Reputation: 30
Upgrading to KDE 3.3


Hi, i am running SuSE 9.1 Professional and i want to upgrade to KDE 3.3, since there are soo many options to download, binary, packages, source code, i get lost in what to do..

What do i get exactly for upgrading, rather than installing fresh
 
Old 10-15-2004, 12:07 PM   #2
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
ok, i get to the

ftp://mirrors.midco.net/pub/kde/stab...SuSE/ix86/9.1/

and all i see is a bunch of rpms... do i install each and every one?

is there a fast way to isntall them?
 
Old 10-15-2004, 12:11 PM   #3
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
rpm -Uvh *.rpm
 
Old 10-15-2004, 12:12 PM   #4
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
so im guessing i download each and everyone correct?
 
Old 10-15-2004, 12:14 PM   #5
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
how would i downlaod them all quickly, i hate clicking on individual links
 
Old 10-15-2004, 12:40 PM   #6
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
hmm when i type that rpm command in i get

user379:/home/mark/downloads/KDE # rpm -Uvh *.rpm
error: Failed dependencies:
glib2-devel is needed by arts-devel-1.3.1-3
libruby.so.1.8 is needed by kdebindings3-ruby-3.3.1-3
povray is needed by kdegraphics3-3D-3.3.1-3
ocrad is needed by kdegraphics3-scan-3.3.1-3
tetex is needed by kdegraphics3-tex-3.3.1-3
cvs is needed by kdesdk3-3.3.1-3
valgrind >= 1.9.6 is needed by kdesdk3-profile-3.3.1-3
cvs is needed by kdevelop3-3.1.1-3
graphviz is needed by kdevelop3-3.1.1-3
doxygen is needed by kdevelop3-3.1.1-3
docbook-toys is needed by kdevelop3-3.1.1-3
html-dtd is needed by kdevelop3-3.1.1-3
tidy is needed by kdewebdev3-3.3.0-7
user379:/home/mark/downloads/KDE #
 
Old 10-15-2004, 12:59 PM   #7
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
hmm ok i'm downloading all the depedancies but i can't find

cvs is needed by kdesdk3-3.3.1-3

and some of the packages(like 2 or 3) were *.noarch*

is that fine even if i use suse?
 
Old 10-15-2004, 03:03 PM   #8
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Rep: Reputation: 15
Hello

I was browsing the suse download section, they have KDE 3.3 packages avaliable to download for 9.1 now. There are still quite a bit of packages to download but it is more organized than the link you posted. Perhaps it will help.

http://www.suse.co.uk/uk/private/dow...uks/index.html


good luck

Last edited by yiang; 10-15-2004 at 03:05 PM.
 
Old 10-17-2004, 12:02 PM   #9
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
hmm,, ok heres my new problem, when i try and install them look what i get

ark@user379:~/downloads/KDE> ls
arts-gmcop.rpm kdebase3-kdm.rpm kdebase3-samba.rpm qt3.rpm
arts.rpm kdebase3-ksysguardd.rpm kdelibs3-doc.rpm taglib.rpm
kde3-i18n-en_GB.rpm kdebase3-nsplugin.rpm kdelibs3.rpm
kdebase3-extra.rpm kdebase3.rpm libart_lgpl.rpm
mark@user379:~/downloads/KDE> rpm -Uvh *.rpm
error: Failed dependencies:
arts = 1.2.1 is needed by (installed) arts-devel-1.2.1-35.4
kdelibs3 = 3.2.1 is needed by (installed) kdelibs3-devel-3.2.1-44.28
qt3 = 3.3.1 is needed by (installed) qt3-devel-3.3.1-33
mark@user379:~/downloads/KDE>



also when i try to install them one at a time i get like 50 conflicts

i tried installing through my user and root
 
Old 10-17-2004, 02:31 PM   #10
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Rep: Reputation: 15
Have you tried just installing the rpms through YAST instead of konsole? I installed KDE 3.3 through yast the other day and had no problems other than for some dependencies which i found through this linuxforum thread - http://www.groupsrv.com/linux/viewtopic.php?p=89984. You might run into these as well:

ftp://ftp.univie.ac.at/systems/linux....7-28.i586.rpm
ftp://ftp.univie.ac.at/systems/linux....0-71.i586.rpm
ftp://ftp.univie.ac.at/systems/linux...0-1.5.i586.rpm
ftp://ftp.univie.ac.at/systems/linux...-38.4.i586.rpm
 
Old 10-17-2004, 03:03 PM   #11
minm
Member
 
Registered: Jun 2003
Location: Canada
Distribution: suse 9.2
Posts: 582

Original Poster
Rep: Reputation: 30
ya i tried but if iwant to do it one at a time it gives me errors such as i have to uninstall most of my kde programs..
is that normal?
 
Old 10-17-2004, 03:18 PM   #12
yiang
LQ Newbie
 
Registered: Sep 2004
Location: US, California
Distribution: Fedora Core 2/Redhat 9/knoppix 3.6/Linare 2.0/Mandrake 10.1/Linspire 4.5/SuSE 9.1
Posts: 26

Rep: Reputation: 15
Does the error say something like

needs libjack.so.0
resolve confict by
.... uninstall prog
....

something like that right?

It just means you have to install say 'libjack.so.0' first. The errors will eventually go away once you have installed the other rpms needed first. I had the same problem. Obviously don't uninstall the progs to resolve the conflicts. Just note the needed dependency and cancel out and install those first. Install the base packages but save the kdelibs3 and kdebase3 for last.

For the dependencies errors you might run into like libsndfile, libjack, libjasper, libaspell, just follow the links I posted previously. The install will work.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrading KDE rohr Debian 5 05-13-2005 02:35 PM
upgrading to KDE 3.3.1 vegpl SUSE / openSUSE 3 11-24-2004 01:21 AM
Upgrading the KDE JIV Linux - Software 3 02-11-2004 10:57 PM
upgrading kde mmc Mandriva 1 11-03-2003 12:41 PM
Upgrading KDE 2.2.2 to 3.1.4 subnet Debian 9 10-08-2003 06:59 AM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration