LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2012, 02:29 PM   #1
ggalan
Member
 
Registered: Oct 2010
Posts: 57

Rep: Reputation: 0
upgrade mysql


can anyone lend a hand please
i am trying to upgrade mysql by
Code:
sudo mysql_upgrade -h <whatgoeshere> -u mysqlUser -p mysqlPass
is this how you do it? also what do i place in the <whatgoeshere> area?

Last edited by ggalan; 04-04-2012 at 04:17 PM.
 
Old 04-04-2012, 03:31 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
Are you trying to upgrade your mysql installation, or trying to upgrade your mysql tables to the currently installed version of mysql?

If you want to upgrade the mysql installation, use your distros package management tools to upgrade mysql.
 
Old 04-04-2012, 03:38 PM   #3
ggalan
Member
 
Registered: Oct 2010
Posts: 57

Original Poster
Rep: Reputation: 0
im a newb : )
i have mysql 5.1.52
want to upgrade to 5.5 because of sql queries

from your question, where would that fall under?
also how would i "use your distros package management tools"

also, i am on LAMP ec2 basic linux

Last edited by ggalan; 04-04-2012 at 03:48 PM.
 
Old 04-04-2012, 03:59 PM   #4
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by ggalan View Post
im a newb : )
i have mysql 5.1.52
want to upgrade to 5.5 because of sql queries

.......
also, i am on LAMP ec2 basic linux
If you want MySQL 5.5 then you are

Quote:
Originally Posted by bigrigdriver View Post
Are you trying to upgrade your mysql installation.
....
Your distro seems to me like Amazon EC2 cloud, which I searched on google, and it's running REDHat.

So you upgrade it from command line:
Code:
yum search-update mysql

and if succesful, then

yum update mysql
as root user.

But I believe that RedHat won't be choosing latest versions of packages, because of possible bugs etc.
so your upgrade is pointing to fail.

good luck

Last edited by lithos; 04-04-2012 at 04:01 PM.
 
Old 04-04-2012, 04:06 PM   #5
ggalan
Member
 
Registered: Oct 2010
Posts: 57

Original Poster
Rep: Reputation: 0
thank you
Quote:
sudo yum update mysql
did it but as you said i am still on 5.1
is 5.5 beta?
 
Old 04-04-2012, 04:13 PM   #6
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
No,

it's not beta, latest community release is "5.5.22"

But RedHat has not confirmed / integrated the packages into the Repositories for installing it, so until then you're out of luck I guess.
It's RedHat's policy you have to comply if you're using it.

You can, ALTHOUGH, use a not approved by RedHat method install 5.5.11
also you can take a look here - MySQL 5.5 Available on Oracle Linux 6 and RHEL 6.

Last edited by lithos; 04-04-2012 at 04:16 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] What is the best way to upgrade from mysql-5.0.77-4.el5_4.2 to MySQL 5.1.47 ursusca Linux - Software 2 06-08-2010 01:47 PM
Upgrade to MySQL-5.0.18 breaks PHP mysql functions MarkVickers Slackware 5 05-03-2006 01:10 AM
php-mysql dependancy problem after nitemare mysql upgrade. RHEL4 andrewc Red Hat 1 01-03-2006 05:16 PM
mysql 4.0.24 to mysql 4.1.12 upgrade problem tuxrules Slackware 7 08-13-2005 07:43 PM
mySQL Upgrade from 3.23 to 4.0 SForsgren Linux - Software 6 12-29-2003 05:11 AM


All times are GMT -5. The time now is 04:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration