LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-01-2010, 02:24 PM   #1
ilvista
Member
 
Registered: Nov 2010
Location: Ghazaouet
Distribution: Fedora OpenSuse
Posts: 150

Rep: Reputation: 21
updating php


hi
I want to update php on my server
Code:
[root@d199 ~]# rpm -qa | grep php
php-common-5.2.6-2.fc8
php-pdo-5.2.6-2.fc8
php-xml-5.2.6-2.fc8
php-mbstring-5.2.6-2.fc8
psa-php5-configurator-1.4.0-fc8.build86080722.00
php5-ioncube-loader-3.2-08011510
php-gd-5.2.6-2.fc8
php-5.2.6-2.fc8
php-mysql-5.2.6-2.fc8
php-cli-5.2.6-2.fc8
php-imap-5.2.6-2.fc8
[root@d199 ~]#
I'm running
Code:
[root@d199 ~]#  /bin/rpm -qf /etc/*-release
fedora-release-8-6.transition
fedora-release-8-6.transition
fedora-release-8-6.transition
[root@d199 ~]#

and the kernel Linux 2.6.26.8-57.fc8
 
Old 12-01-2010, 03:16 PM   #2
jwl17330536
Member
 
Registered: Feb 2010
Location: Raleigh, NC
Posts: 83

Rep: Reputation: 22
Good luck to you. I wish you the best. Is there a question?
 
Old 12-01-2010, 03:46 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Fedora 8 is old, and it is unsupported since January 2009.
No more updates.

# 'rpmbuild -bb php.spec' can build new php packages from an SRC RPM.
Example with a Fedora 11 source src.rpm :
http://www.linuxquestions.org/questi...-0-a-764323/#3
..
 
Old 12-01-2010, 03:50 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by ilvista View Post
hi
I want to update php on my server
Code:
[root@d199 ~]# rpm -qa | grep php
php-common-5.2.6-2.fc8
php-pdo-5.2.6-2.fc8
php-xml-5.2.6-2.fc8
php-mbstring-5.2.6-2.fc8
psa-php5-configurator-1.4.0-fc8.build86080722.00
php5-ioncube-loader-3.2-08011510
php-gd-5.2.6-2.fc8
php-5.2.6-2.fc8
php-mysql-5.2.6-2.fc8
php-cli-5.2.6-2.fc8
php-imap-5.2.6-2.fc8
[root@d199 ~]#
I'm running
Code:
[root@d199 ~]#  /bin/rpm -qf /etc/*-release
fedora-release-8-6.transition
fedora-release-8-6.transition
fedora-release-8-6.transition
[root@d199 ~]#

and the kernel Linux 2.6.26.8-57.fc8
Instead of updating just PHP you need to update the whole OS.
You're six versions behind.


Cheers,
Tink
 
Old 12-02-2010, 09:34 AM   #5
ilvista
Member
 
Registered: Nov 2010
Location: Ghazaouet
Distribution: Fedora OpenSuse
Posts: 150

Original Poster
Rep: Reputation: 21
yes it's pretty old,i tried to update it but I'm getting a bunch of dependencies errors

Code:
[root@d199 tmp]# rpm -i kernel-2.6.35.6-45.fc14.x86_64.rpm
warning: kernel-2.6.35.6-45.fc14.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 97a1071f
error: Failed dependencies:
        grubby >= 7.0.10-1 is needed by kernel-2.6.35.6-45.fc14.x86_64
        dracut >= 001-7 is needed by kernel-2.6.35.6-45.fc14.x86_64
        linux-firmware >= 20100806-2 is needed by kernel-2.6.35.6-45.fc14.x86_64
        rpmlib(FileDigests) <= 4.6.0-1 is needed by kernel-2.6.35.6-45.fc14.x86_64
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by kernel-2.6.35.6-45.fc14.x86_64
[root@d199 tmp]#
and it got more complicated when i downloaded and tried to install the grubby RPM,other dependencies are required.

is there any better way to solve the dependecies.
and is it right that i can update directly from fedora 8 to 14 ?without going through the 9 kernel 10 ......14.
 
Old 12-02-2010, 11:21 AM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
It's not just about getting the kernel updated; you need the
whole hog. Download a recent CD/DVD image, burn that, and tackle
it from there. Chances are you're in for a re-install, though,
as the version gap is so large.
 
Old 12-03-2010, 03:46 AM   #7
ilvista
Member
 
Registered: Nov 2010
Location: Ghazaouet
Distribution: Fedora OpenSuse
Posts: 150

Original Poster
Rep: Reputation: 21
Thumbs up

i dont have the physical access ,it's a hosting server somewhere in switzeland.i'll try to use Yum to update at least the kernel .
thx .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
updating mysql php peterb Linux - Software 2 01-31-2010 02:41 AM
Updating Fedora 7 with PHP 5.2.8 Blade13 Fedora 2 01-22-2009 06:26 PM
Updating PHP in Mandrake 9.1 alienmagic Mandriva 1 02-28-2006 07:58 PM
problem in updating in PHP mohtasham1983 Programming 3 01-06-2006 05:14 PM
Updating php 4.3.1 from tar and keeping current php configuration with mandrake 9.1 mrjeep Linux - General 0 04-02-2003 08:50 AM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration