LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2011, 06:09 PM   #1
santiagobasulto
LQ Newbie
 
Registered: May 2011
Posts: 3

Rep: Reputation: 0
Updating packages in debian


Hello people. I'm trying to install mysql server 5.1 (or newer) in a debian server.

The problem is that "apt-get install mysql-server" try to install mysql-server-5.0.

I've updated the packages, but that package remains.

If I try to issue "apt-get install mysql-server-5.1" it says that other packages are in confict.

How can i update it?

Thanks!
 
Old 05-13-2011, 06:28 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
What version Debian are you using? Have you enabled any backports repositories?

The packages mysql-server-5.1 conflicts with are probably all mysql-server-5.0 related, which only makes sense. But you didn't post the messages you received so I can't really say.
 
Old 05-13-2011, 06:34 PM   #3
santiagobasulto
LQ Newbie
 
Registered: May 2011
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for your answer AlucardZero!

Debian Version: 5.0.8

This is what happens when try to install mysql-server-5.1 (translation aside)


Los siguientes paquetes tienen dependencias incumplidas: (These packages has dependency unaccomplished)
mysql-server-5.1: Depende (depends on: mysql-client-5.1 (>= 5.1.49-3~bpo50+1) pero no va a instalarse
Depende: libmysqlclient16 (>= 5.1.21-1) pero no va a instalarse
PreDepende: mysql-common (>= 5.1.49-3~bpo50+1) pero 5.0.51a-24+lenny5 va a ser instalado
E: Paquetes rotos (broken packages)
 
Old 05-13-2011, 06:45 PM   #4
santiagobasulto
LQ Newbie
 
Registered: May 2011
Posts: 3

Original Poster
Rep: Reputation: 0
I just did it.

Added dotdeb package at /etc/apt/sources.list:

Quote:
deb http://packages.dotdeb.org lenny all
Quote:
gpg --keyserver keys.gnupg.net --recv-key 89DF5277
gpg -a --export 89DF5277 | sudo apt-key add -
Quote:
apt-get update
 
Old 05-13-2011, 09:30 PM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Try using Lenny backports before using packages from dotdeb.

http://packages.debian.org/search?ke...searchon=names
lenny-backports (database): MySQL database server (metapackage depending on the latest version)
5.1.49-3~bpo50+1 [backports]: all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating packages from redhat - insatlling *.hdr packages jomy Linux - Networking 1 01-18-2005 09:36 AM
updating packages tommytomato Linux - General 6 09-01-2004 05:31 PM
Updating Packages PDAOmega Linux - Newbie 3 07-21-2004 07:31 PM
Updating packages Kroenecker Linux From Scratch 2 07-05-2004 12:57 PM
updating packages jogurt666 Debian 2 01-10-2004 02:11 PM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration