LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-04-2004, 07:11 PM   #1
Boudewijn
Member
 
Registered: Nov 2003
Location: The Netherlands
Distribution: MDK: 10,10.1,10_amd64,9.2,9.1 . Debian: sarge,woody, Gentoo (X86 amd64 Sparc)
Posts: 219

Rep: Reputation: 30
Updating library links


Hi,


Just wanted to compile GAIM, on mdk10, and it told me to get GTK2.4 (or something like it). So I got is (source), and libgt, pango and atk.

Compiled it all, and then did 'ldconfig' (als ldconfig /usr/lib) . GTK.org says in some cases that's necessary. Then I tried to recompile GAIM; it kept on asking about GTK (yeah, I compiled a newer one than necessary).

What do I forget? (i think some symlink is still pointing at the old GTK)

Last edited by Boudewijn; 11-04-2004 at 07:13 PM.
 
Old 11-04-2004, 10:22 PM   #2
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
try /sbin/ldconfig
 
Old 11-05-2004, 07:15 PM   #3
Boudewijn
Member
 
Registered: Nov 2003
Location: The Netherlands
Distribution: MDK: 10,10.1,10_amd64,9.2,9.1 . Debian: sarge,woody, Gentoo (X86 amd64 Sparc)
Posts: 219

Original Poster
Rep: Reputation: 30
doesn't work either

extra info:

when installling gtk+ i did:

./configure
make
make install

afaik this is enough, correct me if i'm wrong
 
Old 11-08-2004, 03:57 PM   #4
Boudewijn
Member
 
Registered: Nov 2003
Location: The Netherlands
Distribution: MDK: 10,10.1,10_amd64,9.2,9.1 . Debian: sarge,woody, Gentoo (X86 amd64 Sparc)
Posts: 219

Original Poster
Rep: Reputation: 30
I just tried to start gaim:


[boudewijn@zeus boudewijn]$ gaim: relocation error: /usr/lib/libgobject-2.0.so.0: undefined symbol: g_bsearch_array_new


This is 0.7.8 , but the new firefox faces the same problem......

After replacing thee symlinks with the original ones, it all worked fine. Is the new glib not backward compatible?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
links (hard links and soft links..) sachitha Programming 1 08-10-2005 01:10 PM
library symbolic links removed after rpm install aymanos Linux - Distributions 4 01-03-2005 04:39 PM
updating shared library links jamaso Slackware 1 06-20-2004 11:25 AM
Updating Shared Library Links dawizman Slackware 7 04-27-2004 12:02 PM
Prevent updating shared library links melinda_sayang Slackware 1 02-26-2004 01:20 PM


All times are GMT -5. The time now is 04:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration