LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2004, 12:38 AM   #1
toships
Member
 
Registered: Feb 2004
Posts: 30

Rep: Reputation: 15
updating glib


Story so far,
I had unziped (prob I should say untared) the downloaded files in
/usr/src/glib-2.2.3/
I had then installed glib from there.


./configure
make
make check (all 29 test pass here)
make install
--------------------------------
Libraries have been installed in:
/usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
- add LIBDIR to the `LD_LIBRARY_PATH' environment variable
during execution
- add LIBDIR to the `LD_RUN_PATH' environment variable
during linking
- use the `-Wl,--rpath -Wl,LIBDIR' linker flag
- have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------

/usr/local/lib previously added in ld.so.conf
did "ldconfig" again
"./configure" for atk
---------------------
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the
error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable
PKG_CONFIG_PATH
*** to point to the correct configuration files
no configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.
--------------------------

In our case the pkg-config is correct. How do I remove the old glib and
get the new one linked to all the programs ?

Please help. Thanks in advance.
 
Old 02-26-2004, 08:55 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
sounds a lot like you are running an rpm based distro and installing from source for no particular reason. if you do wish to sue source, use the rpm command to remove older versions first.
 
Old 02-26-2004, 09:05 AM   #3
toships
Member
 
Registered: Feb 2004
Posts: 30

Original Poster
Rep: Reputation: 15
I tried to remove rpm but it has a lot of dependencies.
 
Old 02-26-2004, 11:10 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well upgrade the rpm instead of trying to compile the source....
 
Old 02-28-2004, 07:51 PM   #5
toships
Member
 
Registered: Feb 2004
Posts: 30

Original Poster
Rep: Reputation: 15
thanx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
updating GLib..or pango...or gtk+ or etc etc nadroj Linux - Software 7 01-16-2005 02:54 AM
help with updating glib and gtk mrford Linux - Software 0 09-13-2004 07:33 PM
Updating gLib and GTK Darksun Linux - Software 1 04-24-2004 05:49 PM
Updating glib slurride Slackware 1 02-23-2003 12:28 AM


All times are GMT -5. The time now is 08:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration