LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-11-2005, 09:27 AM   #1
rfw62
LQ Newbie
 
Registered: May 2005
Posts: 23

Rep: Reputation: 15
updating Gentoo


i'm trying to update my gentoo and whn i run....emerge --update world...i get this message.....

Linux ~ # emerge --update world
Calculating world dependencies ...done!

!!! Error: the media-libs/libungif package conflicts
with another package.
!!! both can't be installed on the same system
together.
!!! Please use 'emerge --pretend' to determine
blockers.

Linux ~ # emerge --pretend --update world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B ] media-libs/libungif (is blocking
media-libs/giflib-4.1.4)
[ebuild U ] sys-apps/man-pages-2.11 [2.09]
[ebuild U ] x11-libs/gtk+-2.6.10 [2.6.7]
[ebuild U ] dev-libs/libxml2-2.6.22 [2.6.19]
[ebuild U ] x11-misc/xscreensaver-4.22-r4
[4.22-r2]
[ebuild U ] app-admin/syslog-ng-1.6.8-r1 [1.6.8]
[ebuild U ] net-misc/wget-1.10.2 [1.9.1-r5]
[ebuild NS ] sys-kernel/gentoo-sources-2.6.13-r5
[ebuild U ] x11-wm/fluxbox-0.9.14-r1 [0.9.13-r1]
[ebuild U ] gnome-base/libgnomecanvas-2.10.2
[2.10.0]
[ebuild U ] dev-libs/libIDL-0.8.6 [0.8.5]
[ebuild U ] gnome-base/orbit-2.12.3 [2.12.2]
[ebuild U ] dev-util/intltool-0.34.1 [0.33]
[ebuild U ] gnome-base/libbonobo-2.10.1 [2.8.1]
[ebuild U ] media-sound/esound-0.2.36-r1 [0.2.34]
[ebuild U ] gnome-base/gconf-2.10.1-r1 [2.10.0]
[ebuild U ] app-arch/bzip2-1.0.3-r5 [1.0.3-r4]
[ebuild U ] gnome-base/gnome-vfs-2.10.1-r2
[2.10.1-r1]
[ebuild U ] gnome-base/libgnome-2.10.1-r1 [2.10.0]
[ebuild U ] gnome-base/libbonoboui-2.10.1 [2.8.1]
[ebuild U ] gnome-base/gnome-keyring-0.4.4 [0.4.2]
[ebuild U ] gnome-base/libgnomeui-2.10.1 [2.10.0]
[ebuild U ] x11-themes/hicolor-icon-theme-0.8
[0.5]
[ebuild U ] x11-themes/gnome-icon-theme-2.10.1
[2.10.0]
[ebuild U ] x11-themes/gtk-engines-2.6.5 [2.6.3]
[ebuild U ] x11-themes/gnome-themes-2.10.2
[2.10.0]
[ebuild U ] app-arch/unzip-5.52 [5.50-r2]
[ebuild NS ] app-text/docbook-sgml-dtd-4.1-r3
[ebuild NS ] app-text/docbook-sgml-dtd-4.0-r3
[ebuild U ]
app-text/docbook-dsssl-stylesheets-1.79 [1.77-r2]
[ebuild NS ] app-text/docbook-sgml-dtd-3.0-r3
[ebuild U ] app-text/docbook-sgml-dtd-3.1-r3
[3.1-r2]
[ebuild U ] www-client/lynx-2.8.5-r1 [2.8.5]
[ebuild U ]
app-text/docbook-xml-simple-dtd-4.1.2.4-r2 [4.1.2.4]
[ebuild NS ] app-text/docbook-xml-simple-dtd-1.0-r1
[ebuild U ]
app-text/docbook-xsl-stylesheets-1.68.1-r1 [1.66.1]
[ebuild NS ] app-text/docbook-xml-dtd-4.4
[ebuild U ] app-text/docbook-sgml-utils-0.6.14
[0.6.12]
[ebuild U ] dev-libs/libxslt-1.1.15 [1.1.13-r1]
[ebuild U ] app-text/scrollkeeper-0.3.14-r1
[0.3.14]
[ebuild U ] gnome-base/gnome-desktop-2.10.2
[2.10.1]
[ebuild U ] media-libs/giflib-4.1.4 [4.1.3]
[ebuild U ] x11-wm/icewm-1.2.23 [1.2.21]
[ebuild U ] net-misc/openssh-4.2_p1 [3.9_p1-r3]
[ebuild NS ] gnome-extra/libgtkhtml-2.6.3
[ebuild N ] dev-python/numeric-23.7
[ebuild U ] dev-python/pygtk-2.6.1 [2.4.1]
[ebuild U ] media-gfx/gimp-2.2.8-r1 [2.2.6-r1]
[ebuild U ] net-misc/dhcpcd-2.0.0 [1.3.22_p4-r11]
[ebuild U ] sys-devel/gcc-config-1.3.12-r3
[1.3.12-r2]
[ebuild U ] sys-libs/glibc-2.3.5-r2 [2.3.5-r1]
[ebuild U ] net-misc/ntp-4.2.0.20040617-r3
[4.2.0.20040617-r2]
[ebuild U ] sys-apps/shadow-4.0.7-r4 [4.0.7-r3]
[ebuild U ] gnome-base/gdm-2.8.0.3 [2.6.0.9-r3]
[ebuild U ] sys-apps/util-linux-2.12r [2.12i-r1]
[ebuild U ] sys-fs/udftools-1.0.0b-r5 [1.0.0b-r4]
[ebuild U ] sys-process/psmisc-21.6 [21.5]
[ebuild U ] www-client/mozilla-launcher-1.42
[1.41]
[ebuild U ] www-client/mozilla-firefox-1.0.7-r2
[1.0.6-r2]
[ebuild U ] media-libs/taglib-1.4 [1.3.1]
[ebuild U ] x11-libs/qt-3.3.4-r8 [3.3.4-r3]
[ebuild U ] kde-base/kde-env-3-r4 [3-r3]
[ebuild U ] app-cdr/cdrdao-1.2.0-r1 [1.2.0]
[ebuild N ] media-libs/libsndfile-1.0.11
[ebuild U ] app-cdr/k3b-0.12.4a [0.11.24]
[ebuild U ] sys-devel/m4-1.4.3 [1.4.2-r1]
[ebuild U ] app-portage/gentoolkit-0.2.0-r3
[0.2.0]
[ebuild U ] net-irc/xchat-2.4.5 [2.4.3]

can anyone help me with this???


Thankx
 
Old 11-11-2005, 10:40 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you really should read the user guide for portage at gentoo.org for basic terminology about blocking software, but essentially, just unmerge libungif first, then carry on as normal
 
Old 11-12-2005, 05:06 PM   #3
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
acid_kewpie is, of course, correct. However, a few more details: for most software, libungif is being replaced with giflib. I ran into this problem myself.
Code:
emerge -C libungif && emerge --upgrade world
 
Old 11-12-2005, 05:48 PM   #4
rfw62
LQ Newbie
 
Registered: May 2005
Posts: 23

Original Poster
Rep: Reputation: 15
thankx guys that seemed to wrk but now getting this error:

ERRor: x11-libs/gtk+-2.6.10 failed
Function src_unpack, Line 64, Exitcode

whtz the problem now???
 
Old 11-12-2005, 05:54 PM   #5
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
There was an error during the src_unpack portion of x11-libs/gtk+-2.6.10. That's all we could tell from that message. Post the real error, like it tells you to, and maybe we can tell you more.
 
Old 11-12-2005, 07:47 PM   #6
rfw62
LQ Newbie
 
Registered: May 2005
Posts: 23

Original Poster
Rep: Reputation: 15
here is the full response to my update:

Calculating world dependencies ...done!
>>> emerge (1 of 68) x11-libs/gtk+-2.6.10 to /
>>> md5 files ;-) gtk+-1.2.10-r11.ebuild
>>> md5 files ;-) gtk+-2.6.10.ebuild
>>> md5 files ;-) gtk+-1.2.10-r10.ebuild
>>> md5 files ;-) gtk+-2.6.8.ebuild
>>> md5 files ;-) gtk+-2.8.6.ebuild
>>> md5 files ;-) files/digest-gtk+-2.6.8
>>> md5 files ;-) files/digest-gtk+-2.8.6
>>> md5 files ;-) files/gtk+-2.8.0-multilib.patch
>>> md5 files ;-) files/digest-gtk+-1.2.10-r10
>>> md5 files ;-) files/digest-gtk+-1.2.10-r11
>>> md5 files ;-) files/gtkrc
>>> md5 files ;-) files/gtk+-1.2-locale_fix.patch
>>> md5 files ;-) files/gtk+-1.2.10-m4.patch
>>> md5 files ;-) files/gtk+-2.8.6-freebsd.patch
>>> md5 files ;-) files/digest-gtk+-2.6.10
>>> md5 files ;-) files/gtk+-2.2.1-disable_icons_smooth_alpha.patch
>>> md5 files ;-) files/gtk+-2.4.9-ppc64.patch
>>> md5 src_uri ;-) gtk+-2.6.10.tar.bz2
>>> md5 src_uri ;-) gtk+-2.6-smoothscroll-r5.patch.bz2
>>> Unpacking source...
>>> Unpacking gtk+-2.6.10.tar.bz2 to
/var/tmp/portage/gtk+-2.6.10/work
>>> Unpacking gtk+-2.6-smoothscroll-r5.patch.bz2 to
/var/tmp/portage/gtk+-2.6.10/work
* Applying
gtk+-2.2.1-disable_icons_smooth_alpha.patch ...
[ ok ]
* Applying gtk+-2.6-smoothscroll-r5.patch.bz2 ...
[ ok ]
am-wrapper: /usr/bin/automake-1.7 is missing or not
executable.
Please try emerging the correct version of
automake.

!!! ERROR: x11-libs/gtk+-2.6.10 failed.
!!! Function src_unpack, Line 64, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error,
NOT this status message.
 
Old 11-12-2005, 07:52 PM   #7
rfw62
LQ Newbie
 
Registered: May 2005
Posts: 23

Original Poster
Rep: Reputation: 15
i have automake-1.9 in /usr/bin
 
Old 11-13-2005, 03:47 AM   #8
vmoroz
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by Matir
acid_kewpie is, of course, correct. However, a few more details: for most software, libungif is being replaced with giflib. I ran into this problem myself.
Code:
emerge -C libungif && emerge --upgrade world
... and kuickshow will complain about libungif and emerge kdegraphics will fail for the same reason. Any suggestions?
 
Old 11-13-2005, 11:24 AM   #9
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Using revdep-rebuild fixed any problems I had.
 
Old 11-13-2005, 11:27 AM   #10
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Quote:
Originally posted by rfw62
am-wrapper: /usr/bin/automake-1.7 is missing or not
executable.
Please try emerging the correct version of
automake.

!!! ERROR: x11-libs/gtk+-2.6.10 failed.
!!! Function src_unpack, Line 64, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error,
NOT this status message.
Make sure you have automake-1.7 installed. (specifcially sys-devel/automake-1.7.9-r1)
 
Old 11-18-2005, 06:16 PM   #11
rfw62
LQ Newbie
 
Registered: May 2005
Posts: 23

Original Poster
Rep: Reputation: 15
automake

how do i uninstall version 1.9.6 and install version 1.7????
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo - updating system question (emerge) elitecodex Linux - Distributions 4 04-28-2005 05:54 PM
Portage: Updating individual package and dependencies in Gentoo vharishankar Linux - Distributions 2 03-29-2005 05:26 AM
Some questions about updating portage in Gentoo vharishankar Linux - Distributions 12 03-14-2005 09:26 AM
updating gentoo doralsoral Linux - Software 3 12-31-2004 11:10 AM
updating stuff (gentoo)! bigjohn Linux - Software 4 12-20-2004 03:42 AM


All times are GMT -5. The time now is 03:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration