LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2014, 08:16 AM   #1
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Rep: Reputation: Disabled
Update Manager not working in Linux Mint 16


Hello, just starting this. I'm using Linux Mint 16 Cinnamon, for about 4 days now. Can't get the update manager to work. It says Error in checkAPT.py, could not refresh the list of packages
 
Old 02-13-2014, 11:21 AM   #2
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
The solution can be easily googled.

Last edited by fuorviato; 02-13-2014 at 11:24 AM.
 
Old 02-13-2014, 01:21 PM   #3
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
Yes

Last edited by bumi; 02-13-2014 at 01:31 PM.
 
Old 02-13-2014, 01:24 PM   #4
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
Inc

Last edited by bumi; 02-13-2014 at 01:30 PM.
 
Old 02-13-2014, 02:16 PM   #5
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
Did the solution I gave you solve your problem?
 
Old 02-13-2014, 07:52 PM   #6
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
Not the ones on top. I'm trying to figure which is "the offending file". I'm new to linux, about 4 days, so it's all a bit confusing for me..... I have tried a few things and none of them have worked so far. I'm at the bottom of that page now, trying to find out which file it is....
 
Old 02-14-2014, 11:39 AM   #7
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
The file should be
Quote:
checkAPT.py
. It's a python file. For safety, don't remove it but just move it somewhere else then relaunch update manager.
 
Old 02-14-2014, 01:24 PM   #8
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
don't see it under var/lib/apt/lists
here's what's there
/var/lib/apt/lists/partial/archive.getdeb.net_ubuntu_dists_saucy-getdeb_InRelease.reverify
/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_saucy-updates_Release.gpg.reverify
/var/lib/apt/lists/partial/extra.linuxmint.com_dists_petra_Release.gpg.reverify
/var/lib/apt/lists/partial/packages.linuxmint.com_dists_petra_Release.gpg.reverify
/var/lib/apt/lists/partial/security.ubuntu.com_ubuntu_dists_saucy-security_Release.gpg.reverify
/var/lib/apt/lists/partial/_usr_repo_linuxmint_dists_petra_Release.gpg.reverify
/var/lib/apt/lists/partial/_usr_repo_ubuntu_dists_saucy_Release.gpg.reverify
/var/lib/apt/lists/partial/_usr_repo_ubuntu_dists_saucy-security_Release.gpg.reverify
/var/lib/apt/lists/partial/_usr_repo_ubuntu_dists_saucy-updates_Release.gpg.reverify
/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_saucy_partner_binary-amd64_Packages
/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_saucy_partner_binary-i386_Packages
/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_saucy_Release
/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_saucy_Release.gpg
/var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_saucy-getdeb_apps_binary-amd64_Packages
/var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_saucy-getdeb_apps_binary-i386_Packages
/var/lib/apt/lists/archive.getdeb.net_ubuntu_dists_saucy-getdeb_InRelease
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_main_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_main_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_main_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_multiverse_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_multiverse_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_multiverse_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_Release
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_Release.gpg
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_restricted_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_restricted_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_restricted_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_universe_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_universe_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy_universe_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_main_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_main_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_main_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_multiverse_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_multiverse_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_multiverse_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_Release
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_Release.gpg
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_restricted_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_restricted_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_restricted_i18n_Translation-en
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_universe_binary-amd64_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_universe_binary-i386_Packages
/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_saucy-updates_universe_i18n_Translation-en
/var/lib/apt/lists/extra.linuxmint.com_dists_petra_main_binary-amd64_Packages
/var/lib/apt/lists/extra.linuxmint.com_dists_petra_main_binary-i386_Packages
/var/lib/apt/lists/extra.linuxmint.com_dists_petra_Release
/var/lib/apt/lists/extra.linuxmint.com_dists_petra_Release.gpg
/var/lib/apt/lists/lock
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_import_binary-amd64_Packages
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_import_binary-i386_Packages
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_main_binary-amd64_Packages
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_main_binary-i386_Packages
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_Release
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_Release.gpg
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_upstream_binary-amd64_Packages
/var/lib/apt/lists/packages.linuxmint.com_dists_petra_upstream_binary-i386_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_main_binary-amd64_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_main_binary-i386_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_main_i18n_Translation-en
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_multiverse_binary-amd64_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_multiverse_binary-i386_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_multiverse_i18n_Translation-en
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_Release
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_Release.gpg
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_restricted_binary-amd64_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_restricted_binary-i386_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_restricted_i18n_Translation-en
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_universe_binary-amd64_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_universe_binary-i386_Packages
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_saucy-security_universe_i18n_Translation-en
/var/lib/apt/lists/_usr_repo_linuxmint_dists_petra_import_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_linuxmint_dists_petra_main_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_linuxmint_dists_petra_Release
/var/lib/apt/lists/_usr_repo_linuxmint_dists_petra_Release.gpg
/var/lib/apt/lists/_usr_repo_linuxmint_dists_petra_upstream_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy_main_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy_multiverse_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy_Release
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy_Release.gpg
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy_restricted_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-security_main_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-security_multiverse_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-security_Release
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-security_Release.gpg
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-security_restricted_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-security_universe_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy_universe_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-updates_main_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-updates_multiverse_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-updates_Release
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-updates_Release.gpg
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-updates_restricted_binary-amd64_Packages
/var/lib/apt/lists/_usr_repo_ubuntu_dists_saucy-updates_universe_binary-amd64_Packages
 
Old 02-15-2014, 09:39 AM   #9
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
Does your system have "locate" command? If not, install it and issue:

Quote:
sudo updatedb && locate checkAPT.py
. The output tell you the file location
 
Old 02-16-2014, 11:26 AM   #10
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
I went ahead and moved the checkAPT.py file to another folder. The updater now has a green check instead of a red X, but I don't know if it's actually working. If you open the update manager and try to reload the cache, you get the same error as before. I guess I'll give it a few days and see if it does anything.
 
Old 02-16-2014, 09:03 PM   #11
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
OK, actually if you try to update with the terminal, you still get the error. It does, however, have a green check instead of a red X, whatever that is worth.
 
Old 02-17-2014, 05:36 AM   #12
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
Can you show me what your
Quote:
/etc/apt
dir contains?
 
Old 02-17-2014, 05:46 AM   #13
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
/etc/apt/apt.conf.d
/etc/apt/preferences.d
/etc/apt/sources.list.d
/etc/apt/trusted.gpg.d
/etc/apt/sources.list
/etc/apt/sources.list.orig
/etc/apt/trustdb.gpg
/etc/apt/trusted.gpg
 
Old 02-17-2014, 05:50 AM   #14
fuorviato
Member
 
Registered: Dec 2013
Location: Poland
Distribution: Sabayon/Gentoo 64bit
Posts: 215

Rep: Reputation: 14
Paste this
Quote:
/etc/apt/sources.list
here please.

USE [QUOTE] tags
 
Old 02-17-2014, 01:14 PM   #15
bumi
LQ Newbie
 
Registered: Feb 2014
Location: central illinois
Distribution: linux mint 16
Posts: 23

Original Poster
Rep: Reputation: Disabled
deb file:///usr/repo/linuxmint/ petra main upstream import
deb file:///usr/repo/ubuntu/ saucy main restricted universe multiverse
deb file:///usr/repo/ubuntu/ saucy-updates main restricted universe multiverse
deb file:///usr/repo/ubuntu/ saucy-security main restricted universe multiverse

# deb cdrom:[Linux Mint 16 _petra_ - Release amd64 20131126]/ saucy contrib main non-free
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mint 13: update-manager needs a kick in the ass Doc CPU Linux Mint 3 01-29-2014 02:16 AM
[SOLVED] Error message using update manager mint 13 Dazhann Linux - Newbie 2 01-14-2014 02:36 AM
Mint KDE update manager icon too small pressman57 Linux - Newbie 4 04-28-2013 07:57 PM
LXer: Disable update manager in the notification area in Linux Mint 13 LXer Syndicated Linux News 0 07-29-2012 09:30 PM
[SOLVED] Mint 9 Update Manager problem genogebot Linux - Newbie 5 08-19-2010 04:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration