LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-03-2010, 11:16 AM   #1
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Rep: Reputation: 0
Update error in RH!


Hello,

I'm new to Red hat Linux..I have two RH workstation.
When I run the up2date -u command in my Red hat workstation, Im getting the following error.

Workstation 1:

Testing package set / solving RPM inter-dependencies...
########################################
kernel-2.6.9-89.0.23.EL.x86 ########################## Done.
kernel-devel-2.6.9-89.0.23. ########################## Done.
kernel-largesmp-2.6.9-89.0. ########################## Done.
kernel-smp-2.6.9-89.0.23.EL ########################## Done.
kernel-xenU-2.6.9-89.0.23.E ########################## Done.
Preparing ########################################### [100%]

Installing...
1:kernel-xenU ########################################### [100%]
error: unpacking of archive failed on file /boot/System.map-2.6.9-89.0.23.ELxenU;4bdef4c2: cpio: write
There was a fatal RPM install error. The message was:
There was a rpm unpack error installing the package: kernel-xenU-2.6.9-89.0.23.EL


Workstation 2:

Fetching rpm headers...
########################################

Name Version Rel Arch
----------------------------------------------------------------------------------------
kernel 2.6.9 89.0.23.EL x86_64
kernel-devel 2.6.9 89.0.23.EL x86_64
kernel-largesmp 2.6.9 89.0.23.EL x86_64
kernel-smp 2.6.9 89.0.23.EL x86_64
php 4.3.9 3.29 x86_64


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
php-devel-4.3.9-3.26 requires php = 4.3.9-3.26
php-domxml-4.3.9-3.26 requires php = 4.3.9-3.26
php-gd-4.3.9-3.26 requires php = 4.3.9-3.26
php-imap-4.3.9-3.26 requires php = 4.3.9-3.26
php-ldap-4.3.9-3.26 requires php = 4.3.9-3.26
php-mbstring-4.3.9-3.26 requires php = 4.3.9-3.26
php-mysql-4.3.9-3.26 requires php = 4.3.9-3.26
php-ncurses-4.3.9-3.26 requires php = 4.3.9-3.26
php-odbc-4.3.9-3.26 requires php = 4.3.9-3.26
php-pear-4.3.9-3.26 requires php = 4.3.9-3.26
php-pgsql-4.3.9-3.26 requires php = 4.3.9-3.26
php-snmp-4.3.9-3.26 requires php = 4.3.9-3.26
php-xmlrpc-4.3.9-3.26 requires php = 4.3.9-3.26


The following packages were added to your selection to satisfy dependencies:
Package Required by
----------------------------------------------------------------------------


What should I do to resolve this.

Thanks in advance!!

-Regards,
Rad
 
Old 05-03-2010, 12:02 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
How many different kernels have you got installed at once ?
Just install the one you need and maybe the -devel version for that kernel. You have probably run out of space in /boot.

As for the php issues, don't upgrade php unless you upgrade all the others too.

man up2date

Last edited by smoker; 05-03-2010 at 12:05 PM.
 
Old 05-06-2010, 12:14 PM   #3
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Hello smoker,

Since i'm very new to Linux.. i dint know much about it..
From my under standing, i think redhat leaves the older kernel if at all anything bad happens.
anyhow, according to your advice, i can remove those useless kernels

when i ran uname -s , i got

2.6.9-89.0.7.ELsmp #? SMP Wed Aug 5 14:08:20 2009 x86_64 x86_64 x86_64 GNU/Linux

So,it means smp is used, how can I switch to devel ?

and also when i ran rpm -q kernel, i'm getting the following o/p

kernel-2.6.9-78.0.1.EL
kernel-2.6.9-78.0.5.EL
kernel-2.6.9-78.0.13.EL
kernel-2.6.9-78.0.17.EL
kernel-2.6.9-89.0.3.EL
kernel-2.6.9-89.0.7.EL

but, up2date -u command is giving this,

Testing package set / solving RPM inter-dependencies...
########################################
kernel-2.6.9-89.0.23.EL.x86 ########################## Done.
kernel-devel-2.6.9-89.0.23. ########################## Done.
kernel-largesmp-2.6.9-89.0. ########################## Done.
kernel-smp-2.6.9-89.0.23.EL ########################## Done.
kernel-xenU-2.6.9-89.0.23.E ########################## Done.

why is the latest 2.6.9.89.0.23 is not listed when i ran rpm -q ?

Any help in giving me an insight is really appreciated!!

Thanks
 
Old 05-06-2010, 12:36 PM   #4
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
When you run rpm -q you get a list of the kernels installed.

to remove the useless kernels run rpm -e kernel-xenu kernel-largesmp

the kernel-devel is the development files for the kernel so that if you have to compile anything the files are available, it is not a kernel that runs in its own right.

The latest kernel isn't listed because there was an error installing it, probably due to lack of space in /boot.

remove all the kernels except the one listed in uname command.
If there is an older version of the smp kernel, leave that one too. You only need one good kernel and the latest one. As you are running the smp kernel, get rid of the others.
 
1 members found this post helpful.
Old 05-10-2010, 11:23 AM   #5
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Hello Smoker,
Thanks for the response.. It helped me a lot in fixing the issue!
 
Old 05-28-2010, 03:03 PM   #6
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
Hell0 Smoker,

Sorry to bug u once again..


I got php interdependency error , so u updated php

# up2date -uf php-4.3.9-3.26

Fetching Obsoletes list for channel: rhel-x86_64-ws-4...

Name Version Rel Arch
----------------------------------------------------------------------------------------

All packages are currently up to date

since there are many security update from RHN. i tried updated all the patch released from RHN. but unfortunatly, im getting the same error as i had earlier.




Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
php-devel-4.3.9-3.26 requires php = 4.3.9-3.26
php-domxml-4.3.9-3.26 requires php = 4.3.9-3.26
php-gd-4.3.9-3.26 requires php = 4.3.9-3.26
php-imap-4.3.9-3.26 requires php = 4.3.9-3.26
php-ldap-4.3.9-3.26 requires php = 4.3.9-3.26
php-mbstring-4.3.9-3.26 requires php = 4.3.9-3.26
php-mysql-4.3.9-3.26 requires php = 4.3.9-3.26
php-ncurses-4.3.9-3.26 requires php = 4.3.9-3.26
php-odbc-4.3.9-3.26 requires php = 4.3.9-3.26
php-pear-4.3.9-3.26 requires php = 4.3.9-3.26
php-pgsql-4.3.9-3.26 requires php = 4.3.9-3.26
php-snmp-4.3.9-3.26 requires php = 4.3.9-3.26
php-xmlrpc-4.3.9-3.26 requires php = 4.3.9-3.26


The following packages were added to your selection to satisfy dependencies:
Package Required by
----------------------------------------------------------------------------

So please let me wht to do..
 
Old 05-28-2010, 03:34 PM   #7
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
Have you got php installed at all ?

what does rpm -q php say ?

up2date -u means update the entire system.

To update php only say :

up2date php
 
Old 05-28-2010, 05:31 PM   #8
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
What specific version of RHEL4 are you running? It looks like you are running 4.7 and trying to install 4.8 packages. RH supports all the 4.X versions (last I checked) while Centos only supports the most current(5.5, 4.8, etc). I am not sure how RH handles staying on an older version (say 4.7) and yet maintains support. It COULD be that there is something necessary for the updated php that 4.8 has that 4.7 does not.
 
Old 06-04-2010, 10:03 AM   #9
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
@smoker..
Sorry for late reply... Thanks for the reply,.. these are the results of the two command...
rpm -q php
php-4.3.9-3.26


up2date php

Fetching Obsoletes list for channel: rhel-x86_64-ws-4...

Fetching rpm headers...
########################################

Name Version Rel Arch
----------------------------------------------------------------------------------------
php 4.3.9 3.29 x86_64


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
php-devel-4.3.9-3.26 requires php = 4.3.9-3.26
php-domxml-4.3.9-3.26 requires php = 4.3.9-3.26
php-gd-4.3.9-3.26 requires php = 4.3.9-3.26
php-imap-4.3.9-3.26 requires php = 4.3.9-3.26
php-ldap-4.3.9-3.26 requires php = 4.3.9-3.26
php-mbstring-4.3.9-3.26 requires php = 4.3.9-3.26
php-mysql-4.3.9-3.26 requires php = 4.3.9-3.26
php-ncurses-4.3.9-3.26 requires php = 4.3.9-3.26
php-odbc-4.3.9-3.26 requires php = 4.3.9-3.26
php-pear-4.3.9-3.26 requires php = 4.3.9-3.26
php-pgsql-4.3.9-3.26 requires php = 4.3.9-3.26
php-snmp-4.3.9-3.26 requires php = 4.3.9-3.26
php-xmlrpc-4.3.9-3.26 requires php = 4.3.9-3.26


The following packages were added to your selection to satisfy dependencies:
Package Required by
----------------------------------------------------------------------------

so, what should I do ?
 
Old 06-04-2010, 10:05 AM   #10
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
@lazlow ..

Thanks doode!!

cat /etc/redhat-release

Red Hat Enterprise Linux WS release 4 (Nahant Update 8)

Last edited by rponnu2; 06-04-2010 at 10:07 AM.
 
Old 06-04-2010, 11:41 AM   #11
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
It looks like you need to update all the things mentioned in that list at the same time as php.

i.e.

Code:
yum update php php-devel php-domxml php-gd php-imap php-ldap php-mbstring php-mysql php-ncurses php-odbc php-pear php-pgsql php-snmp php-xmlrpc
All on one line of course.
 
Old 06-07-2010, 10:53 AM   #12
rponnu2
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
@smoker..
I'm still getting the same error message
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get update error gnophear Debian 4 01-27-2009 12:18 AM
Error during update to 7.10 Flash19 Ubuntu 4 11-08-2007 10:08 PM
Update error, probably nothing but stuck! mattjohnstone22 Linux - Newbie 1 03-26-2007 03:45 PM
Update error kaplis Linux - Software 2 07-13-2006 11:20 AM
Auto Update Error after update WL7JA SUSE / openSUSE 2 10-12-2005 12:36 PM


All times are GMT -5. The time now is 08:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration