LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2005, 03:27 PM   #1
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Rep: Reputation: 15
unsuccesfull with ATI :-(


Hello

Im new in Linux.

I have tried to install my ATI driver without luck.
I have for about 2weeks ago installed them with succes but now its all just BEEP!

I have downloaded the latest xorg version version at www.ati.com

My Hardware is

9800pro 128mb.

System:

Mandriva 2005 LE

When i type fglrxinfo i get the followring message:

[root@localhost ~]# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

Seems like my Ati driver isnt getting loaded

Here is a copy of my xorg.conf file

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "glx"
Load "dri"
# Load "extmod" but omit DGA extension
# (the DGA extension is broken in the fglrx driver)
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "dk"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Philips 190B"
HorizSync 30-83
VertRefresh 56-76

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "ATI"
Driver "fglrx" # this is the important bit

# If X refuses to use the screen resolution you asked for,
# uncomment this; see "Bugs and Workarounds" for details.
#Option "NoDDC"

# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "off"
# === Use internal AGP GART support? ===
# If OpenGL acceleration doesn't work, try using "yes" here
# and disable the kernel agpgart driver.
Option "UseInternalAGPGART" "no"
EndSection

Section "Screen"
Identifier "screen1"
Device "ATI"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
 
Old 10-12-2005, 04:54 PM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 2,981

Rep: Reputation: 509Reputation: 509Reputation: 509Reputation: 509Reputation: 509Reputation: 509
The ati linux drivers are not fully functional, and many times broken. Pleading with ati has done nothing, but to get them to say, "just be glad we write linux drivers at all." For that reason I will not use ati products. See entries with trailing asterisks. Leave out the asterisks. Make changes.

Section "Module"
Load "glx"
Load "dri"
Load "fglrx"***********************
# Load "extmod" but omit DGA extension
# (the DGA extension is broken in the fglrx driver)
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "off"**************************
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "on"*****************
# === Use internal AGP GART support? ===
# If OpenGL acceleration doesn't work, try using "yes" here
# and disable the kernel agpgart driver.
Option "UseInternalAGPGART" "no"##(you might also want to change this to yes)**************
EndSection

See how that works for you. Come back and tell us if it does.
 
Old 10-13-2005, 09:03 AM   #3
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Original Poster
Rep: Reputation: 15
No luck!

My new xorg.conf file


Section "Module"
Load "glx"
Load "dri"
Load "fglrx"
# Load "extmod" but omit DGA extension
# (the DGA extension is broken in the fglrx driver)
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "dk"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Philips 190B"
HorizSync 30-83
VertRefresh 56-76

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "ATI"
Driver "fglrx" # this is the important bit

# If X refuses to use the screen resolution you asked for,
# uncomment this; see "Bugs and Workarounds" for details.
#Option "NoDDC"

# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "off"
# === OpenGL Overlay ===
# Note: When OpenGL Overlay is enabled, Video Overlay
# will be disabled automatically
Option "OpenGLOverlay" "on"
# === Use internal AGP GART support? ===
# If OpenGL acceleration doesn't work, try using "yes" here
# and disable the kernel agpgart driver.
Option "UseInternalAGPGART" "no"
EndSection

Section "Screen"
Identifier "screen1"
Device "ATI"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection


What i dont get is that I 2 weeks ago had them installed on the same system with no problems at all!
 
Old 10-13-2005, 09:25 AM   #4
Ephracis
Senior Member
 
Registered: Sep 2004
Location: Sweden
Distribution: Ubuntu, Debian
Posts: 1,109

Rep: Reputation: 49
I fought with the drivers for a 9800 Pro card before and I found some binary that came with the package, it was some kind of configuration program, don't know what it was called, though. But after a bunch of problems getting its dependencies to work I finally ran it. It asked me some questions and then it configured the driver in the xorg config file and so on. After that it said that I was running on the driver and so on.

My problem was that I did not see any better performance at all, it was still the same experience as when running on the default vesa driver. So I bought a Nvidia card, it works great.
 
Old 10-13-2005, 10:52 AM   #5
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Original Poster
Rep: Reputation: 15
2weeks ago it worked with 5-6000fps with glxgears instead of 200fps that i have now.

I have played Half life 2 and quake 3 without problems.

It gotta be possible again!!
 
Old 10-13-2005, 11:37 AM   #6
ioerror
Member
 
Registered: Sep 2005
Location: Old Blighty
Distribution: Slackware, NetBSD
Posts: 536

Rep: Reputation: 30
Have you installed a new kernel?

If so, you need to recompile the fglrx kernel module.

cd /lib/modules/fglrx/build (something like this, might be a different subdir)
./build.sh
cd ..
./install.sh (I think it's called something different, install_whatever.sh)

Something like that, can't remember exactly. I'll check when I get home.

Use lsmod to ensure the fglrx module is being loaded. Check /var/log/Xorg.0.log to make sure that DRI is being initialized correctly.

I've had big (e.g. reboot every 10 mins) stability problems with Nvidia cards, so I bought a Radeon. Works great.
 
Old 10-13-2005, 12:15 PM   #7
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Original Poster
Rep: Reputation: 15
#ioerror

No havent installed a new kernel.

But!

It worked!!!


So there was a log file?? didnt know that but i do now.

Now i only have 1 warning

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset RADEON 9800 PRO (R350 4E48) found

But i pretty sure that ive had a higher framerate last time.
I think about 5-6000fps.

Now i have about 4500fps. Or maybe im wrong.

But a big thanks to all of you!!
 
Old 10-13-2005, 01:01 PM   #8
ioerror
Member
 
Registered: Sep 2005
Location: Old Blighty
Distribution: Slackware, NetBSD
Posts: 536

Rep: Reputation: 30
I think I also get ~4500-4800 with my 9800 Pro (athlon xp 2800, nforce2 mobo).
Then again, UT2004 is a better indication of 3d performance than glxgears.

You can ignore that warning about BusID PCI:1:0:1. That's just the secondary head, which you won't be using unless you have a dual-head setup.
 
Old 10-13-2005, 01:20 PM   #9
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Dual head setup ?

Does that include Tv out?

I have a problem with my tv out.

The screen is pretty big om my Tv. Liked it is zoomed...

I would like to have it in 800x600 if possible.

Is it?
 
Old 10-13-2005, 02:27 PM   #10
ioerror
Member
 
Registered: Sep 2005
Location: Old Blighty
Distribution: Slackware, NetBSD
Posts: 536

Rep: Reputation: 30
Never used tv out. You don't seem to be using dual-head (as the secondary head is unused, and your xorg.conf is setup for single head) I assume you use the monitor and then switch to tv out when you want to. Or are you using both at once?

You say it's zoomed, do you mean the desktop is larger than the screen and you can scroll around? This is caused by the (stupid) virtual desktop that X uses. The screen (root window) will have a resolution of the largest size you specify in you conf file (you seem to be using 1280x1024). If you switch to a smaller resolution, you get a virtual desktop (the desktop is still 1280x1024 but of course, the tv screen is only 768x576, so you have to scroll around to see it all).

I'm not quite sure how that works. How do you switch to using tv out and back?
 
Old 10-13-2005, 04:04 PM   #11
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Hmm you are probaly right.

I have got it to work now but not as i want.
My desktop on my tv is still 1280*1024 but my resolution on my tv is now 1024*768.
So if i change to 1024*768 on my primary monitor i will all fit.
But that looks terrible on my LCD monitor

I believe if i wanna see a movie on my Tv i have to change resolution on my monitor so the picture will
fit my tv.
 
Old 10-13-2005, 04:32 PM   #12
ioerror
Member
 
Registered: Sep 2005
Location: Old Blighty
Distribution: Slackware, NetBSD
Posts: 536

Rep: Reputation: 30
Hmm, if you don't mind restarting X whenever you want to watch a movie, you could always use different config file, one for 1280x1024, one for 800x600 or whatever.

Or you could set up a proper dual-head but that would place part of you desktop on the tv and presumably you don't have the tv on all the time. So that isn't likely to be a good solution.

Then again, you could always run two Xservers, and use Ctrl-Alt-F7 and Ctrl-Alt-F8 (or whatever) to switch between them. Your current setup will be you main server and you could create a second xorg.conf will a res of 800x600 and start a second X server, using the -config option to specify the second conf file.
 
Old 10-13-2005, 11:56 PM   #13
Helskov
Member
 
Registered: Jan 2005
Location: Denmark
Distribution: PclinuxOS 2007
Posts: 47

Original Poster
Rep: Reputation: 15
Sounds nice!

How to i then choose between 2 xorg.config files when starting up a new Xserver?
 
Old 10-14-2005, 12:18 PM   #14
Ray_Kovecses
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 66

Rep: Reputation: 15
alot of the time the ati drivers from there site dont set up the kernel module. this is very easy to do though.

first


in the term type



updatedb

then

locate fglrx

you are gonna see a file called BUILD_MOD or something like that

you change into that directory and type .... make

then you follow the instructions it gives you and works
 
Old 10-14-2005, 07:36 PM   #15
Thulemanden
Member
 
Registered: Sep 2003
Location: Copenhagen, Denmark
Distribution: PC-BSD, PCLOS, MeeGo, Win 7
Posts: 189

Rep: Reputation: 30
fglrx

Quote:
Originally posted by Ray_Kovecses
locate fglrx

you are gonna see a file called BUILD_MOD or something like that

you change into that directory and type .... make

then you follow the instructions it gives you and works [/B]
Actually uou get lots of dirs:

lib/modules/2.4.29/misc/fglrx.o
/lib/modules/2.6.10/misc/fglrx.ko
/usr/share/doc/fglrx-kernel-2.4.29
/usr/share/doc/fglrx-kernel-2.4.29/changelog.Debian.gz
/usr/share/doc/fglrx-kernel-2.4.29/copyright
/usr/share/doc/fglrx-kernel-2.6.10
/usr/share/doc/fglrx-kernel-2.6.10/changelog.Debian.gz
/usr/share/doc/fglrx-kernel-2.6.10/copyright
/usr/X11R6/include/X11/extensions/fglrx_gamma.h
/usr/X11R6/lib/libfglrx_gamma.a
/usr/X11R6/lib/libfglrx_gamma.so.1
/usr/X11R6/lib/libfglrx_gamma.so.1.0
/var/cache/apt/archives/fglrx-kernel-2.4.29_8.10.19-1+MEPIS.3.3_i386.deb
/var/cache/apt/archives/fglrx-kernel-2.6.10_8.10.19-1+MEPIS.3.3_i386.deb
/var/lib/dpkg/info/fglrx-4.3.0-kernel-2.6.7.list
/var/lib/dpkg/info/fglrx-4.3.0-kernel-2.6.7.postrm
/var/lib/dpkg/info/fglrx-kernel-2.4.29.list
/var/lib/dpkg/info/fglrx-kernel-2.4.29.md5sums
/var/lib/dpkg/info/fglrx-kernel-2.4.29.postinst
/var/lib/dpkg/info/fglrx-kernel-2.4.29.postrm
/var/lib/dpkg/info/fglrx-kernel-2.6.10.list
/var/lib/dpkg/info/fglrx-kernel-2.6.10.md5sums
/var/lib/dpkg/info/fglrx-kernel-2.6.10.postinst
/var/lib/dpkg/info/fglrx-kernel-2.6.10.postrm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9600Pro & ATI Proprietary Drivers problem Hyakutake Slackware 6 12-04-2005 10:08 AM
Ati driver a bit unstable but no different than nvidia..ati benchmark inside. spade Slackware 1 10-06-2004 12:13 AM
ATI 9600se running slower than older ATI card w/ DRI on euth665667 Linux - Hardware 0 07-03-2004 06:10 AM
SuSE 9.1 - ATI Mobility 9600 (M10) - ATi Drivers 3.9.0 Beaviis Linux - Hardware 3 06-04-2004 12:51 PM
ati 8500ve - ati Radeon 8500 ve - suse 9.0 pro linuxgamer Linux - Hardware 0 11-30-2003 05:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration