LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2004, 06:00 AM   #1
amea
LQ Newbie
 
Registered: Jan 2004
Posts: 1

Rep: Reputation: 0
unresolved symbol gameport_register_port


Hi, I have integrated sound card:

#lspci
..
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 50)
..

I have installed newest alsa on my Slackware, but when I try to modprobe module for my sound card using alsa driver I have some errors:

----------------------------------------------------------------------------------
# modprobe snd-via82xx
/lib/modules/2.4.24/kernel/sound/pci/snd-via82xx.o.gz: unresolved symbol gameport_register_port
/lib/modules/2.4.24/kernel/sound/pci/snd-via82xx.o.gz: unresolved symbol gameport_unregister_port
/lib/modules/2.4.24/kernel/sound/pci/snd-via82xx.o.gz: insmod /lib/modules/2.4.24/kernel/sound/pci/snd-via82xx.o.gz failed
/lib/modules/2.4.24/kernel/sound/pci/snd-via82xx.o.gz: insmod snd-via82xx failed
----------------------------------------------------------------------------------

maybe I should change some option in my kernel .config and recompile kernel?
How to solve this problem?
 
Old 04-15-2004, 04:16 AM   #2
phase9
Member
 
Registered: Mar 2004
Location: austria, vienna
Distribution: slackware-10.2
Posts: 89

Rep: Reputation: 15
Hi

I just compiled the kernel-2.4.26 and recompiled+installed the alsa-driver.
Now I get the same error message.

Maybe someone has solved this problem yet?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unresolved symbol haddon Linux - Hardware 3 03-11-2005 03:24 PM
Unresolved symbol? Elonch Programming 2 03-02-2005 12:48 AM
Unresolved symbol: xtime_lock stuartx Linux - General 0 10-27-2004 03:05 PM
modprobe unresolved symbol DJSpaceMouse Linux - Software 3 08-08-2003 03:55 PM
SB Audigy Unresolved Symbol Metal Linux - Hardware 2 10-16-2002 08:05 AM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration