LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-29-2003, 05:24 PM   #1
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Rep: Reputation: 30
Unresolved Mplayer problems


I can not fix my Mplayer using Red Hat 9.0.
Everything is ok with Slackware.
I just used .src.rpm files.
[root@localhost src-rpm]# rpmbuild --rebuild mplayer-0.90-1.src.rpm mplayer-skin-2.0-2.src.rpm

at the beginning it starts with a warning repeated several times

Warning user dominik does not exist - using root

then it starts to compile for few minutes and it finishes with
...
...
...
...
Requires: libdha.so.0.1
Processing files: mplayer-vidix-radeon-0.90-1
Provides: mplayer-vidix-driver radeon_vid.so
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libdha.so.0.1 libm.so.6
Processing files: mplayer-vidix-rage128-0.90-1
Provides: mplayer-vidix-driver rage128_vid.so
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libdha.so.0.1
Processing files: mplayer-debuginfo-0.90-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/mplayer-0.90-root
error: Installed (but unpackaged) file(s) found:
/usr/share/mplayer/fonts/osd/gen_osd_h.c


RPM build errors:
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
user dominik does not exist - using root
Installed (but unpackaged) file(s) found:
/usr/share/mplayer/fonts/osd/gen_osd_h.c
[root@localhost src-rpm]#


yesterday i tried with tar.gz2 files but i can not run gmplayer.
I installed using
./configure --enable-gui
make
makeinstall
and this is what happens when i try to run gmplayer
[root@localhost MPlayer-0.90]# gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).

Please help me.
 
Old 09-29-2003, 06:27 PM   #2
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
mplayer is running perfectly, if you use mplayer /path/to/video it will work, what you do not have, is any sort of skin for gmplayer, download a skin and read the directions as to how to add it to mplayer
 
Old 09-30-2003, 02:44 AM   #3
darrenp
Member
 
Registered: Sep 2003
Location: Lancaster, UK
Distribution: Mandrake
Posts: 46

Rep: Reputation: 15
Not sure about the rpm problems, but as for the problem with the compiled gmplayer...

Have you got some skins installed in /usr/local/share/mplayer/Skins

or more to the point have you got a skin called default under that directory?

If you don't want to use the default skin, then you will need to edit the configure file ~/.mplayer/gui.conf (instuctions should be with the source you compiled)

Also, you might want to get the win32 codecs from the mplayer web site and install them and the codecs.conf file so you can play things like .wmv's, .mov's, etc.
 
Old 09-30-2003, 02:52 AM   #4
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
hate to jump in but
mplayer i have won't play vob file
says it doesnt know what they are

which codec do i need for that
( trying to play a DVD btw )
 
Old 09-30-2003, 05:16 AM   #5
darrenp
Member
 
Registered: Sep 2003
Location: Lancaster, UK
Distribution: Mandrake
Posts: 46

Rep: Reputation: 15
To play encrypted DVD's (ie most films) you need to crack the encryption key. This is done with decss. There is a section in the mplayer documentation on how to play DVD's:

http://www.mplayerhq.hu/DOCS/en/cd-dvd.html

This is naughty!
 
Old 09-30-2003, 08:43 PM   #6
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
doc's said the libdvdtoolkit was included
not on mine tho

I as well have the .90 version
tried the .91 version but it was .i386.rpm
mplayer whined bout my processor not being slow enough
said to recompile with --no-cpu-dectection or something like that
but don't quite understand how to recompile an non source rpm
with the rpmbuild --recompile command

oh yea got the .92 version , but its .i386.rpm too
probably whine again
I'm gonna try it tho
 
Old 10-01-2003, 06:10 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
get the REAL version of mplayer, and it WILL contain their libmpdvdkit (no such thing as libdvdtoolkit) to play dvd's without ANY additional configuration
 
Old 10-01-2003, 06:24 AM   #8
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
hello kewpie
I am corrected by you again
I was under the impression I was getting the reall deal whan I followed the links on the mplayer site to the rpms

I assume that was incorrect
 
Old 10-02-2003, 08:44 AM   #9
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
I installed many skins, but i don't know what to write when i edit the file .conf.
 
Old 10-02-2003, 12:40 PM   #10
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
can't you choose the skin in the GUI ?
 
Old 10-02-2003, 03:49 PM   #11
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
No, the Gui doesn't start.
I put the skins in /root/.mplayer/skin and usr/local/...../skin, but i am not sure about what i have done. The skins are .rpm and i installed them with rpm -ivh. Have i to edit some file?
I am going mad.
 
Old 10-02-2003, 06:56 PM   #12
ehdwuld
Member
 
Registered: Jul 2003
Distribution: Currently Suse 11.1 but have RH7,8,9 / Fedora 7,8_64,9_64,&10_64
Posts: 634

Rep: Reputation: 30
ok well you compiled part of it and rpm'd part eh?

well I would suggest since the mplayer is /compled

get the tar for the skins or at least the one default skin

and rpm -e mplayer-skin-default


mine was installed with the rpms

ftp://linux.inrialpes.fr/linux/freshrpms/redhat/9

you got the

mplayer-codecs-win32-1.1-1
mplayer-codecs-win32-dmo-9.0-1
mplayer-codecs-win32-indeo-1.1-1
mplayer-codecs-win32-mjpeg2k-1.0-2
mplayer-codecs-win32-qt-6.0-1
mplayer-codecs-win32-qt-extras-1.1-1
mplayer-common-0.90-1
mplayer-gui-0.90-1

rite


look at the link above
get

heck get everything that starts libdvd

they are all rpm's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer/Mplayer-plugin problems Buffbannana049 Fedora 3 07-12-2005 11:22 PM
XFree problems: atimisc_drv.o is unresolved! cmack Linux - Hardware 3 02-17-2004 12:15 AM
Problems installing ALSA - unresolved symbols Abdul Linux - Software 1 01-19-2004 08:49 PM
massive dep/unresolved symbols problems SLaCk_KiD Slackware 1 07-18-2003 02:42 PM
unresolved vsftpd problems liv-n-letliv Linux - Networking 0 06-21-2003 04:05 AM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration