LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-24-2010, 01:41 AM   #1
gangadher
LQ Newbie
 
Registered: Aug 2010
Posts: 3

Rep: Reputation: 0
Unreadable characters in error messages and man page output


Hi,

The problem goes this way,

The error messages displayed by commands(ls, bash etc) and man page output
contain unreadable characters. I tried Ctrl+l, stty sane but that didn't work.
Say I execute cmd "ganga" which is not a linux cmd. I should get error saying "ganga:No such cmd" but I get something like this
"ganga some unreadable message)"


This is what I got when i ran "man grep"


名称
grep, egrep, fgrep, zgrep - パターンにマッチする行を表示する

書式
ggrreepp [_o_p_t_i_o_n_s] _P_A_T_T_E_R_N [_F_I_L_E...]
ggrreepp [_o_p_t_i_o_n_s] [--ee _P_A_T_T_E_R_N | --ff _F_I_L_E]
and soon

Please someone helpme
 
Old 08-24-2010, 02:41 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
It looks like your system is set up with a Japanese language environment. Run the command "locale" and show us what you get.

Also tell us your distribution, the desktop environment you're using, and any other information you think we might find useful about your setup.

Finally, please use [code]...[/code] tags when you need to post any pre-formatted output.
 
Old 08-24-2010, 05:30 AM   #3
gangadher
LQ Newbie
 
Registered: Aug 2010
Posts: 3

Original Poster
Rep: Reputation: 0
I actually study in college. We access our linux accounts(only console no GUI) over putty software

This is what I could gather from uname

Distribution: Linux 2.6.18 x86_64

output of locale
<locale>

LANG=ja_JP.UTF-8
LC_CTYPE="ja_JP.UTF-8"
LC_NUMERIC="ja_JP.UTF-8"
LC_TIME="ja_JP.UTF-8"
LC_COLLATE="ja_JP.UTF-8"
LC_MONETARY="ja_JP.UTF-8"
LC_MESSAGES="ja_JP.UTF-8"
LC_PAPER="ja_JP.UTF-8"
LC_NAME="ja_JP.UTF-8"
LC_ADDRESS="ja_JP.UTF-8"
LC_TELEPHONE="ja_JP.UTF-8"
LC_MEASUREMENT="ja_JP.UTF-8"
LC_IDENTIFICATION="ja_JP.UTF-8"
LC_ALL=

</locale>

LC_ALL had no value
 
Old 08-24-2010, 06:17 AM   #4
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
You don't say where you're from, so assuming you're in the US, try
Code:
export LC_ALL=en_US.UTF-8
 
Old 08-24-2010, 07:06 AM   #5
gangadher
LQ Newbie
 
Registered: Aug 2010
Posts: 3

Original Poster
Rep: Reputation: 0
I am from Bangalore,India


The above statement( export LC_ALL=en_US.UTF-8 ) worked.
Now I get proper error messages in english.

Ex: $hld //hld is not a linux cmd
bash: hld: command not found //expected error message
$

But man pages are still cluttered. Unlike earlier where I had unreadable characters now I have question marks

Ex $man grep
GREP(1)

??
grep, egrep, fgrep, zgrep - ????????????????

??
grep [options] PATTERN [FILE...]
grep [options] [-e PATTERN | -f FILE] [FILE...]

??
grep ?? FILE ??????????????? (????????????
?? file ???? - ?????????????) ???????????
PATTERN ???????????????????????????? grep
??????????????

and soon.

Thanks a lot David and Andrew.
I can now see error messages in english.
I am not bothered about man pages as I can get them from web.


Thanks once again.
 
Old 08-24-2010, 07:42 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,139
Blog Entries: 52

Rep: Reputation: Disabled
I don't whether this applies to your distro, but in Slackware if you want to use unicode, you have to run unicode_start, it's a script in /usr/bin. Then select a unicode font. Don't know if that would solve your problem.
 
Old 08-24-2010, 07:46 AM   #7
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
@ BrianL - I've never heard of that script - and never used it.. Hmm.. Does that need/want to be run at startup each time, or does it just run once and "do something" that sticks?

Thanks,

Sasha
 
Old 08-24-2010, 07:49 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,139
Blog Entries: 52

Rep: Reputation: Disabled
Run once. Got the procedure from here:
http://slackwiki.org/Utf-8_linux_console
 
1 members found this post helpful.
Old 08-24-2010, 08:49 AM   #9
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,563
Blog Entries: 29

Rep: Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179Reputation: 1179
Quote:
Originally Posted by GrapefruiTgirl View Post
@ BrianL - I've never heard of that script - and never used it.. Hmm.. Does that need/want to be run at startup each time, or does it just run once and "do something" that sticks?
Perhaps it is run during installation if you answer Yes to the "UTF-8 text console" prompt (which defaults to No).
 
Old 08-24-2010, 08:58 AM   #10
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,139
Blog Entries: 52

Rep: Reputation: Disabled
You can edit lilo.conf:
Change:
Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
To:
Code:
# Append any additional kernel parameters:
append=" vt.default_utf8=1"
I've done it on my desktop, but not my laptop (yet).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Strange output from man page Fedora 12 madsovenielsen Linux - Newbie 5 03-31-2010 07:55 AM
strange characters when routing man page to txt file DJOtaku Linux - General 3 05-15-2005 02:03 AM
man pages unreadable in current AxeZ Slackware 7 12-25-2004 11:52 AM
man page with weird characters? falconxlc Linux - General 1 12-07-2002 11:17 PM
Apache install page has unreadable characters nuzzy Linux - Networking 0 09-19-2001 04:25 PM


All times are GMT -5. The time now is 08:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration