LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-04-2004, 09:09 PM   #1
soupface
LQ Newbie
 
Registered: Apr 2004
Location: Canada
Distribution: Gentoo, Ubuntu, Foresight
Posts: 10

Rep: Reputation: 0
Unmountable Floppy? (Gentoo, Dell i8200) [Solved]


Recently bootstrapped Gentoo 2004.2 on my Dell Inspiron 8200 (Pentium 4 m 1.6Ghz...). I have yet to get X.org up: trying to take things a step at a time.

Firstly: I can mount my CD-ROM (read only) without a hitch, but can't mount my floppy drive.

The only floppy-like thing in /dev is /dev/fd, which points to /proc/self/fd. I've tried mounting it (mount /dev/fd /mnt/floppy), but mount claims it's not a block device.

I've no pressing need for a floppy drive (these days, who does?), but it'd be nice to get it working. Any suggestions? Am I over looking something?

Secondly: Is there any reason why I shouldn't have my CD and floppy drives automatically mounted? In other words: what benefits come from the noauto option in fstab for these drives?

Thanks, in advance.

Last edited by soupface; 10-05-2004 at 12:35 PM.
 
Old 10-04-2004, 10:17 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,310

Rep: Reputation: 139Reputation: 139
There should be a /dev/fd0 for your floppy drive. If it's absent, my best guess would be a problem with your kernel configuration, but that's just a guess. I haven't compiled a kernel from scratch in a while but there may be something in there that you have to enable for your floppy to work.
Re your fstab entries for your cd drives - unless you intend to have a cd in your drive at all times you should use the noauto option. The drive isn't mounted; the media in the drive are mounted. If you leave out the noauto option on a cd drive and have no mountable cd in the drive when you boot, it will probably hang up trying to mount the nonexistent media in your cd drive. The noauto option tells the system to not try and mount the cd drive and is commonly used with any device that has removable media like cd drives and floppies.
 
Old 10-05-2004, 11:19 AM   #3
soupface
LQ Newbie
 
Registered: Apr 2004
Location: Canada
Distribution: Gentoo, Ubuntu, Foresight
Posts: 10

Original Poster
Rep: Reputation: 0
It could well be a kernel configuration issue, but I'm not sure what option I missed/added that would cause it not to recognize the floppy drive.

My kernel configuration includes the line CONFIG_BLK_DEV_FD=y, but is not set for CONFIG_BLK_DEV_IDEFLOPPY. Do I need to recompile the kernel with this option set to y? (This option is modularized in this example kernel config.)
 
Old 10-05-2004, 11:39 AM   #4
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
what's your /etc/fstab look like?
 
Old 10-05-2004, 11:50 AM   #5
soupface
LQ Newbie
 
Registered: Apr 2004
Location: Canada
Distribution: Gentoo, Ubuntu, Foresight
Posts: 10

Original Poster
Rep: Reputation: 0
Well, the relevant section of my fstab looks like so:
Code:
/dev/cdroms/cdrom0  /mnt/cdrom  auto  noauto,user  0 0
#/dev/fd  /mnt/floppy  auto  noauto,user  0 0
I commented out the floppy drive part because, well, it doesn't work.

I've also just finished re-compiling my kernel, with the CONFIG_BLK_DEV_IDEFLOPPY=y: no luck. There's only /dev/fd -> /proc/self/fd and that won't mount.
 
Old 10-05-2004, 11:52 AM   #6
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
--------------
quote: "Do I need to recompile the kernel with this option set to y?"
----------------
hi there,

is this a usb-fd or build-in ?
and i would recompile it with that option. just to try...

egag

edit: ok..your fast...

Last edited by egag; 10-05-2004 at 11:53 AM.
 
Old 10-05-2004, 12:08 PM   #7
soupface
LQ Newbie
 
Registered: Apr 2004
Location: Canada
Distribution: Gentoo, Ubuntu, Foresight
Posts: 10

Original Poster
Rep: Reputation: 0
According to the Gentoo forums, there's a bug in the 2.6.8-r3 kernel that causes floppydrives not to be recognized. A Thread there describes a solution (adding floppy=no_acpi to your GRUB configuration) that circumvents the kernel bug.

It works for me.

I have another question: how do you apply code patches (specifically, how could I apply the code patch given at the end of the floppydrive thread)?
 
Old 10-05-2004, 01:23 PM   #8
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
you could go ahead and create : mkdir /dev/fd0 and then add this to your fstab. should work for the floppy. not sure about the kernel error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian testing (sarge) - wireless on dell i8200 laptop steve1401 Linux - Wireless Networking 1 07-08-2004 02:48 AM
Gentoo on a floppy? phekno Linux - General 1 11-06-2003 03:25 PM
Extra buttons on i8200 fettouhi Linux - Newbie 0 10-18-2003 01:59 AM
redhat 7.2 and dell I8200 video twitch_83 Linux - Newbie 1 11-07-2002 01:38 AM
can't mount floppy on dell cpi 366 wietze Linux - General 2 09-19-2001 02:48 PM


All times are GMT -5. The time now is 01:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration