LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-10-2008, 09:07 PM   #1
lumix
Member
 
Registered: Mar 2007
Distribution: Hardy (Gnome on Ubuntu 8.04) on Compaq N600c laptop
Posts: 323

Rep: Reputation: 30
unmet dependencies


If only the following were a helpful message, I might not have to pester other folks for answers:

Quote:
The following packages have unmet dependencies:
mplayer: Depends: libfaac0 (>= 1.26) but it is not installable
Depends: liblame0 (>= 3.97) but it is not installable
Depends: libx264-57 (>= 1:0.svn20071224) but it is not installable
Depends: libxvidcore4 (>= 1:1.0.0-0.0) but it is not installable
Depends: mplayer-skins but it is not installable
E: Broken packages
ubuntu@ubuntu:~$
 
Old 06-10-2008, 09:43 PM   #2
eggixyz
Member
 
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey There,

This is still a huge pain in the behind, but if you check out the Synaptic GUI front-end to apt, you can select Edit and then "fix broken packages" from the menu.

The reason I consider it a pain is that you may have to fix multiple collections of packages before you find the one that may actually contain one that's really broken.

I wish it were easier. If it is, anyone else???? I would love to not have to deal with this either. It seems to happen automatically in Easy Ubuntu, which seems backward to me

Best wishes,

Mike
 
Old 06-10-2008, 10:04 PM   #3
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Is that a fresh install or one that has recently been upgraded? I am under the impression that you either have incompatible repositories (possibly because of an upgrade) or one or more are missing. All of those packages should be in the repositories that are enabled by default. I am kind of suspicious when I see that one missing package is a "svn" version, i.e. a development version. Check your System > Admin > Software sources and make sure that all items on the first tab are selected (except source) as well as the first two of the third tab.

Last edited by jay73; 06-10-2008 at 10:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unmet dependencies. maikie Debian 7 09-04-2007 05:30 PM
unmet dependencies Josephus Ross Linux - General 10 08-21-2007 12:49 PM
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 10:06 PM
unmet dependencies kpachopoulos Debian 3 11-23-2005 10:35 AM
...packages have unmet dependencies? stribas Linux - Newbie 1 09-29-2004 09:55 AM


All times are GMT -5. The time now is 05:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration