LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2003, 01:00 AM   #1
jrwu
LQ Newbie
 
Registered: Jun 2003
Location: Vancouver/Toronto
Distribution: Redhat 9
Posts: 15

Rep: Reputation: 0
Unlocatable package?


I'm trying to install mplayer so I run ./configure --enable-gui
It gives me an error which says I need GTK.
So I try to add them via Add/Remove Applications on the GUI but while it's calculating package dependencies, it gives me an error saying
package not found.
It can't find gtkhtml = 1.1.8-5 which is required by gtkhtml-dev.
I do a simple locate for gtkhtml and find that I have a whole bunch of gtkhtml-1.1.9 directories so I'm assuming I have a newer version that the OS doesn't know about. What now?
How do I fix this so that I can install GTK, which is needed for mplayer?
I have RH9 btw.
 
Old 06-16-2003, 01:06 AM   #2
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
run the following and post results.
Code:
rpm -qa | grep gtk
You may need to remove the newer version, or install 1.1.9 versions of all gtk packages.

If you get no return on the previous command, then your rpm database might be corrupt.
 
Old 06-16-2003, 01:11 AM   #3
jrwu
LQ Newbie
 
Registered: Jun 2003
Location: Vancouver/Toronto
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
This is what I get:

usermode-gtk-1.67-2
gtk2-engines-2.2.0-2
gtk+-1.2.10-25
gtkhtml2-2.2.0-5
pygtk2-1.99.14-4
pygtk2-libglade-1.99.14-4
gtk-engines-0.11-16
mtr-gtk-0.52-2
gtkhtml-1.1.9-0.9
gtk2-2.2.1-4
gnome-python2-gtkhtml2-1.99.14-5
authconfig-gtk-4.3.4-1
gtkam-0.1.7-3
 
Old 06-16-2003, 01:19 AM   #4
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
It looks like a version mis-match to me.

You currently have gtkhtml version 1.1.9-0.9 and you are trying to install gtkhtml-dev version 1.1.8-5.

I would therefore assume that you are trying to install gtk version 1.1.8-5.

As I stated in my first post, you may need to uninstall gtkhtml (version 1.1.9-0.9) or download and install version 1.1.9-0.9 of gtk and gtkhtml-dev.
 
Old 06-16-2003, 01:31 AM   #5
jrwu
LQ Newbie
 
Registered: Jun 2003
Location: Vancouver/Toronto
Distribution: Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks, I'll try a reinstall.

On a side note, I was trying to rebuild my rpm db and got an error:

error: db4 error(16) from dbenv->remove: Device or resource busy
 
Old 06-16-2003, 03:52 AM   #6
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
you don't need the mplayer gui. it works better without it.
 
Old 06-16-2003, 04:00 AM   #7
footfrisbee
Member
 
Registered: Apr 2003
Distribution: Debian Sarge
Posts: 259

Rep: Reputation: 30
The GTK mplayer needs is the developmental header files. The package name will be something like libgtk2.0-dev. But you should listen to whansard. You don't really need the gui.
 
Old 07-25-2003, 04:33 PM   #8
MacKtheHacK
Member
 
Registered: Jul 2003
Location: Boston, MA, USA
Distribution: RedHat, SuSE, Gentoo, Slackware, Mandrake ...
Posts: 111

Rep: Reputation: 15
Re: Unlocatable package?

I just ran into this same problem, and found this thread while looking into it. It seems that RPM has a bad interaction with the RedHat Network's automatic update. Here's what happened:

We had both installed RH9 without all the development library packages. This included gtkhtml-1.1.8-5. At some point, RedHat posted an upgrade, and put gtkhtml-1.1.9-0.9 and gtkhtml-devel-1.1.9-0.9 on their updates FTP server. When our machines did an update, they only got gtkhtml-1.1.9-0.9, but not the development package, because it wasn't installed. Later on, we tried to install the development library packages from the CDs, and it failed because the new gtkhtml was there and the gtkhtml-devel-1.1.8-5 package requires that specific version of gtkhtml.

The fix is install the old gtkhtml package off your CD, with a command like:
rpm -U --oldpackage gtkhtml-1.1.8-5.i386.rpm

Then installing the development library packages from the CDs will work. After that, you can run the RHN update again to get both gtkhtml and gtkhtml-devel updated to the 1.1.9-0.9 versions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unlocatable installed packages (FC3) LloydM Fedora 8 05-27-2005 05:15 AM
message "Problem during installation: x package needed for (installed) x package frayed2 Linux - Newbie 1 04-24-2005 08:05 PM
Unlocatable package natbrazil Red Hat 2 07-10-2004 06:31 PM
Unlocatable Package Error jetfanroy Linux - Newbie 3 06-20-2003 01:59 PM
Unlocatable unzipped file KDE4me Linux - Newbie 5 04-30-2003 09:30 AM


All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration