LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unknown symbols in modules... (http://www.linuxquestions.org/questions/linux-newbie-8/unknown-symbols-in-modules-693032/)

shariefbe 12-26-2008 04:02 AM

Unknown symbols in modules...
 
Hello...when i try to insert "ehci-hcd" with insmod i am getting this error


root@sharief-desktop:/home/sharief/Desktop/drivers/host# insmod ehci-hcd.ko
insmod: error inserting 'ehci-hcd.ko': -1 Unknown symbol in modul
e


output of "dmesg" is :


[ 196.416023] ehci_hcd: Unknown symbol usb_hcd_pci_suspend
[ 196.416023] ehci_hcd: Unknown symbol usb_free_urb
[ 196.416023] ehci_hcd: Unknown symbol usb_hub_tt_clear_buffer
[ 196.416023] ehci_hcd: Unknown symbol usb_hcd_resume_root_hub
[ 196.416023] ehci_hcd: Unknown symbol usb_hcd_pci_probe
[ 196.416023] ehci_hcd: Unknown symbol usb_hcd_unlink_urb_from_ep
[ 196.428074] ehci_hcd: Unknown symbol usb_hcd_check_unlink_urb
[ 196.428406] ehci_hcd: Unknown symbol usb_calc_bus_time
[ 196.428582] ehci_hcd: Unknown symbol ehci_cf_port_reset_rwsem
[ 196.428761] ehci_hcd: Unknown symbol usb_hcd_pci_shutdown
[ 196.428977] ehci_hcd: Unknown symbol usb_hcd_link_urb_to_ep
[ 196.429151] ehci_hcd: Unknown symbol usb_hcd_pci_resume
[ 196.429340] ehci_hcd: Unknown symbol usb_get_urb
[ 196.429527] ehci_hcd: Unknown symbol usb_hcd_giveback_urb
[ 196.429733] ehci_hcd: Unknown symbol usb_hcd_poll_rh_status
[ 196.429900] ehci_hcd: Unknown symbol usb_hcd_pci_remove
[ 196.430222] ehci_hcd: Unknown symbol usb_root_hub_lost_power

Kindly help me what to do...

arckane 12-26-2008 04:56 AM

Your modules are compiled for a different kernel to one you have installed.

Do a full update of your linux-image/kernel, then try again.

shariefbe 12-26-2008 10:06 PM

no...i took this modules from this kernel only.....because i already compiled one modules like this and i succesfully installed before this..that is "usbcore" modules......this is the module used by "uhci-hcd" module...so i compiled that module first and then i tried to install this module...but am getting this error...help me...


All times are GMT -5. The time now is 03:53 AM.