LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-24-2013, 02:04 AM   #1
harshil12345
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Rep: Reputation: Disabled
Lightbulb unknown partition recovery command in linux ubuntu by using usb


hello sir ,

i harshil patel

i want to know how unknown partition recovery command in linux ubuntu by using usb
 
Old 03-24-2013, 02:08 AM   #2
harshil12345
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Exclamation linux ubuntu 12.04 software installation probelm in ns 2.33

hello sir

i install ns 2.33 in ubuntu 12.04 LTS then get error like this
ld -shared -o libotcl.so otcl.o
otcl.o: In function `OTclDispatch':
/home/harshil/ns-allinone-2.33/otcl-1.13/otcl.c:495: undefined reference to `__stack_chk_fail_local'
otcl.o: In function `Otcl_Init':
/home/harshil/ns-allinone-2.33/otcl-1.13/otcl.c:2284: undefined reference to `__stack_chk_fail_local'
ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Error 1
otcl-1.13 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
 
Old 03-24-2013, 02:14 AM   #3
harshil12345
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by harshil12345 View Post
hello sir

i install ns 2.33 in ubuntu 12.04 LTS then get error like this
ld -shared -o libotcl.so otcl.o
otcl.o: In function `OTclDispatch':
/home/harshil/ns-allinone-2.33/otcl-1.13/otcl.c:495: undefined reference to `__stack_chk_fail_local'
otcl.o: In function `Otcl_Init':
/home/harshil/ns-allinone-2.33/otcl-1.13/otcl.c:2284: undefined reference to `__stack_chk_fail_local'
ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Error 1
otcl-1.13 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
sir

in this site no this type of problem solution so please help me
 
Old 03-24-2013, 04:15 AM   #4
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Centos6.3/Debian
Posts: 2,127
Blog Entries: 1

Rep: Reputation: 316Reputation: 316Reputation: 316Reputation: 316
Hi

Did you install all the dependencies???
Have a look here http://nsnam.isi.edu/nsnam/index.php/User_Information

Here it lists dependencies near the end
http://www.isi.edu/nsnam/ns/ns-build.html#allinone

This might help as well http://mayzin.webs.com/howtoinstallns2.htm
 
Old 03-24-2013, 10:58 AM   #5
fpmurphy
Member
 
Registered: Jan 2009
Location: /dev/ph
Distribution: Fedora, Ubuntu, Redhat, Centos
Posts: 297

Rep: Reputation: 62
Look at line 495 of otcl.c. You should see a reference to `_stack_chk_fail_local'. This function should be defined in libotcl but for some reason is apparently not being defined there. I would check your guard defines to see if they are correct for both otcl.c and the libotcl sources.
 
Old 03-24-2013, 11:54 PM   #6
harshil12345
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
ns 2.33 problem

hello sir
i harshil ,when i run tcl script then i get this type of error so please help me , early reply
nam:
[code omitted because of length]
: no event type or button # or keysym
while executing
"bind Listbox {
%W yview scroll [expr {- (%D / 120) * 4}] units
}"
invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox {
%W yview scroll [expr {- (%D)}] units
}
bind Li..."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Create System Recovery Partition in Linux Ubuntu melodyintrance Linux - Newbie 7 03-24-2013 10:49 PM
[SOLVED] Dual boot Windows 7, Ubuntu and Recovery Partition glock356 Ubuntu 3 11-28-2012 02:39 AM
Unknown filesystem partition after using the dd command knspradeep Linux - Newbie 7 11-25-2012 03:53 PM
[SOLVED] USB bootstick, usbimg2disk.sh and OEM recovery partition catkin Slackware 15 07-01-2010 03:54 AM
ntfs partition on usb disk messed up by gparted needs recovery cristiano.fava Linux - Hardware 8 03-09-2009 11:02 AM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration