LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-22-2008, 02:01 PM   #1
krap
LQ Newbie
 
Registered: May 2008
Posts: 25

Rep: Reputation: 15
unistall gcc 4.1 and want to install gcc 2.95


hi ,
I want to install gcc 2.95 on fc6 but currently i have gcc 4.1.So how should i achieve it???

krap
 
Old 05-22-2008, 06:13 PM   #2
vertigo88x
Member
 
Registered: Dec 2006
Location: Perth Amboy, NJ, USA
Distribution: Fedora 9
Posts: 87

Rep: Reputation: 15
why would you want to do that? if it is to compile old code written for 2.95 then download the compatabily libs. it should be package compat-libstdc++-296
 
Old 05-23-2008, 12:54 AM   #3
krap
LQ Newbie
 
Registered: May 2008
Posts: 25

Original Poster
Rep: Reputation: 15
ya i want to compile kernel 2.4.20 but there are conflicting built in functions _exit error with gcc 4.1 ....thus i want to install gcc 2.95

krap
 
Old 05-23-2008, 01:07 AM   #4
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
If you are wanting to do this type of thing DO NOT use an rpm based distro. They are very tightly tied to the version of GCC that the system was built around. Use something like Gentoo or Slackware. They are not tied (as tightly) the the version of GCC.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pkg-get install gcc ERROR: gcc unrecognized Raidmax Solaris / OpenSolaris 10 08-30-2007 01:51 PM
Help me install GCC today! <-- 1yr without gcc :( nectron101 Linux - Newbie 4 04-17-2006 08:57 PM
install new gcc v3.4.5 over gcc v3.2.2 on red hat 9 mlaich Linux - Newbie 2 01-01-2006 09:52 PM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare SUSE / openSUSE 3 11-29-2004 03:13 PM
Must have gcc to install gcc? thafusion Linux - Software 4 05-28-2004 11:20 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration