LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-02-2003, 03:25 PM   #1
Riggs
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandrake 8.0
Posts: 2

Rep: Reputation: 0
Uninstalling gcc


I recently installed gcc v. 3.2 via an rpm in attempt to upgrade mine from 2.96, and i probably installed the wrong rpm b/c it didnt compile mplayer, anyhow i need to know how i can get rid of the version 3.2 and get back to my 2.96. thanks in advance.
btw running Mandrake 8.0
 
Old 08-02-2003, 03:30 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
If it was an rpm:
rpm -e gcc
 
Old 08-02-2003, 03:47 PM   #3
Riggs
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandrake 8.0
Posts: 2

Original Poster
Rep: Reputation: 0
indeed it was an rpm. When i execute rpm -e gcc it tells me my kernel and other programs are dependent upon it, and it lists gcc 2.96, so im thinking 3.2 is uninstalled.. but when i gcc -v and gcc -dumpversion it lists 3.2.

Last edited by Riggs; 08-02-2003 at 03:48 PM.
 
Old 08-02-2003, 04:26 PM   #4
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
You could try

rpm -U --oldpackage theolderversion.rpm

maybe help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
uninstalling gcc 3.2 ali_hammad Linux - Software 2 03-09-2005 05:49 AM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare SUSE / openSUSE 3 11-29-2004 03:13 PM
Kernel compiling: gcc-3.3 is 586, should be gcc-3.3 386 Erik Plaggenmar Linux - Software 0 10-01-2004 12:38 PM
a doubt with host gcc and arm-linux-gcc renjithgopal Linux - General 1 09-11-2003 05:02 PM
export CC=/usr/bin/gcc-3.2 - switch gcc version? ferreter Linux - Software 1 08-20-2003 01:07 AM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration