LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2013, 03:36 PM   #1
gumeniuc
LQ Newbie
 
Registered: Aug 2013
Posts: 11

Rep: Reputation: Disabled
Uninstall iptables


Hello guys,

I need to reduce iptables version on CentOS 6.4.
Can you please advice how to do it ?

I wanted to uninstall it, but yum offered to uninstall 44 packages.

Code:
Dependencies Resolved

=============================================================================================================================================================
 Package                                  Arch               Version                                Repository                                          Size
=============================================================================================================================================================
Removing:
 iptables                                 i686               1.4.7-9.el6                            @anaconda-CentOS-201303020136.i386/6.4             703 k
Removing for dependencies:
 b43-openfwwf                             noarch             5.2-4.el6                              @anaconda-CentOS-201303020136.i386/6.4              31 k
 cronie                                   i686               1.4.4-7.el6                            @anaconda-CentOS-201303020136.i386/6.4             164 k
 cronie-anacron                           i686               1.4.4-7.el6                            @anaconda-CentOS-201303020136.i386/6.4              38 k
 crontabs                                 noarch             1.10-33.el6                            @anaconda-CentOS-201303020136.i386/6.4             2.4 k
 cryptsetup-luks                          i686               1.2.0-7.el6                            @anaconda-CentOS-201303020136.i386/6.4             293 k
 cryptsetup-luks-libs                     i686               1.2.0-7.el6                            @anaconda-CentOS-201303020136.i386/6.4              97 k
 cyrus-sasl                               i686               2.1.23-13.el6_3.1                      @anaconda-CentOS-201303020136.i386/6.4             125 k
 device-mapper                            i686               1.02.77-9.el6                          @anaconda-CentOS-201303020136.i386/6.4             167 k
 device-mapper-event                      i686               1.02.77-9.el6                          @anaconda-CentOS-201303020136.i386/6.4              28 k
 device-mapper-event-libs                 i686               1.02.77-9.el6                          @anaconda-CentOS-201303020136.i386/6.4              20 k
 device-mapper-libs                       i686               1.02.77-9.el6                          @anaconda-CentOS-201303020136.i386/6.4             247 k
 device-mapper-multipath                  i686               0.4.9-64.el6                           @anaconda-CentOS-201303020136.i386/6.4             200 k
 device-mapper-multipath-libs             i686               0.4.9-64.el6                           @anaconda-CentOS-201303020136.i386/6.4             404 k
 dhclient                                 i686               12:4.1.1-34.P1.el6.centos              @anaconda-CentOS-201303020136.i386/6.4             622 k
 dracut                                   noarch             004-303.el6                            @anaconda-CentOS-201303020136.i386/6.4             240 k
 dracut-kernel                            noarch             004-303.el6                            @anaconda-CentOS-201303020136.i386/6.4             202
 fuse                                     i686               2.8.3-4.el6                            @anaconda-CentOS-201303020136.i386/6.4             182 k
 git                                      i686               1.7.1-3.el6_4.1                        @updates                                            14 M
 initscripts                              i686               9.03.38-1.el6.centos                   @anaconda-CentOS-201303020136.i386/6.4             5.4 M
 iproute                                  i686               2.6.32-23.el6                          @anaconda-CentOS-201303020136.i386/6.4             852 k
 iptables-ipv6                            i686               1.4.7-9.el6                            @anaconda-CentOS-201303020136.i386/6.4             159 k
 iputils                                  i686               20071127-16.el6                        @anaconda-CentOS-201303020136.i386/6.4             271 k
 iscsi-initiator-utils                    i686               6.2.0.873-2.el6                        @anaconda-CentOS-201303020136.i386/6.4             1.9 M
 kbd                                      i686               1.15-11.el6                            @anaconda-CentOS-201303020136.i386/6.4             900 k
 kpartx                                   i686               0.4.9-64.el6                           @anaconda-CentOS-201303020136.i386/6.4              35 k
 libdrm                                   i686               2.4.39-1.el6                           @anaconda-CentOS-201303020136.i386/6.4             255 k
 lvm2                                     i686               2.02.98-9.el6                          @anaconda-CentOS-201303020136.i386/6.4             1.4 M
 lvm2-libs                                i686               2.02.98-9.el6                          @anaconda-CentOS-201303020136.i386/6.4             1.8 M
 mdadm                                    i686               3.2.5-4.el6                            @anaconda-CentOS-201303020136.i386/6.4             875 k
 openssh                                  i686               5.3p1-84.1.el6                         @anaconda-CentOS-201303020136.i386/6.4             654 k
 openssh-clients                          i686               5.3p1-84.1.el6                         @anaconda-CentOS-201303020136.i386/6.4             1.0 M
 openssh-server                           i686               5.3p1-84.1.el6                         @anaconda-CentOS-201303020136.i386/6.4             641 k
 perl-Git                                 noarch             1.7.1-3.el6_4.1                        @updates                                            35 k
 plymouth                                 i686               0.8.3-27.el6.centos                    @anaconda-CentOS-201303020136.i386/6.4             170 k
 policycoreutils                          i686               2.0.83-19.30.el6                       @anaconda-CentOS-201303020136.i386/6.4             3.4 M
 postfix                                  i686               2:2.6.6-2.2.el6_1                      @anaconda-CentOS-201303020136.i386/6.4             9.3 M
 rsyslog                                  i686               5.8.10-6.el6                           @anaconda-CentOS-201303020136.i386/6.4             2.1 M
 subversion                               i686               1.6.11-9.el6_4                         @updates                                            11 M
 system-config-firewall-base              noarch             1.2.27-5.el6                           @anaconda-CentOS-201303020136.i386/6.4             2.3 M
 systemtap                                i686               1.8-7.el6                              @base                                               53 k
 systemtap-client                         i686               1.8-7.el6                              @base                                              9.0 M
 udev                                     i686               147-2.46.el6                           @anaconda-CentOS-201303020136.i386/6.4             1.2 M
 util-linux-ng                            i686               2.17.2-12.9.el6                        @anaconda-CentOS-201303020136.i386/6.4             5.6 M

Transaction Summary
=============================================================================================================================================================
Remove       44 Package(s)
Can you please advice a solution ?

thank you
regards,
Alex
 
Old 08-28-2013, 04:40 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by gumeniuc View Post
Hello guys,
I need to reduce iptables version on CentOS 6.4. Can you please advice how to do it ? I wanted to uninstall it, but yum offered to uninstall 44 packages.

Can you please advice a solution ?
The best question would be WHY do you need to 'reduce' the version? You do realize that you will put bugs/security vulnerabilities back ONTO your machine with an older version, right? And possibly reduce the feature set?? What is your goal, and what are you trying to accomplish?

If you don't want iptables, then don't run it. No need to uninstall it.
 
Old 08-29-2013, 01:40 PM   #3
gumeniuc
LQ Newbie
 
Registered: Aug 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
I wanted to apply patch for l7 filtering. The latest version with patch is 1.4.1. Right now I have iptables 1.4.5. If I install another iptables (1.4.1), there will be mismatch between two different versions, so I thought the best way would be to uninstall existing iptables and then install older one.

Can you please advice how to proceed ?
 
Old 08-29-2013, 04:35 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,921

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by gumeniuc View Post
I wanted to apply patch for l7 filtering. The latest version with patch is 1.4.1. Right now I have iptables 1.4.5. If I install another iptables (1.4.1), there will be mismatch between two different versions, so I thought the best way would be to uninstall existing iptables and then install older one.

Can you please advice how to proceed ?
I did...you stay with the latest version. Did you even read the installation instructions for the layer 7 patch???
http://l7-filter.sourceforge.net/HOWTO

It's for the KERNEL...and it's old. It even has VERY PLAIN instructions that say how to apply things to version 1.4.1 OR NEWER iptables. 1.4.5 is newer. The newer L7 filter is still two years old. If you need layer 7 filtering, the best thing to do is purchase a switch that has that capability built into it, and not do this.

Last edited by TB0ne; 08-29-2013 at 04:41 PM.
 
1 members found this post helpful.
Old 08-30-2013, 12:47 PM   #5
gumeniuc
LQ Newbie
 
Registered: Aug 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
TB0ne, thank you for the hint. I just built .so module and moved it to appropriate location.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to uninstall FAKE if there us no make uninstall available sweta.mulgavker Linux - Software 6 08-27-2009 06:46 AM
Need to uninstall SuSe 8.1 & there is no uninstall jwhibdon Linux - Software 10 10-26-2006 12:57 PM
iptables v1.2.9: Unknown arg `/sbin/iptables' Try `iptables -h' or 'iptables --help' Niceman2005 Linux - Security 4 12-29-2005 09:20 PM
How do you uninstall software which doesn't have an uninstall-file? lagu2653 Linux - Software 2 12-08-2005 01:36 PM
Source uninstall with 'make uninstall' HOWTO! Creeps Linux - Newbie 6 09-14-2004 12:03 PM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration