LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-05-2005, 03:49 AM   #1
coolblue
Member
 
Registered: Feb 2005
Posts: 126

Rep: Reputation: 15
UNDEFINED MODE NUMBER error


Dear newbies,
I believe a lot of you have to see this stupid message, "You passed an undefined mode number. Press Enter to see video modes available or Space to continue or wait 30 seconds"

Just for all you newbies, I'm posting the solution to this problem which will enable all of you to get rid of it forever. Heres what you do:

IF YOU ARE USING LILO BOOTLOADER

First login as root. Then look for the lilo.conf file. You'll probably find this here /etc/lilo.conf

Open this file in any text editor. You'll see some text. Look for this line
vga=

Whatever value there is after the '=' (equal to) sign, replace it with 'normal'.
So it should look like this

vga=normal

Now save the changes you have made (if u get the error message that u do not have enough permissions to make this change, then u are NOT logged in as root. Login as root first. Or in some cases, just right-click on the lilo.conf file and Actions>Edit as root)

Once u have made the changes to your lilo.conf file and saved them, reboot. And bingo! that stupid error does not come up anymore!

IF YOU ARE USING GRUB BOOTLOADER

First login as root. Then look for the grub config file. Depending on the distro the config file might be one of these:

/boot/grub/menu.lst
/boot/grub/grub.conf

Open this file in any text editor. You'll see some text. Look for this line
vga=

Whatever value there is after the '=' (equal to) sign, replace it with 'normal'.
So it should look like this

vga=normal

Now save the changes you have made (if u get the error message that u do not have enough permissions to make this change, then u are NOT logged in as root. Login as root first. Or in some cases, just right-click on the lilo.conf file and Actions>Edit as root. Another way is through terminal.)

Once u have made the changes to your lilo.conf file and saved them, reboot. And bingo! that stupid error does not come up anymore!

Hope this helps.
And I hope you all enjoy using Linux. Its FAR BETTER than Windows in many ways. By the way my fav distro is SimplyMEPIS 3.3 - because its FREE and a ready-to-use desktop distro and AWESOME for newbies. Its a LiveCD+InstallationCD+RecoveryCD all in one! And it has a NICE FULLY GRAPHICAL INSTALLER AND DiskPartitioner QTParted!

Whats more soon 3 Extra CD ISOs containing more apps, games & software for SimplyMEPIS 3.3 will soon be avilable for FREE DOWNLOAD!! Check out www.mepis.org and www.mepislovers.com

Spread the message.

Love to all Linux newbies
CoolBlue
 
Old 09-21-2005, 05:33 PM   #2
lefty.crupps
Member
 
Registered: Apr 2005
Location: Minneap USA
Distribution: Debian, Mepis, Sidux
Posts: 470

Rep: Reputation: 32
not too noobie myself, but I've been looking for this solution anyway. Thank you, er, thank u!

lol
 
Old 09-22-2005, 01:34 AM   #3
webshark
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.1
Posts: 23

Rep: Reputation: 15
This is exactly what I was looking for!

Thanks Much.
 
Old 10-16-2005, 10:35 PM   #4
coolblue
Member
 
Registered: Feb 2005
Posts: 126

Original Poster
Rep: Reputation: 15
Try vga=9 too.......

Rarely but not always vga=normal might still give u the same error....so try setting vga=9 and see.

Hope this helps.

All newbies welcome.....I know how pissed off I used to get at seeing this message on bootup and wished I could solve it!

Anyways, my most fav distro now is Kubuntu, NOT Mepis
 
Old 11-03-2005, 12:54 PM   #5
Digital Hand
LQ Newbie
 
Registered: Nov 2005
Posts: 2

Rep: Reputation: 0
Dear coolblue,

Can you explain to me how can i login as root ( what should i write ? )
and how can i edit lilo.conf ( by using bash and how ? or by notepad in windows )

Actually, After entering failsafe what should i do then ?

Note: I installed Mandrive 2006 and selected LILO BOOTLOADER
& my laptop is ferrari 4000.

Last edited by Digital Hand; 11-04-2005 at 03:07 AM.
 
Old 11-04-2005, 03:16 PM   #6
Digital Hand
LQ Newbie
 
Registered: Nov 2005
Posts: 2

Rep: Reputation: 0
? ? ? ? ? ? ? ? ? ? ? ?
 
Old 04-01-2006, 07:05 AM   #7
coolblue
Member
 
Registered: Feb 2005
Posts: 126

Original Poster
Rep: Reputation: 15
sorry digital hand i didnt see ur post as i dont frequent this forum too often...im just a simple ubuntu user...no geek

To login as root, at the login prompt:
Username: root
Password: give the root password here

You should be careful when u are logged in as root. There is no need to be logged in as root...u can do all things logged in as normal user as well...u just have to give the root password.

If u want to edit lilo.conf just right-click the file (from inside Konqueror...I assume u are using KDE) and select "Edit as root".

What u should do after entering failsafe depends on what u want to do...

Hope this helps.
 
Old 06-10-2006, 09:05 AM   #8
MTisza
LQ Newbie
 
Registered: Feb 2005
Location: New Jersey
Distribution: Suse Linx 9.2 Pro
Posts: 1

Rep: Reputation: 0
Slightly different for me

I'm runnign Suse 10.1 and for me the steps were slightly different.
I had to modify /boot/grub/menu.lst

There there was a vga=??? for each of the boot menu options. I changed it to vga=normal and the bootup error was gone.

Thanks for the help it definately pointed me in th eright direction.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
You passed an undefined mode number priest_judas Linux - Newbie 12 02-08-2005 06:16 PM
Video Card boot up error: undefined mode number tt08 Linux - Newbie 1 10-24-2004 10:26 AM
Knoppix 3.6 -- Undefined Mode Number Coppertone Debian 3 09-20-2004 06:40 PM
You passed an undefined mode number priest_judas Linux - Hardware 3 12-11-2003 05:19 PM
You have passed an undefined mode number. acidslut Slackware 5 08-18-2003 12:00 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration