LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2002, 06:06 AM   #1
Daruma
LQ Newbie
 
Registered: Jan 2002
Distribution: Debian
Posts: 8

Rep: Reputation: 0
Angry Uncontrollable Screen Blanking


Greetings, all!

I am running Debian with the 2.0.36 kernel.

My current irritation is the uncontrollable blanking of my monitor at about 10 minutes of inactivity. This occurs when I am in console or in Xwindow display.

I have a strong suspicion that this is a BIOS level setting that I have missed. Unfortunately, I am working without the appropriate BIOS/Motherboard manual. From what I can tell, I have an Award Software, Inc. BIOS. The info at the top of my setting page is:

ROM PCI/ISA BIOS (P5VX-Be)

I've got all of the Power Management Settings disabled that are possible...

Here are the details:

Pwer Management: Disable
PM Control by APM: No
Video Off Method: DPMS
(Note: I have three choices here and I've tried all three with the same results... the choices are:
DPMS
Blank Screen
V/H SYNC+Blank
End note)
Modem Use IRQ: NA
CPU Fan Power Green: Disable
Doze Mode: Disable
Standby Mode: Disable
HDD Power Down: Disable

Next there is a heading for:
*** Wake Up Events In Doze & Standby ***
IRQ3 (Wake-Up Event): ON
IRQ4 (Wake-Up Event): ON
IRQ8 (Wake-Up Event): OFF
IRQ12 (Wake-Up Event): ON

and there is a group:
*** Power Down & Resume Events ***
IRQ3 (COM 2) : ON
IRQ4 (COM 1) : ON
IRQ5 (LPT 2) : ON
IRQ6 (Floppy Disk) : ON
IRQ7 (LPT 2) : ON
IRQ8 (RTC Alarm) : OFF
IRQ9 (IRQ2 Redir) : ON
IRQ10 (Reserved) : ON
IRQ11 (Reserved) : ON
IRQ12 (PS/2 Mouse) : ON
IRQ13 (Coprocessor): ON
IRQ14 (Hard Disk) : ON
IRQ15 (Reserved) : ON

Does anyone have any ideas?? Need to see the info from another page??

Note: I've tried:

#setterm -powersave off -blank 0

and I'm still getting the undesirable screen blanking...

Thanks!

-CJ
 
Old 01-11-2002, 10:57 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
The setterm is for disabling it in the console mode. And xset s off will usually disable it in X. But that's probably not it if you say the setterm doesn't help. I don't think linux uses the BIOS parameters for powersaving. As far as I know it's the apm daemon that takes care of that. I've never really tried to configure it so I wouldn't know how you can tell it to not switch off. But you could always disable it in the kernel. Or try and find some more information about it. I think there is some in the /usr/src/linux-x.x.x/Documentation directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Blanking b0mb3r Slackware 6 03-16-2005 03:39 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
Screen blanking ? ... phoeniXflame Linux - General 12 07-20-2003 06:41 PM
rh 9.0 screen blanking corrupter Linux - General 1 06-04-2003 05:16 PM
Screen Blanking/non-X ldieter Linux - General 0 03-11-2002 10:05 PM


All times are GMT -5. The time now is 05:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration