LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-15-2006, 04:54 AM   #1
TheBrick
Member
 
Registered: Mar 2006
Location: London
Distribution: SUSE 10.0 Home soon to go (no internet conection), gentoo laptop, slack on development box
Posts: 81

Rep: Reputation: 15
Unbootable stops with just short grub on screen


Hello, please help I am toataly lost. I am sorry if this seems very simple. I have tried to search but am not sure what to search for I am so lost.

I am running a dual boot machine with win 98 and SUSE 10.0. Last night I get home and start up my machine which started normaly at first but then stop at

Booting from CDROM:
Booting from CDROM:
GRUB

this is normal but it then usually jumps to the grub screen with my boot options: SUSE 10.0 WINDOWS FAILSAFE e.t.c Not this time it just stops. I try pressing return, nothing. O.K. I check my BIOS boot sequence. 1, CDROM 2. FLOPPY 3. HARD DRIVE. I try swapping to 1, CDROM 2. HARD DRIVE 3. FLOPPY. It makes no diffrence. The next thing I try is putting my SUSE 10.1 CD1 in and boot I choose boot from hard disk and all I get is

GRUB

at the top of the screen. So I then try putting in a Knoppix bootable CD, this starts fine. I can access both my windows and SUSE partions from here to this implies that the HD is connected o.k. I am clean out of any ideas. I also unplugged things plugged in to my USB ports. The last thing I did when the machine was working was install qemu, but that should not screw with anything to do with booting should it?

I am quite a newbe and any help is good.
 
Old 03-15-2006, 07:13 AM   #2
Keruskerfuerst
Member
 
Registered: Oct 2005
Location: Lat: 482356N, Lon: 104145E
Distribution: Gentoo 2006
Posts: 719

Rep: Reputation: 31
You should use the Suse cd to boot the installed Linux. It can be acessed by using the manual installtion -> boot installed Linux.
 
Old 03-15-2006, 07:23 AM   #3
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
hi

thanks for telling us you have trouble shooted the best you could with a live cd cos I am going to tell how some extra steps if you mind.

1 boot from the knoppix again

2 click on the icon for the /boot partition .....if not sure click on all of them until you can get to /boot/grub/menu.lst

post the output of that file....you can save it to floppy if you can not write it down

then ....find the / partition and post the output of the file /etc/fstab

3 using my tutorial you may or may not spot a problem with the suse grub file?

4) but while in knoppix click on the shell icon (for the konsole) and re-install grub to mbr so it links to its booting files

su
grub
root (hdX,y) as per tut where is /boot partition in grub speak
setup (hdX) ....could be hd0?
quit
reboot


5....if that fails you still have no change.....4 will only re-embed grub and its link it will not change your menu options so if you spot they are wrong you need to right hand click the correct drive icon and make it read/writeable and use su powers to edit that file while knoppix is loaded.

6 if you feel keen.....look at my trouble shooter and use commands to boot the drive and then write down the correct ones and edit the file once suse as booted?
 
Old 03-15-2006, 08:45 AM   #4
TheBrick
Member
 
Registered: Mar 2006
Location: London
Distribution: SUSE 10.0 Home soon to go (no internet conection), gentoo laptop, slack on development box
Posts: 81

Original Poster
Rep: Reputation: 15
thankyou very much aus9 I will give it a go tonight! I will let you know if I have succsess.
 
Old 03-16-2006, 04:04 AM   #5
TheBrick
Member
 
Registered: Mar 2006
Location: London
Distribution: SUSE 10.0 Home soon to go (no internet conection), gentoo laptop, slack on development box
Posts: 81

Original Poster
Rep: Reputation: 15
Thanks aus9. I reinstalled grub as you said and every thing as working now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
boot stops at grub> promicro Linux - General 1 03-11-2005 04:54 PM
boot stops at GRUB GRUB linux never boots coffeedemon Slackware 4 11-09-2004 02:20 PM
Typo with GRUB caused Win98 to be unbootable wapcaplet Linux - Software 7 11-28-2003 08:21 AM
Screen Stops At Power Down krissly1 Linux - Newbie 3 11-27-2003 09:17 PM
Trying to dual-boot XP and RH9 with GRUB...GRUB stops right after BIOS EvilYoda Linux - Newbie 5 06-20-2003 03:38 PM


All times are GMT -5. The time now is 02:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration