LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2006, 01:49 AM   #1
lcornea
LQ Newbie
 
Registered: Dec 2005
Location: Onesti Romania
Distribution: fedor core 4
Posts: 24

Rep: Reputation: 15
Question unable tu upgrade gcc on FC4


hi
I need some help on how to upgrade the gcc on my computer. I went to http://gcc.gnu.org but i ended up with just more questions.
My gcc version is something like 2.???? something. I need at least a 3.4 to be able to build some programs that have no rpm on the web for FC4.
Please help me update gcc, and if u can write things that are not confiuzing (something like a step by step would be nice)

Thenx
 
Old 01-27-2006, 02:59 AM   #2
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 49
FC4 comes with gcc 4.0.
 
Old 01-27-2006, 04:21 AM   #3
sohny
Member
 
Registered: Aug 2004
Location: bangalore
Distribution: Redhat,Ubuntu
Posts: 64

Rep: Reputation: 15
type gcc -v or gcc --v
the last line shows u the version
 
Old 01-27-2006, 06:32 AM   #4
lcornea
LQ Newbie
 
Registered: Dec 2005
Location: Onesti Romania
Distribution: fedor core 4
Posts: 24

Original Poster
Rep: Reputation: 15
the gcc -v comand said i have gcc 4.0 but still there are some programs that check for the gcc version while "./configure" and retun "gcc version 4 bad" like below

Checking for cc version ... 4.0.0, bad
Checking for gcc version ... 4.0.0, bad
Checking for gcc-3.4 version ... not found
Checking for gcc-3.3 version ... not found
Checking for gcc-3.2 version ... not found
Checking for gcc-3.1 version ... not found
Checking for gcc3 version ... not found
Checking for gcc-3.0 version ... not found
Checking for cc version ... 4.0.0, bad

What do i do now????
P.S. I still want to know how to update the gcc
Thenx for the help so far.
 
Old 01-27-2006, 06:39 AM   #5
sohny
Member
 
Registered: Aug 2004
Location: bangalore
Distribution: Redhat,Ubuntu
Posts: 64

Rep: Reputation: 15
the problem is not that the gcc is bad.
its searching for the exact version which is 3.4,3.3,3.2,3.1,etc
u need to add 4.0 in that list thats all.

u can do one thing open that configure file in any text editor(kwrite for example or vi; any editor).
search for the line where there is a list of gcc versions or the line where the comaparisions are done & place 4.0 as one of your options & save the file.
Then run the configure script it will work

If all this is too complicated just post that file here. i will tell u which line to change & how.
 
Old 01-27-2006, 07:48 AM   #6
lcornea
LQ Newbie
 
Registered: Dec 2005
Location: Onesti Romania
Distribution: fedor core 4
Posts: 24

Original Poster
Rep: Reputation: 15
it took a while to understand the code but i figured it out.
Thenx.

i don't want to be unapreciative but still the question remains: how do you upgrade the gcc?
And i want to know because until now i thought that my gcc version was wrong and i found out that it's not, but soon enought it will become old and i will have to upgrade it, and i still have no clue non where to start, maby someone knows a site with tutorials or guides that are for newbies. I'll study it on my own. I just want to learn how to use linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4/GCC-4 and OpenCV 0.9.7 conflicts... jiapei100 Linux - Software 0 11-03-2005 08:28 PM
Need Two Versions of gcc on FC4 yellowdognerd Linux - Software 9 09-09-2005 01:46 PM
gcc 3.2-7 on FC4 ? senthilpr_in Linux - Software 14 08-25-2005 12:05 PM
Unable to boot FC4! unzari Fedora 10 07-19-2005 10:33 AM
FC4, linux-gate.so.1 is needed by gcc RohanShrivastav Fedora 3 07-15-2005 09:12 AM


All times are GMT -5. The time now is 09:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration