LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-12-2009, 10:31 PM   #1
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Rep: Reputation: 17
Unable to write to XP NTFS file system


Hi,
Running Slackware 12.2 on HP dv6t notebook.

I've added mp XP partition to fstab and the option specifies 'defaults'. On startup the partition gets mounted successfully and even indicates (rw). But when I try to save something, I get 'Permission denied'.

What should I do to be able to write on the NTFS partition so that I can access the file in Windows.

Thanks in advance,

Ash.
 
Old 12-12-2009, 10:34 PM   #2
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX, OS X
Posts: 567

Rep: Reputation: 57
The problem is you have write permissions, but you can only write in a directory you created. You are running into ownership issues. How are you accessing this XP partition? Are you accessing it from the same hard drive or are you using samba?
 
Old 12-13-2009, 12:30 AM   #3
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
I'm accessing the XP partition from the same hard drive. I even logged in as root but wasn't able to write to it.

So what are these ownership issues that I may be running into?

Thanks,

Ash.
 
Old 12-13-2009, 02:42 AM   #4
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
Quote:
Originally Posted by ash_zz_00 View Post
Hi,
Running Slackware 12.2 on HP dv6t notebook.

I've added mp XP partition to fstab and the option specifies 'defaults'. On startup the partition gets mounted successfully and even indicates (rw). But when I try to save something, I get 'Permission denied'.

What should I do to be able to write on the NTFS partition so that I can access the file in Windows.

Thanks in advance,

Ash.

You probably need the NTFS-3G driver to be able to write to that partition.
Does your /etc/fstab has a line like this one:
Code:
/dev/<your partition>     /media/<mount point>     ntfs-3g     defaults,locale=en_US.utf8   0    0
 
1 members found this post helpful.
Old 12-13-2009, 05:34 AM   #5
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
That was it. I had to specify ntfs-3g for the fs type.

Thanks,
Ash.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem configure RHEL5 kernel to read & write NTFS file system. hocheetiong Linux - Newbie 3 07-09-2008 12:49 AM
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 04:27 AM
Read Write for NTFS file system geeedeee Linux - Laptop and Netbook 8 06-05-2006 08:41 PM
unable to write to mounted .img file decaf Linux - General 10 03-21-2005 06:15 PM
does ntfs write support have to do with a file server? mipia Slackware 7 10-31-2004 06:20 PM


All times are GMT -5. The time now is 04:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration