LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2005, 06:03 PM   #1
aducarrab
LQ Newbie
 
Registered: Jan 2005
Location: Rhode Island
Distribution: Red Hat 9
Posts: 15

Rep: Reputation: 0
unable to write to vfat partition as non-root


I have the following line in my fstab to mount hdb1;

/dev/hdb1 /mnt/hdb1 vfat auto,user,noexec,rw,sync 0 0

Works fine as root but no write access as normal user. I've tried unmounting and setting /mnt/hdb1 directory permission to 660 but when i remount it changes back to 500. I'm guessing I'm missing an option in the fstab line that would set default permission for this drive to 660, how should I change the entry?

Thusfar I've obtained info on this from here;
http://www.tuxfiles.org/linuxhelp/fstab.html
was a great start but no mention of the permission setting.

thks
 
Old 01-29-2005, 06:09 PM   #2
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
After sync add umask=0 like so
Code:
auto,user,noexec,rw,sync,umask=0
 
Old 01-29-2005, 06:53 PM   #3
aducarrab
LQ Newbie
 
Registered: Jan 2005
Location: Rhode Island
Distribution: Red Hat 9
Posts: 15

Original Poster
Rep: Reputation: 0
what exactly is the umask=0 doing? i have write access as a normal user now, but now everything I copy to this partition gets it's permissions changed to rwxrwxrwx and I get an error message saying, "could not change permissions for /mnt/hdb1/test.txt" - this despite the fact that permissions apparently WERE changed.
 
Old 01-29-2005, 07:04 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,720

Rep: Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751
vfat does not do permissions like a linux filesystem. The umask=000 options sets read/write permissions for all which is why you see rwxrwxrwx. umask is the reverse of chmod in its bit settings. i.e. 0 is set. You can not use chmod to change permissions.
 
Old 01-29-2005, 07:08 PM   #5
aducarrab
LQ Newbie
 
Registered: Jan 2005
Location: Rhode Island
Distribution: Red Hat 9
Posts: 15

Original Poster
Rep: Reputation: 0
got it on the file permissions. so I just have to live with the error message every time i drag a file into this drive?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to write to my FAT32 Partition dominoid Linux - Newbie 4 02-12-2005 06:18 AM
Can't write to vfat partition as user sigma957 Slackware 6 07-29-2004 08:58 AM
user can't read/write (vfat) partition MykilX Slackware 6 07-04-2003 05:32 PM
unable to write file to vfat partition from Linux techsarge Linux - Software 5 04-25-2003 04:16 PM
vfat partition - write permission for users group digitized_funk Linux - Newbie 8 03-19-2003 07:30 AM


All times are GMT -5. The time now is 06:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration