LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-27-2009, 03:00 AM   #1
malli42108
Member
 
Registered: Jul 2009
Posts: 37

Rep: Reputation: 15
unable to use "ls" command in x86 solaris 10 machine?


hi experts,

i am using x86 solaris 10 machine. In this i am unable to use "ls" command. but i can use "/bin/ls" instead of "ls".
what to set to use "ls" directly.(without alias names)?

$ uname -a
SunOS dslam015 5.10 Generic_139556-08 i86pc i386 i86pc


$ ls
ls: illegal option -- color=auto
usage: ls -1RaAdCxmnlhogrtuvVcpFbqisfHLeE@ [files]

$ /bin/ls
Desktop kernel
Documents lib
TT_DB libiconv-1.11-sol10-sparc-local
ap libiconv-1.11-sol10-x86-local
aws lost+found
awsvobs1 mcdtools


Thanks in advance
Malli
 
Old 10-27-2009, 03:17 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,628

Rep: Reputation: Disabled
In your bashrc file, there is some alias set which is creating problems. remove the alias and see if it works. The bashrc file is hidden and is .bashrc.
 
Old 10-27-2009, 08:45 PM   #3
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Exactly
Quote:
ls: illegal option -- color=auto
ls has been aliased to use the --color option, not avail in your version of ls.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to start VMWare machine on Windows , saying "Can not find valid peer process" apskaushik Linux - Newbie 1 12-10-2008 09:32 AM
Unable to "whois" from an IC Shared machine. uncle-c Linux - Newbie 1 11-19-2007 12:19 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
LXer: Sabayon Linux x86/x86-64 1.0 "Business Edition" LXer Syndicated Linux News 0 07-18-2007 12:31 AM
command in solaris which is equivalent to "smbstatus" of linux Nupur Singh Solaris / OpenSolaris 2 02-02-2006 01:25 PM


All times are GMT -5. The time now is 04:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration