LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-23-2008, 02:16 AM   #1
skengaku
LQ Newbie
 
Registered: Oct 2005
Location: Japan
Distribution: Open Suse11.0, Win XP
Posts: 7

Rep: Reputation: 0
Unable to start SaX2 from SUSE11.0 YaST2



Until recently, I have been able to use SaX2 from SUSE11.0 YaST2 to change hardware configurations. But somehow, right now, I am unable to start SaX2 from YaST2. I have tried the command 'sax2 --fullscreen', but it causes no errors and no returns.
Am I missing something?

I appreciate any feedbacks.
 
Old 11-23-2008, 03:03 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
What are exactly trying to do in yast2 ?
Which hardware are you trying to reconfigure ?
SAx2 you can also use it from the command line.
 
Old 11-23-2008, 03:16 AM   #3
skengaku
LQ Newbie
 
Registered: Oct 2005
Location: Japan
Distribution: Open Suse11.0, Win XP
Posts: 7

Original Poster
Rep: Reputation: 0
Unhappy


I am trying to change Keyboard assignment. The messages show that SaX2 is reading several modules, but nothing comes up.
I have also tried to check Graphic Card and Monitor, the situation is the same. The messages show SaX2 is reading several modules, but nothing comes up with no errors.
 
Old 11-23-2008, 03:22 AM   #4
skengaku
LQ Newbie
 
Registered: Oct 2005
Location: Japan
Distribution: Open Suse11.0, Win XP
Posts: 7

Original Poster
Rep: Reputation: 0
Post


I have checked system log, /var/log/messages
Found the error below
linux-c4zb kernel: xapi[5014]: segfault at 21 ip 43801a sp 7fff354b21c0 error 6 in xapi[400000+c1000]

Any ideas?
 
Old 11-23-2008, 03:50 AM   #5
JosipBroz
Member
 
Registered: Nov 2008
Location: Ljubljana
Distribution: OpenSuSE
Posts: 56

Rep: Reputation: 18
Have you tried running sax -r from a virtual console (Ctrl-Alt-F1) or, better still, from a failsafe CLI (init 3)?
 
Old 11-23-2008, 04:02 AM   #6
skengaku
LQ Newbie
 
Registered: Oct 2005
Location: Japan
Distribution: Open Suse11.0, Win XP
Posts: 7

Original Poster
Rep: Reputation: 0
Thumbs up


Thanks a lo----t!! 'sax2 -r' did work!!
I now can use SaX2 again!!
 
Old 11-23-2008, 04:02 AM   #7
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by skengaku View Post

I have checked system log, /var/log/messages
Found the error below
linux-c4zb kernel: xapi[5014]: segfault at 21 ip 43801a sp 7fff354b21c0 error 6 in xapi[400000+c1000]

Any ideas?
Segfault just speaking out of my memory occurs when a program try
to aces a part of the memory which is he is not allowed to.
So it is just long shot what more programs are you running when you use sax2 ?
 
Old 11-23-2008, 07:58 AM   #8
skengaku
LQ Newbie
 
Registered: Oct 2005
Location: Japan
Distribution: Open Suse11.0, Win XP
Posts: 7

Original Poster
Rep: Reputation: 0
Question

No I haven't run any other programs, I just booted, logged in as root, started YaST2 => SaX2.
The time stamp says that when I ran SaX2 from KDE4, the error occurred.
 
  


Reply

Tags
sax2, suse11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant start xdm/sax2 in openSuSE 11 symidran Linux - Software 2 09-22-2008 08:35 AM
Yast2 and sax2 unreachable in SuSE 9.2 dwj1024 Linux - Desktop 2 12-13-2006 10:15 AM
SaX2 won't start after x.org update bitpicker Suse/Novell 5 12-03-2004 04:01 AM
suse tools in other distro (yast2 and sax2) pandasuit Linux - Software 3 07-19-2004 03:55 PM


All times are GMT -5. The time now is 03:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration