LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-28-2006, 02:26 AM   #1
d2army
Member
 
Registered: Jun 2004
Posts: 49

Rep: Reputation: 15
Unable to set syntax color on for VIM 6.3 that came with Fedora 4


Hi there

I was wondering why the VIM 6.3 that came installed with Fedora Core 4 does not have syntax coloring on for code files(e.g in C or PHP). I tried to do "syntax on" and the font is still all black for my C code files.

Does anyone know if there is a setting in Fedora that I need to tweak?

Thanks!
 
Old 01-28-2006, 02:48 AM   #2
Optimistic
Member
 
Registered: Jun 2004
Location: Germany
Distribution: Debian (testing)
Posts: 276

Rep: Reputation: 33
In your ~/.vimrc file, check if you have the line

syntax on

Another thing to check: I had this problem when I upgraded from 6.3 to 6.4 because some links were pointing to 63 diurectories instead of 64 directories (look at the top of you .vimrc file for something like:
set runtimepath=~/.vim,/etc/vim,/usr/share/vim/vimfiles,/usr/share/vim/addons,/usr/share/vim/vim64,
/usr/share/vim/vimfiles,/usr/share/vim/addons/after,~/.vim/after,~/.vim/plugin

Last edited by Optimistic; 01-28-2006 at 03:01 AM.
 
Old 01-29-2006, 10:30 AM   #3
d2army
Member
 
Registered: Jun 2004
Posts: 49

Original Poster
Rep: Reputation: 15
Hi there

thanks for replying.

I am actually just using the default VIM that came installed with Fedora 4 and it is version 6.3

I have tried manually executing the command "syntax on" while using VIM but I still don't see any color coding.

So I looked into /etc/vimrc and the only point where "syntax on" is mentioned is :


if &t_Co > 2 || has("gui_running")
syntax on
set hlsearch
endif

Last edited by d2army; 01-29-2006 at 10:34 AM.
 
Old 02-16-2006, 01:52 PM   #4
d2army
Member
 
Registered: Jun 2004
Posts: 49

Original Poster
Rep: Reputation: 15
Ok, the problem is that I used VI instead of VIM

even though VI is aliased to VIM

weird
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vim syntax highlighting problems. donniejones18 Linux - Software 7 04-16-2006 09:03 PM
How to enable color syntax when I start vim? ArthurHuang SUSE / openSUSE 5 01-27-2006 12:10 AM
VIM Color Syntax Highliting bsg Linux - Newbie 5 10-07-2005 09:31 PM
vim syntax highlighting MiniMe001 Linux - General 2 06-19-2005 12:08 PM
Vim syntax highlighting NSKL Linux - Software 2 11-09-2002 03:39 AM


All times are GMT -5. The time now is 12:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration