LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-04-2007, 06:10 PM   #1
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Rep: Reputation: 32
Unable to "scanimage": "invalid argument” in Debian 4.0


I have Artec E+Pro scanner.
http://www.sane-project.org/sane-supported-devices.html. gives support as “minimal”. Debian 4.0 installation included Xsane but this gave “no device connected”. I'd like to scan using Xsane but am working through terminal to get connected. So....
Man pages referred to Sane, but terminal didn't recognize Sane commands, so I installed all the Sane options I could identify from Synaptic. Now Scanimage -L correctly identifies the device “device `artec_eplus48u:libusb:001:005' is a Artec E+ Pro USB flatbed scanner” but scanimage >..filename.. gives “open of device artec_eplus48u:libusb:001:005 failed: Invalid argument” Xsane opened in KDE (accessories,graphics) still says no device connected but xsane in root terminal leads to the same “open of device artec_eplus48u:libusb:001:005 failed: Invalid argument”. Thread TigerOC & binary dreamer Aug06 suggested checking users in the scanner group, I have done that. Man pages suggested commenting out all scanners except mine in /etc/sane.d/dll.conf. I have not done that yet- should I? I'm guessing that this scanner is supported after all but I'm missing something obvious- please tell me what it is!
 
Old 11-17-2007, 06:53 AM   #2
Georgina Everingham
LQ Newbie
 
Registered: Oct 2006
Posts: 19

Rep: Reputation: 0
Quote:
Originally Posted by sonichedgehog View Post
I have Artec E+Pro scanner.
http://www.sane-project.org/sane-supported-devices.html. gives support as “minimal”. Debian 4.0 installation included Xsane but this gave “no device connected”. I'd like to scan using Xsane but am working through terminal to get connected. So....
Man pages referred to Sane, but terminal didn't recognize Sane commands, so I installed all the Sane options I could identify from Synaptic. Now Scanimage -L correctly identifies the device “device `artec_eplus48u:libusb:001:005' is a Artec E+ Pro USB flatbed scanner” but scanimage >..filename.. gives “open of device artec_eplus48u:libusb:001:005 failed: Invalid argument” Xsane opened in KDE (accessories,graphics) still says no device connected but xsane in root terminal leads to the same “open of device artec_eplus48u:libusb:001:005 failed: Invalid argument”. Thread TigerOC & binary dreamer Aug06 suggested checking users in the scanner group, I have done that. Man pages suggested commenting out all scanners except mine in /etc/sane.d/dll.conf. I have not done that yet- should I? I'm guessing that this scanner is supported after all but I'm missing something obvious- please tell me what it is!
Hi!
I don't know whether this will help because I have an Epson Scanner.

In terminal type
sane-find-scanner | grep 0x04b8

This will give a return i.e.found usb scanner |vendor-0x04b8, product=0x0110) at libusb:001:002.

Your scanner may have different entry for 0x04b8, and you may have to find out what 0x0... after grep is for you.

then enter
chmod 0666 /proc/bus/usb/001/002 (here you enter the 00 results from find scanner command.

Then go to /etc/sane.d/ and find epkowa.conf and follow the instructions in this file to enter what will activate your scanner from the above information you have found by the previous commands.

All this has to be done in root.

I hope this helps
 
Old 11-25-2007, 07:19 PM   #3
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Original Poster
Rep: Reputation: 32
Thanks! Will try that lot (when time) & let you know. So far everything else has been possible in Debian... hopefully a bit of faith & a lot of fiddling will do the trick.
 
Old 12-02-2007, 03:31 PM   #4
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Original Poster
Rep: Reputation: 32
e+pro now working

Your suggestion + lots of reading led me to the source of the problem- sane has listed the E+pro and /etc/sane.d/artec_eplus48u.conf has a section devoted to it so commenting out the other bits was a start- but in the end it was the lack of directory and firmware in the location specified by the .conf that caused the "invalid argument". Creating the relevant directory + adding the firmware from the manufacturer's cd solved the issue. Thank you for your reply!-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 02:16 PM
Sound Blaster Audigy LS Problem - "Mixer attach default error: Invalid argument" corporal79 Linux - Hardware 3 03-27-2007 02:09 AM
alsa mixer sayin "function snd_mixer_load failed:invalid argument" callmeleroi Fedora 0 03-11-2007 10:05 AM
"cp -p" fails with "cp: setting permissions for `/home/svbld/t': Invalid argument" mkhesin Red Hat 1 02-28-2007 01:57 AM
Quagga "Can't bind socket: Invalid argument" JJX Linux - Networking 0 04-29-2004 11:21 AM


All times are GMT -5. The time now is 05:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration