LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2004, 01:50 PM   #1
woodgf
LQ Newbie
 
Registered: Dec 2003
Posts: 4

Rep: Reputation: 0
Unable to save fstab


Dear Forum:

Loaded RedHat 9 and wanted to access my shared vfat files, Windows dual boot. When editing the /etc/fstab file to include the following in addition to floopy, zip, and cdrom:

/dev/hda6 /mnt/data1 auto noauto,owner,kuszu 0 0
/dev/hda7 /mnt/data2 auto noauto,owner,kuszu 0 0

and then created directory entries in the /mnt directory for data1 and data2,

using the terminal root, I mount both volumes without any problems and access the data with no problems.

When I reboot my system, of course the Updating fstab occurs and then when I log back in I have lost my changes in /mnt and /etc/fstab.

How can I save the changes in fstab and /mnt so that I don't have to keep modifying each time I log in?

George Wood
 
Old 01-05-2004, 01:55 PM   #2
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
Those lines in you /etc/fstab should say kudzu not kuszu that might be your problem.

Try specifying the file system type as fat by replaceing auto with vfat
-Zero

Last edited by Zero-0-Effect; 01-05-2004 at 02:06 PM.
 
Old 01-05-2004, 02:56 PM   #3
woodgf
LQ Newbie
 
Registered: Dec 2003
Posts: 4

Original Poster
Rep: Reputation: 0
I changed them to the correct name and still the fstab file did not get saved when I rebooted.

/dev/hda6 /mnt/data1 auto noauto,owner,kudzu 0 0
/dev/hda7 /mnt/data2 auto noauto,owner,kudzu 0 0

George
 
Old 01-05-2004, 04:40 PM   #4
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 542

Rep: Reputation: 32
Are you logged as root when doing /etc/fstab modification?
I also suggest you move from
/dev/hda6 /mnt/data1 auto noauto,owner,kudzu 0 0
/dev/hda7 /mnt/data2 auto noauto,owner,kudzu 0 0
to
/dev/hda6 /mnt/data1 auto noauto,user,kudzu 0 0
/dev/hda7 /mnt/data2 auto noauto,user,kudzu 0 0
in order can mount/unmount as ordinary user
Ciao
 
Old 01-05-2004, 05:43 PM   #5
RobertP
Member
 
Registered: Jan 2004
Location: Manitoba, Canada
Distribution: Debian
Posts: 454

Rep: Reputation: 32
How are you editing /etc/fstab? Are you saving to disc after the changes are made? Does
cat /etc/fstab show the changed file?
 
Old 01-06-2004, 09:11 AM   #6
woodgf
LQ Newbie
 
Registered: Dec 2003
Posts: 4

Original Poster
Rep: Reputation: 0
To clarify a bit more I have installed a copy of the new RedHat version Fedora and I am trying to set up a migration plan for me and other clients to have an alternative other than windows.

After rebooting several times, it looks like the /mnt directory is fine and still has the necessary folders for the data1 and data2 mounts. The fstab still updates at startup and of course only has the cdrom, floppy, and zip, and does not include hda6 and hda7.

When I reboot and do my mounts in root terminal mode for hda6 and hda7, everything is fine and I am able to see and use the partitions.

So, I guess this is how it works. Again, I am still new at learning linux, so I guess I have to take one thing/step at a time.

Thank you for your input and help. Any reply comments are greatly appreciated.

As a side note for a newbie, what distribution do you recommend? RedHat, SuSE, Mandrake, etc??

George
 
Old 01-06-2004, 09:26 AM   #7
hazza
Member
 
Registered: Nov 2003
Location: Australia
Distribution: Mandrake, SUSE, Fedora
Posts: 122

Rep: Reputation: 15
Your problem is kudzu is rewriting the lines that you edited in /etc/fstab. Get rid of the kudzu option if you make any changes of your own to a particular mount point. You can also change the filesystem type to "vfat" since it doesn't need to be set as "auto".

/dev/hda6 /mnt/data1 vfat noauto,owner 0 0
/dev/hda7 /mnt/data2 vfat noauto,owner 0 0

You might also find the "showexec=no" option useful if you don't like every file on a vfat partition being shown as executable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to boot due to changes in fstab Covel Linux - General 4 12-09-2010 04:18 PM
Can't save my /etc/fstab :( dicou Linux - Newbie 7 04-20-2005 08:31 AM
Unable to save sound recording to file jeeva Linux - Software 2 02-01-2005 09:46 AM
Unable to save settings to kmenu RanDrake10 Linux - General 0 01-20-2005 07:38 PM
Unable to edit fstab... problems with ext. usb hdd removal gardyloo Linux - Newbie 1 12-27-2003 06:35 PM


All times are GMT -5. The time now is 07:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration