LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   unable to run video with hardware capabilities on pandaboard (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-run-video-with-hardware-capabilities-on-pandaboard-4175427803/)

agmegharaj 09-18-2012 06:17 AM

unable to run video with hardware capabilities on pandaboard
 
I am trying to run xbmc on Pandaboard. Here are the steps I followed

1. installed ubuntu 12.04 (armhf) from http://rcn-ee.net/deb/rootfs/precise...2-09-10.tar.xz

2. installed ubuntu-omap-extras (sudo apt-get install ubuntu-omap-extras) after adding TI PPA

3. sudo apt-get install xinit xbmc

4. now I can see if I try to run xinit it gives me error (Xorg log is at http://paste.ubuntu.com/1212685/)

5. I observed omaplfb and pvrsrvkm modules are not loaded so before calling xinit I try loading them and found both to be loaded but while loading omaplfb I got segmentation fault (though lsmod shows the module been loaded)

6. Kernel log can be found at http://paste.ubuntu.com/1212692/

I have been trying this for a month and tried various way to make it up and running.

Any suggestion or comment will be highly appreciated and definitely would be a great help for me.

Also, if anyone can point me out the working kernel + FS (ubuntu or debian) repository for Pandaboard (not ES version) will be an ultimate help. I need source code for working image as later I have some plan to modify some features.

Thanks in advance.

JaseP 09-19-2012 08:23 PM

Is that a PowerVR chipset?! That's the beginning of your problem. Those chips are a PITA (pain in the ...) to get video running...

Found this at the Pandaboard wiki...
http://www.omappedia.com/wiki/PandaB...be_released.3F


All times are GMT -5. The time now is 08:02 AM.