LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-04-2003, 05:19 PM   #1
gmansfield
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Rep: Reputation: 0
unable to run SWAT


I understand that I can use swat to configure the samba server however one problem I am unable to run it. When i use
# chkconfig swat on
However I get the error message
error reading information on service swat: No such file or directory.

I know that it would appear that I don't have the program installed however I am unable to find it in use Add/Remove applications. I am using Redhat 9 and the Gnome desktop.

Can anyone shed any light?
 
Old 09-04-2003, 07:01 PM   #2
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
It'll be on one of your cd's probably, probably the third one, browse 'em.


I think red hat setup's it up to run through xinetd so you'll have to change the line in /etc/xinetd.d/swat

disable=yes
to
disable=no

if it's in there then restart xinetd to get it going

/etc/init.d/xinetd restart

Once you get it installed
 
Old 09-04-2003, 08:04 PM   #3
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
You don't need SWAT. Just edit the smb.conf file. On my computer its located at /etc/samba.

After you configure smb.conf, type smbd -D and nmbd -D. SAMBA will re-read the smb.conf file.

BTW, you need to be as root or su to edit the smb.conf and to run smbd and nmbd.
 
Old 09-05-2003, 04:46 AM   #4
gmansfield
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Yes I can do that but my problem is that I am unable to get to the shared directory from the windows machine. I have in fact edited the conf file myself BUT thought I must be doing something wrong.
Here is a post of the config file. I have a windows workgroup called home and the user graham is a valid login on all machines including the linux one. The shared directory is owned by graham and has been set to share to everyone! Any ideas would be welcome!

#======================= Global Settings =====================================
[global]

workgroup = Home
server string = File Server
hosts allow = 192.168.1.
printcap name = /etc/printcap
load printers = yes
printing = cups
guest ok = yes
guest account = graham
log file = /var/log/samba/%m.log
max log size = 0
security=user
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:
pam password change = yes
obey pam restrictions = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
username map = /etc/samba/smbusers
guest ok = yes
dns proxy = no


[Music]
path = /home/graham/Music
public = yes
writeable = yes
comment = Music files
guest ok = yes
 
Old 09-05-2003, 05:01 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,252

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
To see it in networkneighborhood you need to add the option under your music share

browsable = yes

You should be able to connect to the share using the file manager and by typing in the path.
 
Old 09-05-2003, 05:50 AM   #6
gmansfield
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Many thanks will give that a try this evening and let you know.
Thanks again
Graham
 
Old 09-06-2003, 01:40 PM   #7
gmansfield
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
I am afraid that it didn;t work. I have also set security to share but that dosn't work either. I really am running out of ideas!! Can anyone help please?

Oh one last thing the director "Music" has permissions of "Read,Write & Execute" for owner group and others. Also folder is owned by graham and graham is the group!
 
Old 09-06-2003, 02:01 PM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
I'm extremely weak on Samba but try add a netbios name

netbios name=File Server

Then a least hopefully it's a start and you can see it in windows network neighbourhood, just in case having a firewall set too high can stop samba working
 
Old 09-07-2003, 02:20 AM   #9
gmansfield
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Well thats the thing I CAN see the linux machine in the network neighborhood. Also if I try and browse the linux machine I get prompted for a password and user-name. I use graham as the user and password which is valid for both linux and windows machine. This is then authenticated and I can then see the shared folder. However thats where the problem starts I am unable to browse inside that folder and when I do I can't get access to to not having correct permissions!
 
Old 09-07-2003, 03:20 AM   #10
ZenithRS
LQ Newbie
 
Registered: Dec 2002
Posts: 24

Rep: Reputation: 15
I think you'll find you need to add the password for graham using the smbpasswd command. As root at the command prompt on the samba server, try

smbpasswd graham

You'll be prompted for a new password and to confirm. Use the password that you're using for windows networking on the windows box.

I reserver the right to be wrong though
 
Old 09-09-2003, 11:02 AM   #11
Medievalist
Member
 
Registered: Aug 2003
Distribution: Dead Rat
Posts: 178

Rep: Reputation: 38
You shouldn't need to use the "netbios name" parameter unless your name services are very broken.

Broken name services will make samba psychotic..,.

When you type the command "hostname" at a text prompt do you get the correct name of your host?

The first time you add a samba password you need to use the -a switch to the smbpasswd command, like so:

smbpasswd -a graham

Samba applies the permissions defined in smb.conf, then those that apply at the *nix level. Either can prevent you from accessing something.

You can get swat running, but editing smb.conf will give you a far deeper understanding of how your system works.... and always remember to make a copy of /etc/samba/smb.conf *before* you run swat, because swat will mangle the file beyond all recognition (mostly by removing all comments).

If you have up2date, you can "up2date samba-swat" in order to install swat. You should also "up2date samba" while you are at it.

If you don't have an up2date subscription, then ftp over to updates.redhat.com and get all the samba rpms

samba-2.2.7-3.7.3
samba-common-2.2.7-3.7.3
samba-client-2.2.7-3.7.3
samba-swat-2.2.7-3.7.3

Install them with the command "rpm -Uvh samba*rpm" from a text prompt.

Do *not* run the unpatched versions distributed on any Red Hat CD - there is a security flaw and a couple of bugs too. Unless you are the kind of guy that likes to stand around bus stops blindfolded with your pants down, in which case don't bother loading any patches.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How To install and run SWAT in Fedora Core 4? regnox Linux - Newbie 8 09-02-2005 09:45 AM
Problems with Samba-Swat: Unable to see other Windoze machines on my network. sutherncomfort Linux - Networking 9 02-02-2005 10:30 PM
Volume control is unable to run correctly. Unable to open audio device '/dev/mixer'. sevenreams Slackware 1 05-16-2003 08:29 PM
Unable to access SWAT triplem Linux - Software 1 04-11-2003 04:32 PM
swat does not run? emin Linux - Networking 7 12-27-2002 03:50 AM


All times are GMT -5. The time now is 06:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration