LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-17-2009, 03:58 PM   #1
xan1242
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Rep: Reputation: 0
Unhappy unable to mount drive


Hi!I am running Mandriva Linux 2008 Spring.(because of wine)Anyway,i am unable to mount my another hard drive,it says that is permission denied or when I try mount it from terminal with root privileges,it says that it has some input output error.On windows that disk works perfectly normal.I have linux on sata disk and my ide drive is primary master.Any help?
 
Old 07-17-2009, 04:10 PM   #2
vijay_babu1981
Member
 
Registered: Nov 2004
Location: india
Distribution: fedora 10
Posts: 82

Rep: Reputation: 19
you cannot mount a disk as a non-root user until its entry is present in /etc/fstab and users are allowed to mount.
what error are you getting when you mount as root? what is the file system on that drive which you are trying to mount? what exact commands are you using to mount?
 
Old 07-17-2009, 05:45 PM   #3
xan1242
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Error:
Failed to mount /dev/hda5:Input/Output error etc,etc..Something with chkdisk /f,it is ntfs file system and i use this command:

Code:
mount /dev/hda5
And i have ran terminal as administrator(root).
 
Old 07-17-2009, 06:08 PM   #4
krishnaix
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Rep: Reputation: 0
Hi,
I was also in same kind of situation. In my case it was because RAID failure. Otherwise check the drive controllers.
 
Old 07-17-2009, 08:35 PM   #5
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
Not sure thats enough.

You need to create a directory to mount it too.. Then you need to use the command:

mount -t ntfs /dev/hda5 /mnt/hda5

where /mnt/hda5 is the path to the empty directory you created.

hope that helps .
 
Old 07-17-2009, 09:47 PM   #6
wabbalee
Member
 
Registered: Oct 2006
Location: brisbane - australia
Distribution: ubuntu
Posts: 335

Rep: Reputation: 38
to mount a hard drive (partition) permanently you will have to create a new directory and add a line to your /etc/fstab file:

in a terminal type:
Code:
sudo mkdir /wxp
then you should check the drive notation of the drive (partition) you would want to mount by opening gparted or qparted, install this if you do not have it on your system, should be in the repositories. On my system the drive notations are all sdxy (where x = the letter of your drive and y = the partition number) but on other systems this could be hdxy, that's why you have to check.

then once you have confirmed this info you can copy and paste this line into the static section of your /etc/fstab file as a root:
Code:
/dev/sdxy /wxp ntfs-3g defaults,umask=000,uid=1000,gid=100,auto,rw,user 0 2
changing the drive notation before you save it to whatever your system has assigned it (good chance it is /dev/sda1 or /dev/hda1) and reboot.

this will give you full read and write access to that drive which you will find in the newly created /wxp directory.

good luck.

Last edited by wabbalee; 07-17-2009 at 09:48 PM.
 
Old 07-18-2009, 05:56 AM   #7
xan1242
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Original Poster
Rep: Reputation: 0
hey thanks hern!but i still cant access that drive.i get this error:
Could not enter/mnt/hda5.


I am so close...

And BTW on that ntfs disk is not windows.it is just my storage drive.
And now I had wtf moment.I can access from terminal as root.

Last edited by xan1242; 07-18-2009 at 06:06 AM.
 
Old 07-18-2009, 09:48 AM   #8
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
Ok.

Now we know that works, add the drive to your fstab. Be sure to give it users access.

Here are some good examples:

http://en.wikipedia.org/wiki/Fstab

You can use the umask option to give users access and enjoy .

Last edited by Hern_28; 07-18-2009 at 09:51 AM. Reason: Typo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to mount dvd drive? ruthquip Linux - Newbie 2 09-25-2007 03:01 AM
help! unable to mount usb-drive ! ag2uki Debian 14 09-29-2006 04:38 AM
unable to mount second DVD drive eeenigma SUSE / openSUSE 2 07-11-2006 09:28 AM
unable to mount network drive Ashrack Linux - Networking 1 06-27-2006 12:48 AM
Unable to mount drive. Markness Linux - Hardware 10 04-23-2006 02:03 PM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration