LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-16-2004, 07:29 PM   #1
nav_Lin
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Unable to Mount," Bogus File System Found"


Hi all
I am trying to integrate a block device driver. The driver works the first time, it gets installed and then I am able to mount and do all the operations on the card.

The problem is that after I umount the card, and then try to mount it, says unable to find Fat 0 Sector.
Bogus File system found.

For mounting i use

mount -t vfat /dev/cfa1 /mnt/cf

for unmounting

umount /mnt/cf


Can anyone throw some light on this.

I am working with Linux just for the last few weeks, so Am I am missing something very obvious

Thanks
Regards

Nav
 
Old 04-16-2004, 10:27 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,593

Rep: Reputation: 188Reputation: 188
"I am trying to integrate a block device driver. The driver works the first time, it gets installed and then I am able to mount and do all the operations on the card.

The problem is that after I umount the card, and then try to mount it, says unable to find Fat 0 Sector.
Bogus File system found."

I would try the same test with the normal vfat driver that comes with Linux and see if you get the same error. If you don't then I would say that there is a bug in the block device driver that you are trying to integrate.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount windows harddrive in Linux: "already mounted" Xandor Linux - Software 10 11-28-2005 04:00 PM
Problems w/ Installation -- "Unable to detect and mount CD-ROM"? Sabriel Dyrim Ubuntu 1 09-20-2005 04:38 PM
unable to mount USB camera: "No medium found" in Fedora Core 2 meonkeys Fedora 0 05-20-2004 03:35 PM
Recompiled kernel error - "Unable to mount root fs on 21:42" vetro91 Linux - Software 3 02-17-2003 08:08 PM
error:"kernel panic: VFS: Unable to mount root fs":-( shyguy Linux - Newbie 1 07-23-2001 05:03 PM


All times are GMT -5. The time now is 04:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration