LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to Mount," Bogus File System Found" (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-mount-bogus-file-system-found-171095/)

nav_Lin 04-16-2004 06:29 PM

Unable to Mount," Bogus File System Found"
 
Hi all
I am trying to integrate a block device driver. The driver works the first time, it gets installed and then I am able to mount and do all the operations on the card.

The problem is that after I umount the card, and then try to mount it, says unable to find Fat 0 Sector.
Bogus File system found.

For mounting i use

mount -t vfat /dev/cfa1 /mnt/cf

for unmounting

umount /mnt/cf


Can anyone throw some light on this.

I am working with Linux just for the last few weeks, so Am I am missing something very obvious

Thanks
Regards

Nav

jailbait 04-16-2004 09:27 PM

"I am trying to integrate a block device driver. The driver works the first time, it gets installed and then I am able to mount and do all the operations on the card.

The problem is that after I umount the card, and then try to mount it, says unable to find Fat 0 Sector.
Bogus File system found."

I would try the same test with the normal vfat driver that comes with Linux and see if you get the same error. If you don't then I would say that there is a bug in the block device driver that you are trying to integrate.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites


All times are GMT -5. The time now is 06:41 AM.