LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to mount Audio Disc (http://www.linuxquestions.org/questions/linux-newbie-8/unable-to-mount-audio-disc-692543/)

RAFAL 12-23-2008 01:53 PM

Unable to mount Audio Disc
 
Hi,

With new opensuse 11.1 I get following error when I put CD in the drive:
Code:

Unable to mount Audio Disc
Cannot find drive /dev/sr0

I have observed following. When I log off with the user, put CD and then log on - everything works fine. I see CD icon on my desktop, I can eject it and insert again.

What could be wron here? Why I cannot mount CD without logoff.

Mounting other devices, like USB drive works fine (though is a little strange compared to Opensuse 11. For instance: for USB drive I get folder /media/WD-1TB_ and not /media/WD-1TB. I see /media/WD-1TB created by root. I can read the data fronm this drive)

Here is output from "ls -l /dev/cd* /dev/sd*" command:
Code:

lrwxrwxrwx 1 root root    3 2008-12-23 16:27 /dev/cdrom -> sr0
lrwxrwxrwx 1 root root    3 2008-12-23 16:27 /dev/cdrw -> sr0
brw-rw---- 1 root disk 8, 0 2008-12-23 16:27 /dev/sda
brw-rw---- 1 root disk 8, 1 2008-12-23 16:27 /dev/sda1
brw-rw---- 1 root disk 8, 2 2008-12-23 16:27 /dev/sda2
brw-rw---- 1 root disk 8, 3 2008-12-23 16:27 /dev/sda3
brw-rw---- 1 root disk 8, 4 2008-12-23 16:27 /dev/sda4
brw-rw---- 1 root disk 8, 5 2008-12-23 16:27 /dev/sda5
brw-rw---- 1 root disk 8, 6 2008-12-23 16:27 /dev/sda6
brw-rw---- 1 root disk 8, 7 2008-12-23 16:27 /dev/sda7
brw-rw---- 1 root disk 8, 8 2008-12-23 15:27 /dev/sda8


any ideas?

regards
Rafal

RAFAL 12-23-2008 02:00 PM

Quote:

Originally Posted by RAFAL (Post 3385313)
Hi,
Mounting other devices, like USB drive works fine (though is a little strange compared to Opensuse 11. For instance: for USB drive I get folder /media/WD-1TB_ and not /media/WD-1TB. I see /media/WD-1TB created by root. I can read the data fronm this drive)

regarding this part I think that something was not deleted properly in media directory. Here what I see there:
Code:

linux-ugu6:/media # ls -l
total 28
-rw-r--r-- 1 root root  72 2008-12-23 20:50 .hal-mtab
-rw------- 1 root root    0 2008-12-23 19:59 .hal-mtab-lock
drwx------ 2 root root 4096 2008-12-20 22:45 OCZ
drwx------ 2 root root 4096 2008-12-20 21:56 SU1110.001
drwx------ 2 root root 4096 2008-12-20 22:25 WD-1TB
drwxrwxrwx 1 root root 8192 2008-12-23 11:43 WD-1TB_
drwxr-xr-x 2 root root 4096 2008-10-09 23:19 xmms_audio_cd

...so three folders are older:
Code:

drwx------ 2 root root 4096 2008-12-20 22:45 OCZ
drwx------ 2 root root 4096 2008-12-20 21:56 SU1110.001
drwx------ 2 root root 4096 2008-12-20 22:25 WD-1TB

I will try to delete them, but don't know why system has not done it.

RAFAL 12-24-2008 06:13 AM

described problem only affects CD Audio. CD with data is mounted correctly.
Any ideas?
regards
Rafal


All times are GMT -5. The time now is 06:36 PM.