LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2012, 03:26 PM   #1
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Rep: Reputation: Disabled
unable to login to GUI mode


Hi all,

OS: openSUSE 10.3 (X86-64)

I am unable to login to GUI (eventhough run-level is 5) and every time i boot up the system it goes directly to command line (run-level3).
This is used to login to GUI earlier. Not sure now what happend.
I see following messages when system is booting up.
Code:
Master Resource Control: Running /etc/init.d/after.local
doneMaster Resource Control: runlevel 5 has been reached
Failed services in runlevel 5: xinetd avahi-dnsconfd
Skipped services in runlevel 5: smbfs xend xendomains
and trying to start x , gives following error message

Code:
startx
xauth:  creating new authority file /root/.serverauth.6995

Fatal server error:
Can't read lock file /tmp/.X0-lock

giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
I find following in /var/log/Xorg.0.log

Code:
# egrep "EE|WW" /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/local" does not exist.
(WW) The directory "/usr/share/fonts/PEX" does not exist.
(WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
(WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
(WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/baekmuk" does not exist.
(WW) The directory "/usr/share/fonts/japanese" does not exist.
(WW) The directory "/usr/share/fonts/kwintv" does not exist.
(WW) The directory "/usr/share/fonts/CID" does not exist.
(WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
(WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
(WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
(WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
(WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
(WW) The directory "/usr/share/fonts/xtest" does not exist.
(II) Loading extension MIT-SCREEN-SAVER
(WW) Jan 25 13:38:44 NVIDIA(0): TwinView requested, but only 1 display devices found.
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1920x1080+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1920x1080+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1600x1024+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1600x1024+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1400x1050+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1400x1050+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1280x1024+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1280x1024+0+0"; unable to
(WW) Jan 25 13:38:44 NVIDIA(0):     map to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1280x960+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1280x960+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1152x864+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1152x864+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:1024x768+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:1024x768+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:800x600+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:800x600+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
(WW) Jan 25 13:38:44 NVIDIA(0): Invalid display device in Mode Description
(WW) Jan 25 13:38:44 NVIDIA(0):     "DFP-0:640x480+0+0"
(WW) Jan 25 13:38:44 NVIDIA(0): Not using mode description "DFP-0:640x480+0+0"; unable to map
(WW) Jan 25 13:38:44 NVIDIA(0):     to display device
Thaks in advance!
 
Old 01-26-2012, 03:32 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
It's a wild guess, but check if your system is not full (especially /tmp)

df -h
 
Old 01-26-2012, 03:40 PM   #3
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi sycamorex,

No, the system is NOT full.
/tmp is under /

Code:
 # df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             405G   19G  387G   5% /
Code:
/tmp # du -sh
du: cannot access `./.X0-lock': Permission denied
4.0M    .
 
Old 01-26-2012, 03:45 PM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
What's the output of :
Code:
ls -al /tmp | grep .X0-lock
 
Old 01-26-2012, 03:54 PM   #5
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi sycamorex,

I logged in as root

Code:
 # ls -al /tmp/ |grep .X0-lock
ls: cannot access /tmp/.X0-lock: Permission denied
??????????  ? ?      ?            ?            ? .X0-lock
 
Old 01-26-2012, 03:55 PM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
Found somewhere that running fsck from a live cd should solve this problem.
Try it and see what happens.
 
Old 01-26-2012, 03:56 PM   #7
paladin.michael
Member
 
Registered: Jun 2011
Location: Danbury, CT, USA
Distribution: Kubuntu, Slackware, Debian, FreePBX
Posts: 72

Rep: Reputation: 22
ok, try deleting the /tmp/.X0-lock file. e.g.
Quote:
# rm /tmp/.X0-lock
Note I'd recommend trying this as root or using su or sudo.

If you get an error about a stale NFS handle (which I've read can happen) you'll want to force an fsck on the filesystem /tmp is located on.
Quote:
# fsck /dev/sda2
If you don't get the goofy nfs error but still can't dlete the file, you can also use lsof to determine if a process is locking the file.
Quote:
# lsof /tmp/.X0-lock
and then kill it either by using kill <PID> where <PID> is the process ID or by using killall <name> where <name> is the name of the process.

Once you manage to delete the file try rebooting
Quote:
# reboot now
generally works, could also use
Quote:
# shutdown -r now
I hope this is helpful, I didn't see a lot of in depth info on this problem in my searching.
 
Old 01-26-2012, 04:10 PM   #8
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi sycamorex,

Do i need to login via live CD to fsck ?
If so, where can i find to download ISO to make it ?

Hi paladin.michael,

Code:
 # rm /tmp/.X0-lock
rm: cannot remove `/tmp/.X0-lock': Permission denied
Code:
 #  lsof /tmp/.X0-lock
lsof: status error on /tmp/.X0-lock: Permission denied

 # lsof |grep X0
 # echo $?
 1
 
Old 01-26-2012, 04:15 PM   #9
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
Quote:
Originally Posted by linuxandtsm View Post
Hi sycamorex,

Do i need to login via live CD to fsck ?
If so, where can i find to download ISO to make it ?
I'm not sure if your suse installation medium works as a live cd, if it does you can use it.
If not, this live cd works is quite good for all sorts of troubleshooting.
http://partedmagic.com/doku.php?id=downloads

Alternatively, if you've got any other linux installed on that computer you could do it from there. The key thing is that the file system mustn't be mounted when you run fsck on it.
 
Old 01-26-2012, 04:22 PM   #10
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi sycamorex,

Is this download free of cost ?
 
Old 01-26-2012, 04:25 PM   #11
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
Quote:
Originally Posted by linuxandtsm View Post
Hi sycamorex,

Is this download free of cost ?
Yes, it is (you can donate money ONLY if you want). Download that one: "Most people will only need this file"
 
Old 01-27-2012, 09:39 AM   #12
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Ok i have the live CD now.
Could anybody please provide steps for fsck with live CD ?
Thanks in advance!
 
Old 01-27-2012, 09:57 AM   #13
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200Reputation: 1200
Quote:
Originally Posted by linuxandtsm View Post
Ok i have the live CD now.
Could anybody please provide steps for fsck with live CD ?
Thanks in advance!
Boot the computer with your Live CD now (you have burned the .iso image onto a CD, haven't you?)
Once it's loaded, open a terminal.
As root, issue the fsck command that Paladin posted before (that's assuming that the partition in question is /dev/sda2 - that's where your suse system is installed, isn't it?)

If something is unclear, do not hesitate to ask for clarification. Better safe than sorry
 
Old 01-27-2012, 01:51 PM   #14
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi sycamorex,

Thanks for introducing a great tool (PartedMagic) to me!!!.

Ok...i logged into shell with Live CD and did fsck on /dev/sda2 and it is clean!
Then i treid to remove "/tmp/.X0-lock" by mounting "/" on /mnt but surprisingly i couldn't find it there ???

And with Live CD ...GUI is working fine ...it directly booted to GUI mode !!!!!

so what could be the problem here ????
 
Old 01-27-2012, 02:01 PM   #15
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
Upgrading to OpenSuSE 11.4 might fix some problems

Quote:
Originally Posted by TroN-0074 View Post
Here is the link http://software.opensuse.org/121/en

you have Internet connection so download the Network upgrade, burn it to CD then reboot your computer with the CD in and follow the steps.

I will suggest that for the upgrading purpose you actually plug your computer to a router instead of doing it wireless.

If your current installation has Gnome desktop manager Gnome 3 is what you are going to get final product. If your computer can't handle Gnome 3 there is a way to roll it back turning the roll back mode.

Also depend on your connection you might need to leave it upgrading overnight

Good luck to you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable login via GUI but can login via Putty (command line) linuxandtsm Linux - Newbie 10 06-09-2011 03:08 PM
i m running ubuntu 8.10 .unable to login as a user in gui mode. chandan766 Linux - Newbie 1 04-05-2009 06:03 PM
unable to login in GUI mode cjayps Linux - Desktop 1 11-27-2006 09:11 PM
Unable to Log in GUI Mode cat67 Ubuntu 2 01-17-2006 08:24 PM
cannot login to gui mode.. aaru_ali Linux - Newbie 3 11-08-2004 09:23 AM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration