LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-09-2004, 02:17 PM   #1
kairamr
LQ Newbie
 
Registered: Jun 2004
Location: New York
Distribution: RPM
Posts: 2

Rep: Reputation: 0
Unable to login as local user with vsftpd running on the server


RedHat Linux 9
My /etc/vsftpd.conf contains
anonymous_enable=YES
local_enabe=YES
write_enable=YES
anon_upload_enable=YES
local_umask=022
connect_from_port_20=YES
ftpd_banner=Welcome to Raj FTP Servicelisten=NO

My /etc/xinetd.d/vsftpd contains
service ftp
{
socket_type = stream
wait = no
user = root
server = /usr/local/sbin/vsftpd
nice = 10
disable = no
}
After I restart the server with
[root@CEEYFLC init.d]# ./xinetd restart
Stopping xinetd:
Starting xinetd:

I have a user account "rajk" on the unix host.
I am now at a Win2K host and start ftp client and try to login as user rajk
I am getting "530 Login incorrect Login Failed"

Try login as anonymous - Login successful but would not let me change to /tmp directory

What else needs to be done in the conf file to be able to use ftp ?. Please help
 
Old 06-09-2004, 02:25 PM   #2
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Hi,

Try backing up your file with a different name and try using this one. This is mine, and I am able to sftp into my machine no problem.

#Begin /etc/vsftp/vsftp.cnf

###################################################################

# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
# Uncomment this to allow local users to log in.
local_enable=YES
# Uncomment this to enable any form of FTP write command.
write_enable=YES
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to jeffs FTP service.

pam_service_name=vsftpd
userlist_enable=YES
userlist_deny=NO
#enable for standalone mode
listen=YES
tcp_wrappers=YES

###############################################################################

Dont know much about this, but it's worth a try. I bet the lines in the last potion are what you need, the "userlist_enable=YES" in particular.

Good luck,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsFTPd local user can't create directories nuzzy Linux - Software 11 12-04-2011 10:45 PM
vsftpd 2.0.3 ftp authentication failing for local user scooger Linux - Software 1 05-17-2005 10:48 AM
FTP Server Up and running... how do I hide ftp users from local login screen? joe1031 Mandriva 2 03-18-2005 04:24 PM
Running X as local user Ephracis Linux - Software 1 11-05-2004 04:07 PM
vsftpd : process running as user nobody left after login ? markus1982 Linux - Security 4 01-18-2003 02:49 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration