LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-07-2009, 02:59 AM   #1
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Rep: Reputation: 36
unable to login


hi Guys , I m completely new to this environment.
I m working in linux gnu operating type.

I have root user access to this machine and i have created a user named scott using useradd command then set its password using passwd command.
Now my problem is i m not able to loggin using this new user scott.
after inputting password it says "access denied"
however i can use su - scott using root. this user is also in /etc/passwd file.
I m using ssh to connect to this server.
Is there any other setting i need to configure .Please help i m begginer here.
This is my first question to forum .
 
Old 09-07-2009, 03:08 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
If the user scott is on the local machine and you are ssh'ing the remote machine logging as scott then the remote machine should also have the user scott.
 
Old 09-07-2009, 03:14 AM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
just login via root and run

passwd scott

and it'll enable you to change scott's passwd. Make sure you know what you've typed, and remember Linux is case sensitive.
You do NOT have to have the same user on 2 different machines.
If you want to login as scott via ssh, when you are eg fred on a different box it's

fred@box1> ssh -l scott box2

that's a lowercase 'L'
http://linux.die.net/man/1/ssh
 
Old 09-07-2009, 03:35 AM   #4
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
My problem is not yet solved.

I will explain my problem is detail.

I using using window machine as client machine.
I m using putty (Client application) to connect with linux gnu based machine.
i have created scott user and also given password to it.but i m not able to loggin using scott user.
There is an inbuilt checkbox for ssh login in putty.

Last edited by pinga123; 09-07-2009 at 03:38 AM.
 
Old 09-07-2009, 03:39 AM   #5
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by linuxlover.chaitanya View Post
If the user scott is on the local machine and you are ssh'ing the remote machine logging as scott then the remote machine should also have the user scott.
both users are created on remote machine(server).
 
Old 09-07-2009, 04:29 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Have you denied any user in sshd_config ?
 
Old 09-07-2009, 04:36 AM   #7
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
As i mentioned in my query i m new to unix and dont know much about sshd_config file.
But the server i m using is shared one may be someone has did it which i m completely unaware.
By the way could you please explain me the use of this config file and where is it located so that i can post the content of the file here.
 
Old 09-07-2009, 04:39 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
the file is located in /etc/ssh in Red Hat systems.
 
Old 09-07-2009, 05:18 AM   #9
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
-rw------- 1 root root 111892 Jun 4 2008 moduli
-rw-r--r-- 1 root root 210 Mar 26 17:08 ssh_host_rsa_key.pub
-rw------- 1 root root 887 Mar 26 17:08 ssh_host_rsa_key
-rw-r--r-- 1 root root 319 Mar 26 17:08 ssh_host_key.pub
-rw------- 1 root root 515 Mar 26 17:08 ssh_host_key
-rw-r--r-- 1 root root 590 Mar 26 17:08 ssh_host_dsa_key.pub
-rw------- 1 root root 668 Mar 26 17:08 ssh_host_dsa_key
-rw-r--r-- 1 root root 1417 Apr 8 18:02 ssh_config
-rw-r--r-- 1 root root 1417 Jul 22 12:54 ssh_config.tmp
-rw------- 1 root root 3033 Sep 4 13:49 sshd_config
[root@test etc]# vi sshd_config
[root@test etc]# cat sshd_config
cat: sshd_config: No such file or directory
Why i m getting this problem.
I m logged in using root user.
 
Old 09-07-2009, 05:23 AM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You are not in the directory where the file is. You should use vi or cat to open file from inside /etc/ssh directory.
 
Old 09-08-2009, 03:43 AM   #11
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Original Poster
Rep: Reputation: 36
Content of my ssh_config files:
# $OpenBSD: ssh_config,v 1.19 2003/08/13 08:46:31 markus Exp $

# This is the ssh client system-wide configuration file. See
# ssh_config(5) for more information. This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
# 1. command line options
# 2. user-specific file
# 3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for various options

# Host *
# ForwardAgent no
ForwardX11 yes
# RhostsRSAAuthentication no
# RSAAuthentication yes
# PasswordAuthentication yes
# HostbasedAuthentication no
# BatchMode no
# CheckHostIP yes
# AddressFamily any
# ConnectTimeout 0
# StrictHostKeyChecking ask
# IdentityFile ~/.ssh/identity
# IdentityFile ~/.ssh/id_rsa
# IdentityFile ~/.ssh/id_dsa
# Port 22
# Protocol 2,1
# Cipher 3des
# Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
# EscapeChar ~
Host *
GSSAPIAuthentication yes
# If this option is set to yes then the remote X11 clients will have full access
# to the local X11 display. As virtually no X11 client supports the untrusted
# mode correctly we set this to yes.
ForwardX11Trusted yes
 
Old 09-08-2009, 04:39 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
that seems ok to me.
 
Old 09-08-2009, 05:10 AM   #13
Amy84
LQ Newbie
 
Registered: Aug 2009
Location: Netherlands
Distribution: CentOS 5.3
Posts: 27

Rep: Reputation: 15
Take a look in your sshd_config. Make sure PasswordAuthentication looks like this: PasswordAuthentication yes
 
Old 09-08-2009, 06:08 AM   #14
29t88
Member
 
Registered: Jan 2009
Distribution: CentOS 5.3
Posts: 62

Rep: Reputation: 17
When u say etc/ssh i have the same problem in CentOS Would this be the same directory>?
 
Old 09-08-2009, 07:04 AM   #15
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Yes its in the same directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to login to NIS client machine(Ubuntu) using NIS login user name crazymoonboy Linux - Server 10 05-08-2015 08:28 AM
unable to login as user; can login as root. rksanders Debian 24 02-09-2011 09:01 AM
unable to graphic login, but text login is OK! cqmyg5 Slackware 2 01-16-2007 10:05 PM
unable to login because no login prompt DX2 Linux - General 1 05-25-2005 01:33 PM
unable to login due to login expiry niiha Programming 2 09-02-2004 11:50 AM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration