LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2012, 06:44 PM   #1
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Rep: Reputation: Disabled
Unable to log in to user account


Hello. I'm using Linux Mint 9 on a Eepc 701. THe system has a single user account, and /home is moved to an SDHC card. Setup works well.

Occasionally I'll run out of battery and so system force shuts down. When this happened today I plugged in and restarted. When logging in to my user account the system returns me to the login screen - no indication that the account has failed authentication, but the login is refused.

I can log in as root no problem. Tried changing the password in a terminal, didn't work. Have rebooted and shut down - nothing.

Can anyone suggest any further steps to get this working please. I really don't want to reinstall if a I can help it.

Thanks
 
Old 07-08-2012, 06:48 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Usually this is a sign that something is wrong with your home-directory. Log in as root and launch the commands
Code:
ls -l /home
mount
 
Old 07-08-2012, 07:35 PM   #3
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
ls -l /home returned this:

Code:
total 20
drwsr-sr-x 2 macburp root 16384 2012-01-12 19:04 lost+found
drwsr-sr-x 59 macburp macburp 4096 2012-07-09 19:04 macburp
Ummm. The SDHC card is 16GB, but I used to use a 4GB one. Could this be the issue?

fstab line for SDHC card is:

Code:
UUID=[number] /home ext2 defaults,user,exec,noatime, errors=continue 0 0
Perhaps there should be no space between noatime and errors=continue?

Last edited by Macburp; 07-08-2012 at 07:44 PM.
 
Old 07-08-2012, 07:49 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Could be, give it a try ..

BTW, I've never seen lost+found dir owned by other than root:root.
Also, never seen suid+sgid perms set on either of those dirs either.

Last edited by chrism01; 07-08-2012 at 07:52 PM.
 
Old 07-08-2012, 07:52 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Yes, there should be no space between the options. Just to make that clear:
You usually used a 4GB card and replaced it with a 16GB card. This shouldn't matter, the 701 can read 16GB cards, I used one myself with a 16GB card. Have you adapted the UUID in fstab after the change?
What is the output of
Code:
mount
 
Old 07-08-2012, 07:52 PM   #6
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Well, I took out the space in fstab, but I still can't log in .

Any ideas?
 
Old 07-08-2012, 08:09 PM   #7
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: Mint
Posts: 410

Rep: Reputation: 82
Extra spaces in fstab don't mean anything, options can be separted by a space or comma. I suspect the UUID of the new SD card is different, so it's not recognized. Even two identical cards would have a different UUID. I'd suggest changing it to the device string, like /dev/sdb1 or whatever.
 
Old 07-08-2012, 08:28 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Quote:
Originally Posted by guyonearth View Post
Extra spaces in fstab don't mean anything, options can be separted by a space or comma.
Sorry, but no. If I do extra spaces in the options for the mountpoint /server on my machine I get this:
Code:
root@dragon ~ :) # mount /server
[mntent]: line 9 in /etc/fstab is bad
mount: can't find /server in /etc/fstab or /etc/mtab
(and vim marks this as error). It works fine without the spaces.
 
Old 07-08-2012, 08:36 PM   #9
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by guyonearth View Post
I suspect the UUID of the new SD card is different, so it's not recognized. Even two identical cards would have a different UUID. I'd suggest changing it to the device string, like /dev/sdb1 or whatever.
When I changed SD Cards I updated the UUID, so the UUID is correct. When I log in as root, /home mounts. I just can't log in as me
 
Old 07-08-2012, 08:42 PM   #10
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: Mint
Posts: 410

Rep: Reputation: 82
Quote:
Originally Posted by TobiSGD View Post
Sorry, but no. If I do extra spaces in the options for the mountpoint /server on my machine I get this:
Code:
root@dragon ~ :) # mount /server
[mntent]: line 9 in /etc/fstab is bad
mount: can't find /server in /etc/fstab or /etc/mtab
(and vim marks this as error). It works fine without the spaces.
It must be a quirk of the format you're using, because I've edited many fstabs, and have never had an issue like that. I don't use vim to do it.
 
Old 07-08-2012, 08:46 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
It would be hard to believe that the text editor causes this, especially when it is vim, which is one of the most used text editors.
Anyways, since this seemingly can cause issues on some OSes it is better to avoid such a format.

@Macburp: Still waiting for the output of the mount-command.
Also, try it with a newly created user. If that works it is likely that it is a misconfiguration in your users settings that is causing this.
 
Old 07-08-2012, 08:47 PM   #12
guyonearth
Member
 
Registered: Jun 2012
Location: USA
Distribution: Mint
Posts: 410

Rep: Reputation: 82
Quote:
Originally Posted by Macburp View Post
When I changed SD Cards I updated the UUID, so the UUID is correct. When I log in as root, /home mounts. I just can't log in as me
Then you've got some kind of weird permission issue going on. Try simplifying it. This is what the line in my fstab looks like (I also have home on a different drive):

UUID=3edb3098-3c74-441b-9102-fbb46e01b85f /home ext4 defaults 0 2
 
Old 07-08-2012, 08:59 PM   #13
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
@TobiSGD, here's the result of mount:

Code:
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sdb1 on /home type ext2 (rw,nosuid,nodev,noatime,errors=continue)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)
//192.168.1.32/Xvids on /home/macburp/Highview type cifs (rw,mand)
@guyonearth, I'm slightly reluctant to change fstab settings for the SD ced as I had serious problems getting it to work initially. I'll keep it in mind.
 
Old 07-08-2012, 09:17 PM   #14
Macburp
LQ Newbie
 
Registered: Jan 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
Also, try it with a newly created user. If that works it is likely that it is a misconfiguration in your users settings that is causing this.
Well, I created a new account and was able to log in OK. Still can't log in to the original account. How do I do a disk check on the SD card to see if there are any errors?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I cant log in to my Linux Mint user account using my user name and password itstraining Linux - Newbie 11 04-26-2012 08:20 PM
"To add a new user account, log in to the root account" how do i do this (im new) pierce77x Linux - Newbie 4 12-28-2008 03:44 PM
Can't log into user account nenochka9 Linux - Security 11 01-23-2006 07:33 AM
unable to log in to a user account cheema Mandriva 1 12-25-2004 10:34 AM
ftp cannot log in using new user account wendallsan Linux - Software 0 12-07-2004 09:31 PM


All times are GMT -5. The time now is 10:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration