LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-15-2008, 10:38 PM   #1
hisuresh
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Rep: Reputation: 0
Question unable to load network bootable image using etherboot


Hi i am new user to Linux.
I am using centOS 5.2 distribution.
I am installing diskless Linux cluster.
I am using Etherboot.
I download boot rom form http://www.rom-o-matic.net/.
I put this image in floppy disk.
i configured dhcp,tftp servers.
it seems that they are working.
the dhcp server is assigning the client with ip address and tftp downloading vmlinuz.nbi. After that i am getting the following message:


Boot from (N)etwork or (Q)uit?
Searching for server
(DHCP)....
Me: 10.0.0.2, DHCP: 10.0.0.1, TFTP: 10.0.0.1

Loading 10.0.0.1:/vmlinuz.nbi ................TFTP download complete, but
Unable to load file.
<sleep>
<abort>
Probing for pci nic ...
Probing for isa nic....
<sleep>


this message is repeating several times.
I anyone know what is the problem please help me i am eagerly waiting for replies. Thank you

Last edited by hisuresh; 11-15-2008 at 10:39 PM.
 
Old 11-16-2008, 03:15 PM   #2
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 148

Rep: Reputation: 15
Looks like you need to edit the kickstart file to point to you PXE server. Try checking as per http://www.opensourcehowto.org/how-t...a-install.html
 
Old 11-16-2008, 11:23 PM   #3
hisuresh
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tmick View Post
Looks like you need to edit the kickstart file to point to you PXE server. Try checking as per http://www.opensourcehowto.org/how-t...a-install.html

yes in this website everything is related to pxe-boot environment, but i am using etherboot now. thanks for ur reply
 
Old 11-18-2008, 12:24 AM   #4
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 148

Rep: Reputation: 15
try this link: http://etherboot.org/wiki/doc
it has troubleshooting.
As I said before it looks like you have the wrong file path set in etherboot (soon to be gPXE ) follow this link http://etherboot.org/wiki/filename_specification and you will see what I mean.
 
Old 11-19-2008, 03:12 AM   #5
hisuresh
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tmick View Post
try this link: http://etherboot.org/wiki/doc
it has troubleshooting.
As I said before it looks like you have the wrong file path set in etherboot (soon to be gPXE ) follow this link http://etherboot.org/wiki/filename_specification and you will see what I mean.



K
now it got working.
i changed the kernel.
now problem is NFS mounting file systems.
Here i am creating root device for kernel by using,


mknod /dev/nfs c 0 255
rdev /tftpboot/bzImage


But after some time i could not find nfs in dev directory. whats wrong.
Plz post if u have any idea. Thank u very much
 
Old 11-19-2008, 08:33 PM   #6
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 148

Rep: Reputation: 15
Follow this and see if it helps http://www.centos.org/docs/5/html/De...US/ch-nfs.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ipw2200 - Unable to load ucode, unable to load firmware blizinsk Linux - Wireless Networking 2 10-10-2004 09:28 AM
need Etherboot ROM image for a 3C589 PCMCIA network card lothario Linux - Networking 0 10-07-2004 06:58 AM
Error while installing RH9 over the network using etherboot psingh Linux - Laptop and Netbook 2 11-17-2003 03:58 PM
Error while installing RH9 over the network using etherboot psingh Linux - Newbie 0 11-16-2003 08:39 PM
unable to create a bootable cd from iso image abhijit Linux - Newbie 4 09-01-2003 05:16 PM


All times are GMT -5. The time now is 10:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration