LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-03-2006, 05:03 AM   #1
Black Hawk
Member
 
Registered: Mar 2006
Distribution: Ubuntu 7.10
Posts: 38

Rep: Reputation: 15
unable to launch shell within IceWM


Hi.
I just installed IceWM. I'm unable to launh bash or any other shell within it. I can launch other applications like calculator. I'm running Debian Sarge with a 2.6 kernel.
I want to be able to launch a shell within x.

Thanks in advance
 
Old 12-03-2006, 05:37 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,594

Rep: Reputation: 124Reputation: 124
What error messages do you get? Can you swith to the first virtual console (Ctrl+Alt+F1, if it works you get back with Ctrl+Alt+F7) and see if there are any of these?
 
Old 12-03-2006, 06:14 AM   #3
Black Hawk
Member
 
Registered: Mar 2006
Distribution: Ubuntu 7.10
Posts: 38

Original Poster
Rep: Reputation: 15
I don't know how to post images so a screenshot of the info can be found here

http://www.planteinfo.net/gvs/personal/errormessage.jpg
 
Old 12-03-2006, 06:24 AM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,594

Rep: Reputation: 124Reputation: 124
Well, that doesn't tell me much and I guess there are more errors. You could edit your ~/.xinit file and insert a line before "exec /usr/bin/icewm" like "/usr/X11R6/bin/xterm &". This should give you an xterm in IceWM from which you can try to start another xterm and see what error messages this gives.
Maybe just the links are broken or something like this.
 
Old 12-03-2006, 09:44 AM   #5
Black Hawk
Member
 
Registered: Mar 2006
Distribution: Ubuntu 7.10
Posts: 38

Original Poster
Rep: Reputation: 15
Now I've tried using openbox too and I have the exact same problem.
Hmm seems like there where no shells installed, even though the shurtcuts where in the startmenu. I've installed xterm now and it works.

Last edited by Black Hawk; 12-03-2006 at 10:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to launch two shell scripts at once beeblequix Linux - Newbie 1 10-18-2006 09:00 AM
Launch CGI script from shell alex986best Linux - Newbie 2 06-28-2006 07:28 AM
shell script launch two apps webreake Programming 4 04-01-2006 08:29 PM
Unable to launch X apps with non login root shell kc00l Slackware 2 11-24-2003 04:32 AM
Unable to launch UnrealGold??? trey85stang Linux - Games 7 11-10-2003 10:51 PM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration