LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 01-30-2012, 12:55 PM   #1
paruhang
Member
 
Registered: Aug 2011
Location: /home
Posts: 96

Rep: Reputation: Disabled
unable to install vlc player for centos 6.2


hi everybody,
i have download centos 6.2 and while installing vlc player from "http://blog.ask4itsolutions.com/2011/07/25/how-to-install-vlc-player-on-rhel-6-x-centos-6-x-32-bit-64-bit-x86_64-using-script/"
i have some error messages so i can't install vlc on my laptop

# sh vlc6-installation.sh




Press (R32) to Install VLC on RHEL 6.x on 32bit
Press (R64) to Install VLC on RHEL 6.x on 64bit

Press (C32) to Install VLC on CentOS 6.x on 32bit
Press (C64) to Install VLC on CentOS 6.x on 64bit
Press (E) to Exit anytime

Please Enter your Selection:C32
You have selected VLC Installation for CentOS 6.x.... Just Sit back and Relax.....
You are running as a root, Moving to next step.....
You cannot continue, CentOS release 6.2 (Final), CentOS Linux version must be 6.x

so i want to install vlc player on my laptop, is it possible to install from above blog?
 
Old 01-30-2012, 01:51 PM   #2
nonamedotc
Member
 
Registered: Mar 2011
Posts: 343

Rep: Reputation: Disabled
As far as I know, VLC is available in the repositories (RPMforge). You should be able to install it using yum unless you are specifically looking to install it using the script.

Last edited by nonamedotc; 01-30-2012 at 01:52 PM.
 
Old 01-30-2012, 07:08 PM   #3
paruhang
Member
 
Registered: Aug 2011
Location: /home
Posts: 96

Original Poster
Rep: Reputation: Disabled
hi, iam using 32 bits centos 6.2 i have problem installing vlc in my laptop. i have download rpmforge-release-0.5.2-2.el5.rf.i386.rpm from this link

http://packages.sw.be/rpmforge-relea...l5.rf.i386.rpm

and follow the instruction as given

# rpm -ivh rpmforge-release-0.5.2-2.el5.rf.i386.rpm
# yum install vlc -y

such error occurs

# yum install vlc -y

Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: ftp.iitm.ac.in
* extras: ftp.iitm.ac.in
* rpmforge: ftp-stud.fht-esslingen.de
* updates: ftp.iitm.ac.in
http://mirror.centos.org/centos-6/6....ta/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: tejas-barot-vlc. Please verify its path and try again

so what is error and how can i fix this error and how can i install vlc on my laptop. any kinds of ideas and suggestions are accepted.
 
Old 01-30-2012, 11:58 PM   #4
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Dehradun, Uttarakhand, India
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,412

Rep: Reputation: 303Reputation: 303Reputation: 303Reputation: 303
Try this:

Quote:
# rm -f/var/lib/rpm/__db*
# rpm –rebuilddb
# yum clean all
and then

Quote:
# yum install vlc
and check this page also:

https://www.centos.org/modules/newbb...topic_id=32969
 
Old 01-31-2012, 05:09 AM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,112

Rep: Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591
You installed the repo file for cent5
and you are running cent 6
6 can not use the repo for 5
the two operating systems are NOT compatible

also you might want to READ the cent wiki
http://wiki.centos.org/

http://wiki.centos.org/AdditionalResources/Repositories
the INSTRUCTIONS for installing rpmforge on 6
http://wiki.centos.org/AdditionalRes...ories/RPMForge

and install the repo for cent6

when you click on the repo file ( for the 32 bit " rpmforge-release-0.5.2-2.el6.rf.i686.rpm" )in firefox you can choose to INSTALL or download
select install

Last edited by John VV; 01-31-2012 at 05:16 AM.
 
Old 02-01-2012, 04:05 PM   #6
paruhang
Member
 
Registered: Aug 2011
Location: /home
Posts: 96

Original Poster
Rep: Reputation: Disabled
hi everybody,
i was not able to install vlc player on my laptop so i have follow the above instructions but such error occurs while downloading rpmforge-release-0.5.2-2.el6.rf.i686.rpm and installing.


[root@binary Downloads]# rpm -ivh rpmforge-release-0.5.2-2.el6.rf.i686.rpm
Preparing... ########################################### [100%]
file /etc/apt/sources.list.d/rpmforge-extras.list from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/apt/sources.list.d/rpmforge-testing.list from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/apt/sources.list.d/rpmforge.list from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/RPM-GPG-KEY-rpmforge-dag from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-fabian from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/RPM-GPG-KEY-rpmforge-fabian from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/smart/channels/rpmforge.channel from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/sysconfig/rhn/sources.rpmforge.txt from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/mirrors-rpmforge from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/mirrors-rpmforge-extras from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/mirrors-rpmforge-testing from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/rpmforge.repo from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/mirrors-rpmforge.yum from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.apt from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.smart from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.up2date from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.yum from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386


and i have done the following steps,

1) [root@binary yum.repos.d]# rm -f *
[root@binary yum.repos.d]# ls
[root@binary yum.repos.d]#


2) [root@binary sources.list.d]# rm -f *
[root@binary sources.list.d]# ls
[root@binary sources.list.d]#

3) [root@binary rpm-gpg]# rm -f *
[root@binary rpm-gpg]# ls
[root@binary rpm-gpg]#

4) [root@binary rpmforge-release-0.5.2]# rm -f *
[root@binary rpmforge-release-0.5.2]# ls
[root@binary rpmforge-release-0.5.2]#

5) [root@binary channels]# rm -f *
[root@binary channels]# ls
[root@binary channels]#

6) [root@binary rhn]# rm -f *
[root@binary rhn]# ls
[root@binary rhn]#

after,

file /etc/apt/sources.list.d/rpmforge-extras.list from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/apt/sources.list.d/rpmforge-testing.list from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/apt/sources.list.d/rpmforge.list from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/RPM-GPG-KEY-rpmforge-dag from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-fabian from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/RPM-GPG-KEY-rpmforge-fabian from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/smart/channels/rpmforge.channel from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/sysconfig/rhn/sources.rpmforge.txt from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/mirrors-rpmforge from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/mirrors-rpmforge-extras from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/mirrors-rpmforge-testing from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /etc/yum.repos.d/rpmforge.repo from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/mirrors-rpmforge.yum from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.apt from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.smart from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.up2date from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386
file /usr/share/doc/rpmforge-release-0.5.2/rpmforge.yum from install of rpmforge-release-0.5.2-2.el6.rf.i686 conflicts with file from package rpmforge-release-0.5.2-2.el5.rf.i386


so i was not able to install vlc on my machine and did i remove important file so i will get other problem except installing vlc
 
Old 02-01-2012, 04:31 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,112

Rep: Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591
remove the repo for cent 5

Quote:

and i have done the following steps,

1) [root@binary yum.repos.d]# rm -f *
[root@binary yum.repos.d]# ls
[root@binary yum.repos.d]#
--- and the rest ---
WHY ????

at this point it is most likely easier for you to start over
reformat and reintall


all you had to do in the first place was uninstall the cent5 rpmforge repo

did you read the "help" options for rpm?
Code:
rpm --help
" -e, --erase=<package>+ erase (uninstall) package"
or you could have used
" --replacefiles "

Last edited by John VV; 02-01-2012 at 04:36 PM.
 
Old 02-03-2012, 11:47 AM   #8
paruhang
Member
 
Registered: Aug 2011
Location: /home
Posts: 96

Original Poster
Rep: Reputation: Disabled
hellow everybody,
thank you every one for giving me an idea about installing vlc player. finally i format and reinstall centos and able to install by downloading rpmforge-release-0.5.2-2.el6.rf.i686.rpm on my machine and install vlc and mplayer.


so i have one more questions,

i have install centos on my friend machine and can install creating local repo previously i used RHEL6 i know how to create and install but the problem is where can i fine .rpm files in my machine i have already installed of vlc..?

any kinds of ideas are accepted and thankx in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install vlc media player on centos 5 hasa44 Linux - Software 9 01-08-2013 12:28 PM
[SOLVED] Install VLC Player Easily on RHEL/CentOS 5.x Using Script networking.dept Red Hat 2 02-16-2011 05:43 PM
Unable to install VLC Media player on FC3 vikram_cvk Linux - Software 11 12-01-2007 12:43 AM
Unable to install wmp11 skin VLC player me4linux Linux - Software 10 08-07-2007 11:18 AM
Unable to install VLC media player hokckey Linux - Software 2 05-09-2006 11:10 AM


All times are GMT -5. The time now is 07:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration