LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2014, 02:44 PM   #1
Phil569
LQ Newbie
 
Registered: Jul 2014
Location: New Hampshire
Distribution: Ubuntu 12
Posts: 6

Rep: Reputation: Disabled
Unable to install R


I have a relatively clean install of Precise on a VM VirtualBox and am attempting to install R and RStudio and have not had much luck. I think I have followed all the update and upgrade steps but am missing dependencies. I have added the marutter/rfdev repository apparently successfully.
Not sure where to go from here.
 
Old 07-31-2014, 03:08 PM   #2
notKlaatu
Senior Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 1,007

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
Can you detail what steps exactly you have taken to install it?
 
Old 07-31-2014, 07:47 PM   #3
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: LinuxMint
Posts: 775

Rep: Reputation: 199Reputation: 199
Have you checked the software center? I know R is showing in 14.04, under Science and Engineering section.
 
1 members found this post helpful.
Old 08-02-2014, 09:41 PM   #4
Phil569
LQ Newbie
 
Registered: Jul 2014
Location: New Hampshire
Distribution: Ubuntu 12
Posts: 6

Original Poster
Rep: Reputation: Disabled
For my present setup, I have to run 12.10. I can see the package in the software center but it won't go into the basket for installation.
 
Old 08-03-2014, 05:06 AM   #5
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: LinuxMint
Posts: 775

Rep: Reputation: 199Reputation: 199
Quote:
Originally Posted by Phil569 View Post
For my present setup, I have to run 12.10. I can see the package in the software center but it won't go into the basket for installation.
If you truly are running 12.10 that is an issue as it is dead and unsupported at this time. In the first post you said "Precise" which is 12.04 LTS which is still okay. So, are you on 12.04 or 12.10?
 
Old 08-03-2014, 05:53 AM   #6
Phil569
LQ Newbie
 
Registered: Jul 2014
Location: New Hampshire
Distribution: Ubuntu 12
Posts: 6

Original Poster
Rep: Reputation: Disabled
I appear to be on 12.10. The CRAN sources available have 'precise' as the source for R and I used that. Is this that delicate a process that there is a fatal flaw in 12.10 but not in 12.04?
 
Old 08-03-2014, 06:25 AM   #7
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: LinuxMint
Posts: 775

Rep: Reputation: 199Reputation: 199
12.10 is unsupported so no repositories for software. Support for 12.10 was dropped May 16, 2014 (see this link).

I would install 14.04 LTS version if I were you. As you can see from the link previously, it would be supported until April 2019. Option 2 is reinstall 12.04 which is covered until 2017. I would do option 2 if I had older hardware that is unsupported on 14.04.

I noticed you made a comment "for my present setup....". Is there a hardware issue? I see where you are running it on virtualbox, why not download and install 14.04?

Last edited by jkirchner; 08-03-2014 at 11:46 AM.
 
Old 08-03-2014, 12:43 PM   #8
Phil569
LQ Newbie
 
Registered: Jul 2014
Location: New Hampshire
Distribution: Ubuntu 12
Posts: 6

Original Poster
Rep: Reputation: Disabled
Installing 12.04 did the job. That seems to be a theme with Ubuntu - delete and reinstall.
 
Old 08-03-2014, 01:52 PM   #9
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: LinuxMint
Posts: 775

Rep: Reputation: 199Reputation: 199
Well to be fair, 12.10 is no longer supported whereas the 12.04LTS version is until 2017.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Unable to install Linux(Centos) on virtual machine using virt-install --prompt shazgaurav Linux - Newbie 9 12-15-2013 11:41 AM
install unubtu 12.04 show"unable to install grub in /dev/mapper. my patition tomli21228 Linux - Server 2 09-20-2012 01:45 PM
Unable to complete install 'exceptions.RuntimeError Invalid install location jimmyjiang Red Hat 1 10-21-2008 11:32 AM
Unable to install virtual server from NFS mounted install media fwdann Linux - Newbie 1 05-07-2008 07:10 PM
Error: Unable to boot /install/2.6/linux when starting Etch Install BuckRogers01 Debian 4 08-06-2005 06:40 PM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration