LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-21-2013, 05:31 AM   #1
Arun Kurian
LQ Newbie
 
Registered: Oct 2013
Posts: 23

Rep: Reputation: Disabled
Unable to install php5-dev


Hi,

Got the below error while installing php5-dev in my ubuntu 10.04.

root@aaaa:/usr/local/src# apt-get install php5-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-dev: Depends: libssl-dev but it is not going to be installed
E: Broken packages

I have tried to install libssl-dev

root@aaaa:/usr/local/src# apt-get install libssl-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.15) but 0.9.8o-4squeeze13 is to be installed
E: Broken packages



I have upgraded apt-get and getting the below notifications :

root@aaaa:/usr/local/src# php -v
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/gd.so' - /usr/lib/php5/20090626/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mcrypt.so' - /usr/lib/php5/20090626/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mysql.so' - /usr/lib/php5/20090626/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mysqli.so' - /usr/lib/php5/20090626/mysqli.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/pdo_mysql.so' - /usr/lib/php5/20090626/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.3.2-1ubuntu4.21 with Suhosin-Patch (cli) (built: Sep 4 2013 19:13:13)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

Kindly advise.
 
Old 11-21-2013, 11:49 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
I assume your release is Ubuntu 10.04 LTS. Is that correct?
Quote:
The following packages have unmet dependencies:
libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.15) but 0.9.8o-4squeeze13 is to be installed
Is it normal to use Debian packages for Ubuntu?

Quote:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/gd.so' - /usr/lib/php5/20090626/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0
Quote:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mcrypt.so' - /usr/lib/php5/20090626/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0
You need to install php5-dbg
Quote:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mysql.so' - /usr/lib/php5/20090626/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0
You need to install php5-myslql
and so on ....
jdk
 
Old 11-21-2013, 12:11 PM   #3
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,156

Rep: Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159
Suspect your sources.list is messed up (the reference to "squeeze" is deeply disturbing), can you post the output of

Code:
apt-get update
 
Old 11-30-2013, 09:24 AM   #4
Arun Kurian
LQ Newbie
 
Registered: Oct 2013
Posts: 23

Original Poster
Rep: Reputation: Disabled
Lightbulb

Thanks for all the tips

I tried by using aptitude and it worked..
 
  


Reply

Tags
php, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install unubtu 12.04 show"unable to install grub in /dev/mapper. my patition tomli21228 Linux - Server 2 09-20-2012 01:45 PM
unable to install php5 using apt nkd Ubuntu 2 01-02-2012 03:03 AM
unable to install php5 - configure: error: libjpeg.(a|so) not found. vikram_cvk Linux - Software 6 11-01-2009 08:00 AM
"unable to find device node for /dev/x in /dev!" during install zombiedeth *BSD 0 02-02-2004 02:38 AM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration