LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2009, 01:37 PM   #1
arunlfc
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Rep: Reputation: 15
Unhappy Unable to install flash plugin


Hi all.
I've been desperately trying to install flash plugin but i'm having 'unmet dependencies' problem with apt-get.
I'm using debian etch.
Here's what i'm getting:

Code:
ArunDebianEtch:/home/arun# apt-get install flash-plugin
Reading package lists... Done
Building dependency tree... Done
flash-plugin is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  flash-plugin: Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch8 is to be installed
                Depends: libfreetype6 (>= 2.3.5) but 2.2.1-5+etch3 is to be installed
                Depends: libglib2.0-0 (>= 2.14.0) but 2.12.4-2 is to be installed
  libgtk2.0-0: Depends: libatk1.0-0 (>= 1.20.0) but 1.12.4-3 is to be installed
               Depends: libc6 (>= 2.7-1) but 2.3.6.ds1-13etch8 is to be installed
               Depends: libcairo2 (>= 1.6.4-6.1) but 1.2.4-4.1+etch1 is to be installed
               Depends: libcups2 (>= 1.3.8) but it is not installable
               Depends: libglib2.0-0 (>= 2.16.0) but 2.12.4-2 is to be installed
               Depends: libgnutls26 (>= 2.4.0-0) but it is not installable
               Depends: libkrb53 (>= 1.6.dfsg.2) but 1.4.4-7etch6 is to be installed
               Depends: libpango1.0-0 (>= 1.20.3) but 1.14.8-5 is to be installed
               Depends: libxdamage1 (>= 1:1.1) but 1:1.0.3-3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
I tried what it says (use the -f install) but it asks to remove some important programs like kde, iceweasel, so i didn't proceed.
Anyone could help??
 
Old 05-19-2009, 01:43 PM   #2
robogymnast
Member
 
Registered: Dec 2005
Location: Boston, USA
Distribution: Kubuntu, Debian
Posts: 78

Rep: Reputation: 16
Have you tried running "sudo apt-get update"?
 
Old 05-19-2009, 01:47 PM   #3
Ledfeather
LQ Newbie
 
Registered: May 2009
Location: Portland, OR
Distribution: Ubuntu 14.04
Posts: 18

Rep: Reputation: 0
have you tried to go through the add/remove frontend? you can just type in flash, and find browser plugins and other stuff related to flash. worked for me.
 
Old 05-19-2009, 02:04 PM   #4
arunlfc
LQ Newbie
 
Registered: Jan 2009
Posts: 21

Original Poster
Rep: Reputation: 15
yeah i updated the packages' list before installing, but no successful result!
At first i thought maybe i got the wrong repositories, so i included a whole lot of repos that i found on the net in the sources.list file...but again no success!
I suppose apt-get can resolve dependencies automatically, right? It doesn't seem to work for me!
 
Old 05-19-2009, 02:08 PM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
try

Code:
apt-get install flashplugin-nonfree adobe-flashplugin
 
Old 05-19-2009, 02:13 PM   #6
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
you could upgrade to lenny.

if you don`t want that and if you didn`t allready did the following:
comment everything you added to your sources.list
so it looks somehow like this:
Code:
#MAIN
deb http://ftp.de.debian.org/debian etch main
deb-src http://ftp.de.debian.org/debian etch main

#MULTIMEDIA
deb http://www.debian-multimedia.org/ etch main

#SECURITY
deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main

# VOLATILE
deb http://volatile.debian.org/debian-volatile etch/volatile main
deb-src http://volatile.debian.org/debian-volatile etch/volatile main

# YOUR added repos
# http://XXX.blahxx/***
# http://example.two/***
then run the following as root, best might be all browsers are closed:
Code:
apt-get update
apt-get install debian-mutlimedia-keyring
apt-get update
apt-get install flashplayer-mozilla
i hope this might help you, good luck.

Last edited by j1alu; 05-19-2009 at 02:17 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install flash plugin Murtagh Linux - Desktop 2 12-26-2006 10:21 PM
Can't install flash plugin Dan63043 Debian 6 05-29-2006 04:27 AM
how to install macromedia flash plugin skie_knite007 Linux - Software 4 03-17-2005 04:58 PM
flash plugin won't install Zaius Linux - Newbie 6 01-14-2004 03:56 PM
cant install FLASH plugin UKMan Linux - Newbie 6 06-09-2003 04:50 AM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration