LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2011, 02:38 PM   #1
dann_radkov
Member
 
Registered: Sep 2011
Posts: 52

Rep: Reputation: Disabled
unable to install driver / launch device for wireless usb Dlink 140 into Slackware 13


Hey Folks,
I just installed the driver for my d-link wireless dwa140 usb adapter/receiver on my Linux slackware 13.0.0.0.0.Kernel is 2.6.My router is 1 room away so I decided to keep it simple and use a wifi. I found instructions and all the stuff i needed here :
ftp://ftp.dlinkla.com/pub/drivers/DWA-140/
and
ftp://ftp.dlinkla.com/pub/drivers/DW..._For_LINUX.pdf


So far so good.Every bit of code went fine.I rebooted the system and I can see that the device is now flashing.However I cannot see anything in the wicd manager. I dont see any wireless conns.Note that this is a brand new install.I havent installed anything on this linux box so far.Just a clean 5 gig install of Slackware.
I tried to use an add-hoc but this assigns whatever ip i use to the ifconfig eth1 and is not valid.

P.S. After a couple of reboots the usb stopped flashing so I guess the module needs to be reinserted or something.

Last edited by dann_radkov; 11-17-2011 at 02:41 PM.
 
Old 11-17-2011, 06:50 PM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,143

Rep: Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503
Here is the best set of instructions I have seen for getting wireless working on Slackware.

-->http://alien.slackbook.org/dokuwiki/...ckware:network

About half way down you will see a section on wireless networking, with examples of how to configure an adapter. I got an older wireless adapter to work by following this. If I can remember, WICD works after you get the adapter named to wlan0. As long as its eth(n) it will not be seen by WICD.

Hope this helps.
 
1 members found this post helpful.
Old 11-18-2011, 04:06 AM   #3
dann_radkov
Member
 
Registered: Sep 2011
Posts: 52

Original Poster
Rep: Reputation: Disabled
Tried your instructions and they didnt seem to work.Wicd doesnt see my interface that i defined in rc.inet1.conf via IFNAME which i set to wlan0.I checked everything twice.Reset the services:
/etc/rc.d/rc.inet1
/etc/rc.d/rc.inet1 restart
Changed interface in wicd to be vwan0 and it is.
Reinserted ko file again via insmod and rebooted.Nothing.In the guide here:
ftp://ftp.dlinkla.com/pub/drivers/DW..._For_LINUX.pdf where it says :
Copy RT2870STA.dat to the directory /etc/Wireless/RT2870STA

I dont see any etc/Wireless directory.I created one myself.Is there an equivalent under Slackware?

Last edited by dann_radkov; 11-18-2011 at 11:52 AM.
 
Old 11-19-2011, 02:55 AM   #4
dann_radkov
Member
 
Registered: Sep 2011
Posts: 52

Original Poster
Rep: Reputation: Disabled
I cant believe it take such an effort to install & trigger drivers for this distro.I have to say I am disappointed.
 
Old 11-19-2011, 04:35 AM   #5
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 375

Rep: Reputation: 77
Here's a couple things to try.

Run command: lsmod
A long list of modules loaded to the kernel will be printed in the terminal, if you see rt2870sta.ko in the list, then your driver is good to go. If not, then it was not compiled. By rights, the make command should have made sure it get's loaded upon a reboot automatically if an applicable device is found, if you get no errors when issueing the insmod command, this also would indicate there is nothing wrong with the driver.
Next, with the USB adapter pluggend in, run command as root or sudo: ifconfig to see the name of the device, in the example below, mine is eth1.
Next, run command: iwconfig to determine which device is the wireless device.
Next, run command: iwlist devicename scan to see if it works, if your ap shows up as in the example below (Tbone), then there is no driver issue. Replace 'devicename' in the iwlist command with your device's name as found in the iwconfig command.
If all seems OK to this point, you probably just need to go through Wicd's settings to specify which device is the wireless device. Last I remember, unlike network-manager which does this automatically, in Wicd, you need to specify the device in settings by actually typing it in the proper field. This would be the device name as found by the iwconfig and iwlist commands.
Code:
root@Willy:/home/jo# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:11:43:78:46:01  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18 

eth1      Link encap:Ethernet  HWaddr 00:13:ce:1b:7b:d6  
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::213:ceff:fe1b:7bd6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5482 (5.3 KiB)  TX bytes:9263 (9.0 KiB)
          Interrupt:17 Base address:0x4000 Memory:dcfef000-dcfeffff 
                                                                                                                                                                                              
lo        Link encap:Local Loopback                                                                                                                                                           
          inet addr:127.0.0.1  Mask:255.0.0.0                                                                                                                                                 
          inet6 addr: ::1/128 Scope:Host                                                                                                                                                      
          UP LOOPBACK RUNNING  MTU:16436  Metric:1                                                                                                                                            
          RX packets:84 errors:0 dropped:0 overruns:0 frame:0                                                                                                                                 
          TX packets:84 errors:0 dropped:0 overruns:0 carrier:0                                                                                                                               
          collisions:0 txqueuelen:0                                                                                                                                                           
          RX bytes:6072 (5.9 KiB)  TX bytes:6072 (5.9 KiB)                                                                                                                                    
                                                                                                                                                                                              
root@Willy:/home/jo# iwconfig                                                                                                                                                                 
lo        no wireless extensions.                                                                                                                                                             
                                                                                                                                                                                              
eth0      no wireless extensions.                                                                                                                                                             
                                                                                                                                                                                              
eth1      IEEE 802.11bg  ESSID:"Tbone"                                                                                                                                                        
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:23:69:EA:35:6F                                                                                                                  
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0                                                                                                                                
          Retry limit:7   RTS thr:off   Fragment thr:off                                                                                                                                      
          Encryption key:4974-15D0-DEA4-1E88-C9BC-A211-D396-5FAD   Security mode:open                                                                                                         
          Power Management:off                                                                                                                                                                
          Link Quality=0/100  Signal level=-27 dBm  Noise level=-84 dBm                                                                                                                       
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0                                                                                                                            
          Tx excessive retries:0  Invalid misc:0   Missed beacon:97                                                                                                                           
                                                                                                                                                                                              
root@Willy:/home/jo# iwlist eth1 scan
eth1      Scan completed :                                                                                                                                                                    
          Cell 01 - Address: 00:23:69:EA:35:6F                                                                                                                                                
                    ESSID:"Tbone"                                                                                                                                                             
                    Protocol:IEEE 802.11bg                                                                                                                                                    
                    Mode:Master                                                                                                                                                               
                    Frequency:2.437 GHz (Channel 6)                                                                                                                                           
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=94/100  Signal level=-27 dBm  
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    Extra: Last beacon: 12ms ago

root@Willy:/home/jo#
EDIT: It is possible you may need to undo some of the changes you were recommended in post number two if things are not going well.

Last edited by Brains; 11-19-2011 at 04:45 AM.
 
1 members found this post helpful.
Old 11-21-2011, 03:22 AM   #6
dann_radkov
Member
 
Registered: Sep 2011
Posts: 52

Original Poster
Rep: Reputation: Disabled
Run command: lsmod :
This didnt display any information about my module whatsoever.Going back to step one to find out why it doesnt "make" the module.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is it that wicd has issues connecting to new AP's after sleeping? chrisportela Linux - Networking 3 07-08-2011 09:10 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
why is wicd not fully connecting? tonye Gentoo 3 12-01-2009 11:25 PM
Has Anyone Managed To Do This? ~zoey~ Linux - Newbie 14 10-03-2004 03:21 PM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration