LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-08-2016, 12:25 AM   #1
sysmicuser
Member
 
Registered: Mar 2010
Posts: 334

Rep: Reputation: 0
Unhappy Unable to install apache web server(httpd) on RHEL 6.5


Yesterday I was giving an amazon test and I was presented with a Unix Server (RHEL 6.5) and task was to install apache Web Server !

What interesting is whatever commands I did run they was no way to install it !

Code:
sudo yum install httpd -y
Loaded plugins: amazon-id, rhui-lb, security
Setting up Install Process
No package httpd available.
Code:
sudo yum install httpd*
Loaded plugins: amazon-id, rhui-lb, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package httpd-itk.x86_64 0:2.2.22-7.el6 will be installed
--> Processing Dependency: httpd >= 2.2 for package: httpd-itk-2.2.22-7.el6.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-itk-2.2.22-7.el6.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-itk-2.2.22-7.el6.x86_64
--> Finished Dependency Resolution
Error: Package: httpd-itk-2.2.22-7.el6.x86_64 (epel)
           Requires: httpd >= 2.2
Error: Package: httpd-itk-2.2.22-7.el6.x86_64 (epel)
           Requires: libapr-1.so.0()(64bit)
Error: Package: httpd-itk-2.2.22-7.el6.x86_64 (epel)
           Requires: libaprutil-1.so.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Code:
$ sudo rpm -Va --nofiles --nodigest
sudo yum install httpd*
Loaded plugins: amazon-id, rhui-lb, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package httpd-itk.x86_64 0:2.2.22-7.el6 will be installed
--> Processing Dependency: httpd >= 2.2 for package: httpd-itk-2.2.22-7.el6.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-itk-2.2.22-7.el6.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-itk-2.2.22-7.el6.x86_64
--> Finished Dependency Resolution
Error: Package: httpd-itk-2.2.22-7.el6.x86_64 (epel)
           Requires: httpd >= 2.2
Error: Package: httpd-itk-2.2.22-7.el6.x86_64 (epel)
           Requires: libapr-1.so.0()(64bit)
Error: Package: httpd-itk-2.2.22-7.el6.x86_64 (epel)
           Requires: libaprutil-1.so.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
$ sudo yum install httpd* --skip-broken
Loaded plugins: amazon-id, rhui-lb, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package httpd-itk.x86_64 0:2.2.22-7.el6 will be installed
--> Processing Dependency: httpd >= 2.2 for package: httpd-itk-2.2.22-7.el6.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-itk-2.2.22-7.el6.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-itk-2.2.22-7.el6.x86_64

Packages skipped because of dependency problems:
    httpd-itk-2.2.22-7.el6.x86_64 from epel
$

Code:
cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.5 (Santiago)
$

I looked further in yum.conf to see if httpd is excluded  but nope

$ cat /etc/yum.conf
[main]
cachedir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=3

#  This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
#  It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
proxy=http://10.0.100.20:8888
Code:
 ls /etc/yum.repos.d/
epel.repo  epel-testing.repo  redhat-rhui-client-config.repo  redhat-rhui.repo  rhel-source.repo  rhui-load-balancers.conf  scl.repo
$ cat /etc/yum.repos.d/rhel-source.repo
[rhel-source]
name=Red Hat Enterprise Linux $releasever - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/SRPMS/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

[rhel-source-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/beta/$releasever/en/os/SRPMS/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release
Last but not least, I did try

Code:
sudo yum --disableexcludes=all install httpd
Still no charm, I have no idea what is the issue for me not to be able to install httpd !!

Please assist me Thanks.

Last edited by sysmicuser; 08-08-2016 at 12:26 AM.
 
Old 08-08-2016, 02:45 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,258

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
You don't want 'source'; that's usually src ode.
Check
Code:
yum repolist
you may find relevant repo (prob redhat-rhui.repo ) is not marked enabled.
 
1 members found this post helpful.
Old 08-08-2016, 03:47 AM   #3
sysmicuser
Member
 
Registered: Mar 2010
Posts: 334

Original Poster
Rep: Reputation: 0
Thanks @chrism01.
Might be a silly question but how would I check if the
Quote:
you may find relevant repo (prob redhat-rhui.repo ) is not marked enabled.
?
 
Old 08-08-2016, 04:51 AM   #4
sysmicuser
Member
 
Registered: Mar 2010
Posts: 334

Original Poster
Rep: Reputation: 0
Yep, enabled=(from 0) is the key. RHEL 6 base packages were not enabled !!! Thanks chrism01
 
Old 08-09-2016, 01:25 AM   #5
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,258

Rep: Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328Reputation: 2328
nw

BTW if you use other repos as well as base RHEL, install / setup https://wiki.centos.org/PackageManag...Yum/Priorities otherwise you can get repos overwriting pkgs that are not compatible.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Please suggest how to Install Apache Httpd server on RHEL 6 in easy steps. dheeraj_pr10 Linux - Desktop 6 04-09-2013 03:14 AM
Unable to access web server from the computer running apache brunoschwartz Linux - Networking 7 08-05-2010 05:55 PM
Unable to Import SSL to Apache Web Server carlosinfl Linux - Server 5 09-15-2008 11:49 AM
Unable to access to a website on apache web server bisbane Linux - Networking 3 07-11-2001 10:18 AM
Unable to access to a website on apache web server bisbane General 3 07-10-2001 12:03 PM


All times are GMT -5. The time now is 01:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration